Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0039805
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 09. Financial managementmajoralways2018-12-14 12:102018-12-26 19:20
ReporteranderarangurenView Statuspublic 
Assigned ToAtulOpenbravo 
PrioritynormalResolutionfixedFixed in Version3.0PR19Q1
StatusclosedFix in branchFixed in SCM revision0dc6820e006c
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned ToSandrahuguet
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0039805: Cannot add new record in Modify Payment Plan from Purchase Invoice window when Total Outstanding field is not shown in grid

DescriptionCannot add new record in Modify Payment Plan from Purchase Invoice window when Total Outstanding field is not shown in grid view
Steps To Reproduce-Display Modify Payment Plan button from Purchase Invoice in Window,tabs and fields as System admin.
-And uncheck Show in Grid View of Total Outstanding field from Purchase Invoice header.
-Go to Purchase Invoice window select a record and pres Modify Payment Plan
-Try to Add New record and realize that nothing happens and an error is showing in the console.
TagsNo tags attached.
Attached Filespng file icon ModifyPaymentPlanAddNew.png [^] (248,453 bytes) 2018-12-14 12:10

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0108659)
AtulOpenbravo (developer)
2018-12-18 06:39
edited on: 2018-12-19 18:54

Test Plan
- Login as System admin.
- Display Modify Payment Plan button from Purchase Invoice/Payment Plan tab in Window,tabs and fields
- Uncheck Show in Grid View of Total Outstanding field from Purchase Invoice header.

- Go to Purchase Invoice window select a record (which is completed and is not yet paid).

- Go to Payment Plan window and select record and click Modify Payment Plan.
- Try to Add New record and realize that new record is created.

- Cancel new record, click on Paid Amount field in grid record. Check that no error is found in browser console. Prior to this fix error was shown Uncaught BigDecimal(), Not a Number, undefined.

(0108681)
hgbot (developer)
2018-12-20 09:04

Repository: erp/devel/pi
Changeset: 0dc6820e006cc871aa1ed521625dca27c22bc85c
Author: Atul Gaware <atul.gaware <at> openbravo.com>
Date: Tue Dec 18 10:48:18 2018 +0530
URL: http://code.openbravo.com/erp/devel/pi/rev/0dc6820e006cc871aa1ed521625dca27c22bc85c [^]

Fixes Issue 39805:Cannot add new record in Modify Payment Plan
from Purchase Invoice window when Total Outstanding field is
not shown in grid

** get value for outstanding amount from parent window's active
view context information.

---
M modules/org.openbravo.advpaymentmngt/web/org.openbravo.advpaymentmngt/js/ob-aprm-utilities.js
---
(0108682)
Sandrahuguet (developer)
2018-12-20 09:05

Code review + testing OK
(0108708)
hudsonbot (developer)
2018-12-20 21:30

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/32784e66f6df [^]
Maturity status: Test
(0108740)
Sandrahuguet (developer)
2018-12-26 13:37

reopened because fix is not working using in Format.xml decimal separator ","
(0108745)
hgbot (developer)
2018-12-26 15:04

Repository: erp/devel/pi
Changeset: 068b3a6490439ec19196232fe127e0d1fe531e1e
Author: Sandra Huguet <sandra.huguet <at> openbravo.com>
Date: Wed Dec 26 13:40:46 2018 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/068b3a6490439ec19196232fe127e0d1fe531e1e [^]

related to issue 39805 set proper parameters in getContextInfo

set proper parameters in getContextInfo, because it use to do operations.

---
M modules/org.openbravo.advpaymentmngt/web/org.openbravo.advpaymentmngt/js/ob-aprm-utilities.js
---
(0108746)
Sandrahuguet (developer)
2018-12-26 15:06

Code review + testing ok
(0108757)
hudsonbot (developer)
2018-12-26 19:20

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/669070b8a1eb [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2018-12-14 12:10 anderaranguren New Issue
2018-12-14 12:10 anderaranguren Assigned To => Triage Finance
2018-12-14 12:10 anderaranguren File Added: ModifyPaymentPlanAddNew.png
2018-12-14 12:10 anderaranguren Modules => Core
2018-12-14 12:10 anderaranguren Triggers an Emergency Pack => No
2018-12-14 13:27 Sandrahuguet Assigned To Triage Finance => AtulOpenbravo
2018-12-18 05:09 AtulOpenbravo Status new => scheduled
2018-12-18 06:39 AtulOpenbravo Note Added: 0108659
2018-12-19 16:49 jfrances Issue Monitored: jfrances
2018-12-19 18:54 Sandrahuguet Note Edited: 0108659 View Revisions
2018-12-20 09:04 hgbot Checkin
2018-12-20 09:04 hgbot Note Added: 0108681
2018-12-20 09:04 hgbot Status scheduled => resolved
2018-12-20 09:04 hgbot Resolution open => fixed
2018-12-20 09:04 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/0dc6820e006cc871aa1ed521625dca27c22bc85c [^]
2018-12-20 09:05 Sandrahuguet Review Assigned To => Sandrahuguet
2018-12-20 09:05 Sandrahuguet Note Added: 0108682
2018-12-20 09:05 Sandrahuguet Status resolved => closed
2018-12-20 09:05 Sandrahuguet Fixed in Version => 3.0PR19Q1
2018-12-20 21:30 hudsonbot Checkin
2018-12-20 21:30 hudsonbot Note Added: 0108708
2018-12-26 13:37 Sandrahuguet Note Added: 0108740
2018-12-26 13:37 Sandrahuguet Status closed => new
2018-12-26 13:37 Sandrahuguet Resolution fixed => open
2018-12-26 13:37 Sandrahuguet Fixed in Version 3.0PR19Q1 =>
2018-12-26 15:04 hgbot Checkin
2018-12-26 15:04 hgbot Note Added: 0108745
2018-12-26 15:06 Sandrahuguet Status new => scheduled
2018-12-26 15:06 Sandrahuguet Status scheduled => resolved
2018-12-26 15:06 Sandrahuguet Resolution open => fixed
2018-12-26 15:06 Sandrahuguet Note Added: 0108746
2018-12-26 15:06 Sandrahuguet Status resolved => closed
2018-12-26 15:06 Sandrahuguet Fixed in Version => 3.0PR19Q1
2018-12-26 19:20 hudsonbot Checkin
2018-12-26 19:20 hudsonbot Note Added: 0108757


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker