Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0039647
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSminoralways2018-11-19 18:202018-12-07 11:59
ReporteranderarangurenView Statuspublic 
Assigned Torqueralta 
PriorityimmediateResolutionfixedFixed in VersionRR19Q1
StatusclosedFix in branchFixed in SCM revisionf56218344703
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned Tojorge-garcia
Regression level
Regression date2017-02-20
Regression introduced in releaseRR17Q2
Regression introduced by commithttps://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/ef736becd65aa38498f8d692ae148f6f1a791b95 [^]
Triggers an Emergency PackNo
Summary

0039647: It is not possible to edit the style of the modal-dialog popups because is overwritten with the default value

DescriptionIt is not possible to edit the style of the modal-dialog popups because is overwritten with the default value this.setStyle('display: initial');
Steps To ReproduceN/A
Proposed SolutionIn ob-commonbutons.js change the line:
 this.setStyle('display: initial');
for
 this.setStyle(this.getStyle() + '; display: initial;');
And in ob-utilitiesui.js change the line:
 popup.setStyle('display:initial');
for
 popup.setStyle(popup.getStyle() + '; display: initial;');
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0108007)
anderaranguren (developer)
2018-11-20 11:16

Regression introduced through above commit and also through this one:
https://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/880de1b8a8c0 [^]
(0108076)
hgbot (developer)
2018-11-23 12:32

Repository: erp/pmods/org.openbravo.mobile.core
Changeset: 9290b7102356f9bb9eec73014c3b5f305a42224f
Author: Rafael Queralta <rafaelcuba81 <at> gmail.com>
Date: Wed Nov 21 15:09:55 2018 -0500
URL: http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/9290b7102356f9bb9eec73014c3b5f305a42224f [^]

Fixed issue 39647: It is not possible to edit the style of the
modal-dialog popups because is overwritten with the default value

- Avoided to be overwritten the modal-dialog popups style

---
M web/org.openbravo.mobile.core/source/component/ob-commonbuttons.js
M web/org.openbravo.mobile.core/source/utils/ob-utilitiesui.js
---
(0108105)
jorge-garcia (developer)
2018-11-26 15:05

The solution applied is not working following these steps:

1) Login in webPOS
2) Execute this code in developers tools:
   "OB.UTIL.showConfirmation.display('Confirm', 'This is a confirmation popup with an orange background', null, {style: 'background-color: #EBA001'});"
3) An orange popup is shown
4) Execute this code in developers tools:
   "OB.UTIL.showLoading(true);"
5) The Loading view is showm
6) Execute this code in developers tools:
   "OB.UTIL.showLoading(false);"
7) The popup is shown again, but the background color is green (this is wrong)
(0108145)
hgbot (developer)
2018-11-28 13:05

Repository: erp/pmods/org.openbravo.mobile.core
Changeset: 7c2359e9ae46d715556b0239bae72c8a3208535f
Author: Rafael Queralta <rafaelcuba81 <at> gmail.com>
Date: Mon Nov 26 12:24:27 2018 -0500
URL: http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/7c2359e9ae46d715556b0239bae72c8a3208535f [^]

Fixed issue 39647: It is not possible to edit the style of the
modal-dialog popups because is overwritten with the default value

- Avoided to be overwritten the modal-dialog popups style before hide popup

---
M web/org.openbravo.mobile.core/source/component/ob-commonbuttons.js
M web/org.openbravo.mobile.core/source/utils/ob-utilitiesui.js
---
(0108146)
hgbot (developer)
2018-11-28 13:06

Repository: tools/automation/pi-mobile
Changeset: fbdafcd6f5528e9f41368111cd068e80ac39ed46
Author: Rafael Queralta <rafaelcuba81 <at> gmail.com>
Date: Tue Nov 27 10:49:35 2018 -0500
URL: http://code.openbravo.com/tools/automation/pi-mobile/rev/fbdafcd6f5528e9f41368111cd068e80ac39ed46 [^]

Related to issue 39647: It is not possible to edit the style of the
modal-dialog popups because is overwritten with the default value

- Changed script executed, to search a substring into style string.

---
M src-test/org/openbravo/test/mobile/retail/pack/selenium/tests/system/I35170_HideOpenedPopupOnShowLoading.java
---
(0108250)
marvintm (developer)
2018-12-04 13:58

After latest changes the showLoading calls that Jorge mentioned in his comments are not working correctly, the showLoading window including the scrim should appear over the popup, and the scrim part is not appearing correctly
(0108260)
hgbot (developer)
2018-12-04 21:57

Repository: erp/pmods/org.openbravo.mobile.core
Changeset: f56218344703afcb8bb7811049e0dfe0b69239b3
Author: Rafael Queralta <rafaelcuba81 <at> gmail.com>
Date: Tue Dec 04 11:36:36 2018 -0500
URL: http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/f56218344703afcb8bb7811049e0dfe0b69239b3 [^]

Fixed issue 39647: It is not possible to edit the style of the
modal-dialog popups because is overwritten with the default value

- Avoided to be overwritten the modal-dialog popups style before hide popup

---
M web/org.openbravo.mobile.core/source/utils/ob-utilitiesui.js
---

- Issue History
Date Modified Username Field Change
2018-11-19 18:20 anderaranguren New Issue
2018-11-19 18:20 anderaranguren Assigned To => Retail
2018-11-19 18:20 anderaranguren Regression date => 2017-02-20
2018-11-19 18:20 anderaranguren Regression introduced in release => RR17Q2
2018-11-19 18:20 anderaranguren Regression introduced by commit => https://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/ef736becd65aa38498f8d692ae148f6f1a791b95 [^]
2018-11-19 18:20 anderaranguren Triggers an Emergency Pack => No
2018-11-20 11:16 anderaranguren Note Added: 0108007
2018-11-20 11:16 anderaranguren Proposed Solution updated
2018-11-20 11:31 jfrances Issue Monitored: jfrances
2018-11-21 20:55 rqueralta Assigned To Retail => rqueralta
2018-11-21 20:58 rqueralta Status new => scheduled
2018-11-23 12:32 hgbot Checkin
2018-11-23 12:32 hgbot Note Added: 0108076
2018-11-23 12:32 hgbot Status scheduled => resolved
2018-11-23 12:32 hgbot Resolution open => fixed
2018-11-23 12:32 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/9290b7102356f9bb9eec73014c3b5f305a42224f [^]
2018-11-26 15:05 jorge-garcia Note Added: 0108105
2018-11-26 15:05 jorge-garcia Status resolved => new
2018-11-26 15:05 jorge-garcia Resolution fixed => open
2018-11-26 15:16 jorge-garcia Review Assigned To => jorge-garcia
2018-11-28 13:05 hgbot Checkin
2018-11-28 13:05 hgbot Note Added: 0108145
2018-11-28 13:05 hgbot Status new => resolved
2018-11-28 13:05 hgbot Resolution open => fixed
2018-11-28 13:05 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/9290b7102356f9bb9eec73014c3b5f305a42224f [^] => http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/7c2359e9ae46d715556b0239bae72c8a3208535f [^]
2018-11-28 13:06 hgbot Checkin
2018-11-28 13:06 hgbot Note Added: 0108146
2018-12-04 13:58 marvintm Note Added: 0108250
2018-12-04 13:58 marvintm Status resolved => new
2018-12-04 13:58 marvintm Resolution fixed => open
2018-12-04 21:57 hgbot Checkin
2018-12-04 21:57 hgbot Note Added: 0108260
2018-12-04 21:57 hgbot Status new => resolved
2018-12-04 21:57 hgbot Resolution open => fixed
2018-12-04 21:57 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/7c2359e9ae46d715556b0239bae72c8a3208535f [^] => http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/f56218344703afcb8bb7811049e0dfe0b69239b3 [^]
2018-12-07 11:59 marvintm Status resolved => closed
2018-12-07 11:59 marvintm Fixed in Version => RR19Q1


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker