Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0039440
TypeCategorySeverityReproducibilityDate SubmittedLast Update
design defect[Retail Modules] Gift cards and gift vouchersmajoralways2018-10-11 17:562019-07-11 08:49
Reportersamuel_nicuesaView Statuspublic 
Assigned Tomigueldejuana 
PriorityhighResolutionopenFixed in Version
StatusclosedFix in branchFixed in SCM revision85158ff2f529
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned Tomarvintm
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0039440: A Credit note is closed without any sales order associated.

DescriptionA Credit note is closed without any sales order associated, it happens if you have bad internet connection.
Steps To Reproduce[POS]

-Create one Credit Note
(Create ticket - add product and pay it - verified return - select CNote as a payment)
-Create a new Ticket and add one product
-Select Credit Note payment method and find the Credit Note created
-Using slow internet press apply button.
-Make sure you don't have internet connection after pressing apply button
-You will see that your credit note has not been added to the receipt but it has been used in Back office see :(Gift card instance window).

-A new transaction has been created but it is not linked to the sales order.

See the attached video
TagsNo tags attached.
Attached Filespng file icon IssueCNote.png [^] (130,500 bytes) 2018-12-10 16:03

- Relationships Relation Graph ] Dependency Graph ]
duplicate of design defect 0041265 closedmigueldejuana Consume Gift Card in case of not consumed in an error request 

-  Notes
(0107703)
hgbot (developer)
2018-10-31 19:50

Repository: erp/pmods/org.openbravo.retail.giftcards
Changeset: 59f52df7ac7fd37ee44700fb13f75ba04a80d75e
Author: Rafael Queralta <rafaelcuba81 <at> gmail.com>
Date: Wed Oct 31 14:15:59 2018 -0400
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.giftcards/rev/59f52df7ac7fd37ee44700fb13f75ba04a80d75e [^]

Fixed issue 39440: A Credit note is closed without any sales order associated

- If jsonsent.optString("orderline") is empty the process is canceled

---
M src/org/openbravo/retail/giftcards/ConsumeGiftCardAmount.java
---
(0107705)
hgbot (developer)
2018-11-01 03:11

Repository: erp/pmods/org.openbravo.retail.giftcards
Changeset: 9548f7b552482f0dac8357ba88c85f74ab80e2de
Author: Rafael Queralta <rafaelcuba81 <at> gmail.com>
Date: Wed Oct 31 22:10:19 2018 -0400
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.giftcards/rev/9548f7b552482f0dac8357ba88c85f74ab80e2de [^]

Related to issue 39440: Backed out changeset: 59f52df7ac7f

---
M src/org/openbravo/retail/giftcards/ConsumeGiftCardAmount.java
---
(0107727)
hgbot (developer)
2018-11-04 04:43

Repository: erp/pmods/org.openbravo.retail.giftcards
Changeset: 9355bdce53f34934c5bfadf6bf36f67e2e6564bf
Author: Rafael Queralta <rafaelcuba81 <at> gmail.com>
Date: Sat Nov 03 23:41:47 2018 -0400
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.giftcards/rev/9355bdce53f34934c5bfadf6bf36f67e2e6564bf [^]

Fixed issue 39440: A Credit note is closed without any sales order associated

- If jsonsent.optString("orderline") is empty the process is canceled

---
M src/org/openbravo/retail/giftcards/ConsumeGiftCardAmount.java
---
(0107762)
hgbot (developer)
2018-11-06 03:13

Repository: erp/pmods/org.openbravo.retail.giftcards
Changeset: 8f1fe9a0d4184793d541c3725fd39b9453432f2f
Author: Rafael Queralta <rafaelcuba81 <at> gmail.com>
Date: Mon Nov 05 16:04:57 2018 -0500
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.giftcards/rev/8f1fe9a0d4184793d541c3725fd39b9453432f2f [^]

Fixed issue 39440: A Credit note is closed without any sales order associated

- If ConsumeGiftCardAmount process fail by time out, RevertGiftCardAmount is
executed to revert the Gift Card Amount

---
M src/org/openbravo/retail/giftcards/RevertGiftCardAmount.java
M web/org.openbravo.retail.giftcards/js/model/GiftCardUtils.js
---
(0107765)
hgbot (developer)
2018-11-06 12:09

Repository: erp/pmods/org.openbravo.retail.giftcards
Changeset: f11c76377389df3a7341b373e8258ea031cf3bcf
Author: Rafael Queralta <rafaelcuba81 <at> gmail.com>
Date: Tue Nov 06 06:09:24 2018 -0500
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.giftcards/rev/f11c76377389df3a7341b373e8258ea031cf3bcf [^]

Related to issue 39440: A Credit note is closed without any sales order
associated

---
M web/org.openbravo.retail.giftcards/js/model/GiftCardUtils.js
---
(0108104)
samuel_nicuesa (developer)
2018-11-26 13:42

This changeset is also part of this issue:

https://code.openbravo.com/erp/pmods/org.openbravo.retail.giftcards/rev/fbbce021376d [^]
(0108363)
samuel_nicuesa (developer)
2018-12-10 16:02

Hi!
I thought that the fix was working fine but I am be able to reproduce the error.
Can you check it ?
(0112994)
hgbot (developer)
2019-06-25 09:26

Repository: tools/automation/pi-mobile
Changeset: 9397bbe33f0e5c211970fe51b44ee73dc68d36b0
Author: Miguel de Juana <miguel.dejuana <at> openbravo.com>
Date: Tue Jun 25 09:26:14 2019 +0200
URL: http://code.openbravo.com/tools/automation/pi-mobile/rev/9397bbe33f0e5c211970fe51b44ee73dc68d36b0 [^]

Related to issue 0039440: A Credit note is closed without any sales order associated.

- Add missing tap which could break the tex

---
M src-test/org/openbravo/test/mobile/retail/extmodules/selenium/tests/giftcards/I32798_ReceiptGiftVoucherDiscount.java
M src-test/org/openbravo/test/mobile/retail/extmodules/selenium/tests/giftcards/I33914_ReceiptGiftVoucherMultiLines.java
M src-test/org/openbravo/test/mobile/retail/extmodules/selenium/tests/giftcards/I36006_AddGiftVoucherFromMenuToReceipt.java
---
(0112995)
hgbot (developer)
2019-06-25 09:38

Repository: erp/pmods/org.openbravo.retail.giftcards
Changeset: 85158ff2f529ca01d1ded0e8ffa333f45e9e3a17
Author: Miguel de Juana <miguel.dejuana <at> openbravo.com>
Date: Tue Jun 25 09:37:50 2019 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.giftcards/rev/85158ff2f529ca01d1ded0e8ffa333f45e9e3a17 [^]

Fixed issue 0039440: A Credit note is closed without any sales order associated.

- If gift card consume fails, assume that it worked and it will be consumed in OrderLoaderhook

---
M src/org/openbravo/retail/giftcards/ConsumeGiftCardAmount.java
M src/org/openbravo/retail/giftcards/GiftCardModel.java
M web/org.openbravo.retail.giftcards/js/hooks/PreReversePaymentHook.js
M web/org.openbravo.retail.giftcards/js/hooks/preaddpaymenthook.js
M web/org.openbravo.retail.giftcards/js/model/GiftCardUtils.js
---
(0113150)
hgbot (developer)
2019-07-03 12:19

Repository: erp/pmods/org.openbravo.retail.giftcards
Changeset: 80d03c4bd9505e4f6bed87124cfe4bbcd0e44edf
Author: Miguel de Juana <miguel.dejuana <at> openbravo.com>
Date: Wed Jul 03 12:18:48 2019 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.giftcards/rev/80d03c4bd9505e4f6bed87124cfe4bbcd0e44edf [^]

Related to issue 0039440: A Credit note is closed without any sales order associated.

- Uncomplete solution
- Backed out changeset 85158ff2f529

---
M src/org/openbravo/retail/giftcards/ConsumeGiftCardAmount.java
M src/org/openbravo/retail/giftcards/GiftCardModel.java
M web/org.openbravo.retail.giftcards/js/hooks/PreReversePaymentHook.js
M web/org.openbravo.retail.giftcards/js/hooks/preaddpaymenthook.js
M web/org.openbravo.retail.giftcards/js/model/GiftCardUtils.js
---
(0113151)
hgbot (developer)
2019-07-03 12:53

Repository: tools/automation/pi-mobile
Changeset: 06ca03016aaa6be325bdb5dbf9b33a680a5619ee
Author: Miguel de Juana <miguel.dejuana <at> openbravo.com>
Date: Wed Jul 03 12:53:37 2019 +0200
URL: http://code.openbravo.com/tools/automation/pi-mobile/rev/06ca03016aaa6be325bdb5dbf9b33a680a5619ee [^]

Related to issue 0039440: A Credit note is closed without any sales order associated.

- Uncomplete solution
Backed out changeset 9397bbe33f0e

---
M src-test/org/openbravo/test/mobile/retail/extmodules/selenium/tests/giftcards/I32798_ReceiptGiftVoucherDiscount.java
M src-test/org/openbravo/test/mobile/retail/extmodules/selenium/tests/giftcards/I33914_ReceiptGiftVoucherMultiLines.java
M src-test/org/openbravo/test/mobile/retail/extmodules/selenium/tests/giftcards/I36006_AddGiftVoucherFromMenuToReceipt.java
---
(0113264)
hgbot (developer)
2019-07-11 08:49

Repository: retail/backports/3.0RR19Q3/pi-mobile
Changeset: 8e1ca6c42e12459304add1cffc9c83e5413d68b4
Author: Miguel de Juana <miguel.dejuana <at> openbravo.com>
Date: Thu Jul 11 08:48:53 2019 +0200
URL: http://code.openbravo.com/retail/backports/3.0RR19Q3/pi-mobile/rev/8e1ca6c42e12459304add1cffc9c83e5413d68b4 [^]

Related to issue 0039440: A Credit note is closed without any sales order associated.

Backed out changeset 9397bbe33f0e
The issue change were backported

---
M src-test/org/openbravo/test/mobile/retail/extmodules/selenium/tests/giftcards/I32798_ReceiptGiftVoucherDiscount.java
M src-test/org/openbravo/test/mobile/retail/extmodules/selenium/tests/giftcards/I33914_ReceiptGiftVoucherMultiLines.java
M src-test/org/openbravo/test/mobile/retail/extmodules/selenium/tests/giftcards/I36006_AddGiftVoucherFromMenuToReceipt.java
---

- Issue History
Date Modified Username Field Change
2018-10-11 17:56 samuel_nicuesa New Issue
2018-10-11 17:56 samuel_nicuesa Assigned To => Retail
2018-10-11 17:56 samuel_nicuesa Triggers an Emergency Pack => No
2018-10-15 09:08 rafaroda Issue Monitored: rafaroda
2018-10-15 23:40 rqueralta Assigned To Retail => rqueralta
2018-10-16 14:44 rqueralta Status new => scheduled
2018-10-31 19:50 hgbot Checkin
2018-10-31 19:50 hgbot Note Added: 0107703
2018-10-31 19:50 hgbot Status scheduled => resolved
2018-10-31 19:50 hgbot Resolution open => fixed
2018-10-31 19:50 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.giftcards/rev/59f52df7ac7fd37ee44700fb13f75ba04a80d75e [^]
2018-11-01 03:11 hgbot Checkin
2018-11-01 03:11 hgbot Note Added: 0107705
2018-11-02 10:24 marvintm Status resolved => new
2018-11-02 10:24 marvintm Resolution fixed => open
2018-11-02 10:25 marvintm Status new => scheduled
2018-11-04 04:43 hgbot Checkin
2018-11-04 04:43 hgbot Note Added: 0107727
2018-11-04 04:43 hgbot Status scheduled => resolved
2018-11-04 04:43 hgbot Resolution open => fixed
2018-11-04 04:43 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.giftcards/rev/59f52df7ac7fd37ee44700fb13f75ba04a80d75e [^] => http://code.openbravo.com/erp/pmods/org.openbravo.retail.giftcards/rev/9355bdce53f34934c5bfadf6bf36f67e2e6564bf [^]
2018-11-04 15:00 rqueralta Status resolved => new
2018-11-04 15:00 rqueralta Resolution fixed => open
2018-11-04 15:00 rqueralta Status new => scheduled
2018-11-06 03:13 hgbot Checkin
2018-11-06 03:13 hgbot Note Added: 0107762
2018-11-06 03:13 hgbot Status scheduled => resolved
2018-11-06 03:13 hgbot Resolution open => fixed
2018-11-06 03:13 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.giftcards/rev/9355bdce53f34934c5bfadf6bf36f67e2e6564bf [^] => http://code.openbravo.com/erp/pmods/org.openbravo.retail.giftcards/rev/8f1fe9a0d4184793d541c3725fd39b9453432f2f [^]
2018-11-06 12:09 hgbot Checkin
2018-11-06 12:09 hgbot Note Added: 0107765
2018-11-16 09:50 marvintm Review Assigned To => marvintm
2018-11-16 09:50 marvintm Status resolved => closed
2018-11-16 09:50 marvintm Fixed in Version => RR19Q1
2018-11-26 13:42 samuel_nicuesa Note Added: 0108104
2018-12-10 16:02 samuel_nicuesa Note Added: 0108363
2018-12-10 16:02 samuel_nicuesa Status closed => new
2018-12-10 16:02 samuel_nicuesa Resolution fixed => open
2018-12-10 16:02 samuel_nicuesa Fixed in Version RR19Q1 =>
2018-12-10 16:03 samuel_nicuesa File Added: IssueCNote.png
2018-12-21 16:29 marvintm Type defect => design defect
2019-06-25 09:26 hgbot Checkin
2019-06-25 09:26 hgbot Note Added: 0112994
2019-06-25 09:38 hgbot Checkin
2019-06-25 09:38 hgbot Note Added: 0112995
2019-06-25 09:38 hgbot Status new => resolved
2019-06-25 09:38 hgbot Resolution open => fixed
2019-06-25 09:38 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.giftcards/rev/8f1fe9a0d4184793d541c3725fd39b9453432f2f [^] => http://code.openbravo.com/erp/pmods/org.openbravo.retail.giftcards/rev/85158ff2f529ca01d1ded0e8ffa333f45e9e3a17 [^]
2019-07-03 12:19 hgbot Checkin
2019-07-03 12:19 hgbot Note Added: 0113150
2019-07-03 12:53 hgbot Checkin
2019-07-03 12:53 hgbot Note Added: 0113151
2019-07-03 18:02 marvintm Assigned To rqueralta => migueldejuana
2019-07-03 18:02 marvintm Status resolved => new
2019-07-03 18:02 marvintm Resolution fixed => open
2019-07-03 18:02 marvintm Status new => closed
2019-07-03 18:02 marvintm Relationship added duplicate of 0041265
2019-07-11 08:49 hgbot Checkin
2019-07-11 08:49 hgbot Note Added: 0113264


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker