Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0039335
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 02. Master data managementmajoralways2018-09-21 10:422018-12-11 20:22
Reporterjoniturralde93View Statuspublic 
Assigned Tononofrancisco 
PriorityurgentResolutionfixedFixed in Version3.0PR19Q1
StatusclosedFix in branchFixed in SCM revision5170d62ca42f
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned ToSandrahuguet
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0039335: It is possible to chose an account which does not belong to the General Ledger (G/L Item window)

DescriptionG/L Item window, Accounting tab:

It is possible to create a record with a General Ledger, select his accounts and then switch the General Ledger, resulting in a wrong combination of General Ledger and accounts. It can be saved like that. Happens both in form and new row.
Steps To Reproduce1. Log into live builds, G/L Item window and select Organization: '*'
2. Create a new record in the Accounting tab and select General Ledger: 'F&B España, S.A. US/A/Euro'
3. Select both Glitem debit acct and Glitem credit acct: '10000 - Capital social'
4. Now, without saving before, change General Ledger to 'F&B International Group US/A/US Dollar', and then save the record. You shouldn't be allowed to do that, since that account doesn't belong to that General Ledger.
5. Open the record in form view and click on the Glitem debit acct link to open it in another tab. It is shown at the top of the window that '10000 - Capital social' belongs to 'F&B España, S.A. US/A/Euro'
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0107077)
nonofrancisco (developer)
2018-09-28 18:55

Test Plan

Log as F&B International Group Admin
Open G/L Item window and select Organization: '*'
Create a new record in the Accounting tab and select General Ledger: 'F&B España, S.A. US/A/Euro'
Select both Glitem debit acct and Glitem credit acct: '10000 - Capital social'
Now, without saving before, change General Ledger to 'F&B International Group US/A/US Dollar'.
Notice the G/L Item credit and debit amount fields are reset. Opening the selectors in those fields shows accounts that belongs to 'F&B International Group US/A/US Dollar' General Ledger
(0107132)
hgbot (developer)
2018-10-03 12:20

Repository: erp/devel/pi
Changeset: 5170d62ca42fad2a12f746e24e7c292875e638c8
Author: Nono Carballo <nonofce <at> gmail.com>
Date: Wed Oct 03 10:21:31 2018 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/5170d62ca42fad2a12f746e24e7c292875e638c8 [^]

Fixes issue 39335: Wrong combination of General Ledger and accounts

* A new Event Observer was created to check, on save, if Debit and Credit
  accounts belongs to the selected Accounting Schema.

---
M src-db/database/sourcedata/AD_MESSAGE.xml
A src/org/openbravo/event/GLItemAccountsEventHandler.java
---
(0107133)
Sandrahuguet (developer)
2018-10-03 12:21

Code review + testing OK
(0108416)
hudsonbot (developer)
2018-12-11 20:22

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/470e3cd384c5 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2018-09-21 10:42 joniturralde93 New Issue
2018-09-21 10:42 joniturralde93 Assigned To => Triage Finance
2018-09-21 10:42 joniturralde93 Modules => Core
2018-09-21 10:42 joniturralde93 Triggers an Emergency Pack => No
2018-09-27 12:07 Sandrahuguet Assigned To Triage Finance => nonofrancisco
2018-09-28 08:54 vmromanos Status new => scheduled
2018-09-28 18:55 nonofrancisco Note Added: 0107077
2018-10-03 12:20 hgbot Checkin
2018-10-03 12:20 hgbot Note Added: 0107132
2018-10-03 12:20 hgbot Status scheduled => resolved
2018-10-03 12:20 hgbot Resolution open => fixed
2018-10-03 12:20 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/5170d62ca42fad2a12f746e24e7c292875e638c8 [^]
2018-10-03 12:21 Sandrahuguet Review Assigned To => Sandrahuguet
2018-10-03 12:21 Sandrahuguet Note Added: 0107133
2018-10-03 12:21 Sandrahuguet Status resolved => closed
2018-10-03 12:21 Sandrahuguet Fixed in Version => 3.0PR19Q1
2018-12-11 20:22 hudsonbot Checkin
2018-12-11 20:22 hudsonbot Note Added: 0108416


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker