Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0039282
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSmajoralways2018-09-13 12:182018-09-21 17:58
ReporterumartirenaView Statuspublic 
Assigned Toranjith_qualiantech_com 
PriorityimmediateResolutionfixedFixed in VersionRR18Q4
StatusclosedFix in branchFixed in SCM revisionc1432b08317a
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tomarvintm
Regression levelProduction - Confirmed Stable
Regression date
Regression introduced in releaseRR18Q2
Regression introduced by commithttps://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/9e73d22ce9ce0622108a2352f416522690a6cc85 [^]
Triggers an Emergency PackNo
Summary

0039282: callback property coming in args from OBPOS_preAddPayment hook is not any more executed because it is overriden

Descriptioncallback coming in args from OBPOS_preAddPayment hook is not any more executed because it is overriden.
Steps To ReproduceImplement 'OBPOS_preAddPayment' hook and set a function in args.callback property. Check that the callback function is not called in this instruction:

if (args.callback instanceof Function) {
    args.callback(order);
}
TagsNo tags attached.
Attached Filespatch file icon issue 39282 source posterminal.patch [^] (3,253 bytes) 2018-09-18 12:17 [Show Content]

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 0039302RR18Q3.1 closedranjith_qualiantech_com callback property coming in args from OBPOS_preAddPayment hook is not any more executed because it is overriden 
depends on backport 0039310RR18Q2.3 closedranjith_qualiantech_com callback property coming in args from OBPOS_preAddPayment hook is not any more executed because it is overriden 
caused by feature request 0037888 closedjorgewederago Add a hook to be executed after adding a payment to the order 

-  Notes
(0106791)
hgbot (developer)
2018-09-17 08:12

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: 753d77119c8c597ebd9aa26b15e24325eeba1407
Author: Ranjith S R <ranjith <at> qualiantech.com>
Date: Mon Sep 17 11:42:07 2018 +0530
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/753d77119c8c597ebd9aa26b15e24325eeba1407 [^]

Fixed issue 39282 : Removed callback property of PrePayment hook in PostAddPayment hook

---
M web/org.openbravo.retail.posterminal/js/model/order.js
---
(0106807)
jorge-garcia (developer)
2018-09-17 15:44

Reopened to create backport
(0106821)
hgbot (developer)
2018-09-18 09:03

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: 512091b08f7e4c18cf1785d5d7386d64dd797bb4
Author: Ranjith S R <ranjith <at> qualiantech.com>
Date: Tue Sep 18 12:32:58 2018 +0530
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/512091b08f7e4c18cf1785d5d7386d64dd797bb4 [^]

Fixed issue 39282 : Removed callback property of PrePayment hook in PostAddPayment hook

* Removed callback property in MultiOrder addPayment function

---
M web/org.openbravo.retail.posterminal/js/model/order.js
---
(0106839)
hgbot (developer)
2018-09-18 15:40

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: c1432b08317a239fe457834bf9353b1ae4fb5aa2
Author: Ranjith S R <ranjith <at> qualiantech.com>
Date: Tue Sep 18 18:55:04 2018 +0530
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/c1432b08317a239fe457834bf9353b1ae4fb5aa2 [^]

Fixed issue 39282 : Removed callback argument in PrePayment hook and postPayment hook

---
M web/org.openbravo.retail.posterminal/js/model/order.js
---

- Issue History
Date Modified Username Field Change
2018-09-13 12:18 umartirena New Issue
2018-09-13 12:18 umartirena Assigned To => Retail
2018-09-13 12:18 umartirena Regression introduced in release => RR18Q2
2018-09-13 12:18 umartirena Regression introduced by commit => https://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/9e73d22ce9ce0622108a2352f416522690a6cc85 [^]
2018-09-13 12:18 umartirena Triggers an Emergency Pack => No
2018-09-13 13:13 martinsdan Issue Monitored: martinsdan
2018-09-13 14:51 ranjith_qualiantech_com Assigned To Retail => ranjith_qualiantech_com
2018-09-13 14:51 ranjith_qualiantech_com Status new => scheduled
2018-09-14 09:52 egoitz Resolution time => 1537221600
2018-09-14 09:53 egoitz Priority urgent => immediate
2018-09-14 10:41 ngarcia Issue Monitored: ngarcia
2018-09-17 08:12 hgbot Checkin
2018-09-17 08:12 hgbot Note Added: 0106791
2018-09-17 08:12 hgbot Status scheduled => resolved
2018-09-17 08:12 hgbot Resolution open => fixed
2018-09-17 08:12 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/753d77119c8c597ebd9aa26b15e24325eeba1407 [^]
2018-09-17 15:44 jorge-garcia Note Added: 0106807
2018-09-17 15:44 jorge-garcia Status resolved => new
2018-09-17 15:44 jorge-garcia Resolution fixed => open
2018-09-17 15:44 jorge-garcia Status new => scheduled
2018-09-17 15:44 jorge-garcia Status scheduled => resolved
2018-09-17 15:44 jorge-garcia Resolution open => fixed
2018-09-18 09:03 hgbot Checkin
2018-09-18 09:03 hgbot Note Added: 0106821
2018-09-18 09:03 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/753d77119c8c597ebd9aa26b15e24325eeba1407 [^] => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/512091b08f7e4c18cf1785d5d7386d64dd797bb4 [^]
2018-09-18 09:52 marvintm Status resolved => new
2018-09-18 09:52 marvintm Resolution fixed => open
2018-09-18 09:52 marvintm Status new => scheduled
2018-09-18 09:52 marvintm Status scheduled => resolved
2018-09-18 09:52 marvintm Fixed in Version => RR18Q4
2018-09-18 09:52 marvintm Resolution open => fixed
2018-09-18 12:17 ranjith_qualiantech_com File Added: issue 39282 source posterminal.patch
2018-09-18 15:40 hgbot Checkin
2018-09-18 15:40 hgbot Note Added: 0106839
2018-09-18 15:40 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/512091b08f7e4c18cf1785d5d7386d64dd797bb4 [^] => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/c1432b08317a239fe457834bf9353b1ae4fb5aa2 [^]
2018-09-19 10:47 marvintm Review Assigned To => marvintm
2018-09-19 10:47 marvintm Status resolved => closed
2018-09-20 18:35 dmitry_mezentsev Relationship added caused by 0037888
2018-09-21 17:58 dmitry_mezentsev Regression level => Production - Confirmed Stable


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker