Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0039265
TypeCategorySeverityReproducibilityDate SubmittedLast Update
feature request[Retail Modules] Web POSmajorhave not tried2018-09-11 16:152018-12-13 15:01
ReportercaristuView Statuspublic 
Assigned TojavierRodriguez 
PriorityhighResolutionfixedFixed in VersionRR19Q1
StatusclosedFix in branchFixed in SCM revision96b159bdd3a4
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tomarvintm
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0039265: Add a method in ExternalOrderLoader to transform and process orders in a synchronous way

DescriptionIt would be nice to have a method in the ExternalOrderLoader to process orders in a synchronous way. Ideally this method would perform the following tasks:

1- Transform a JSONObject received as parameter, adding/completing the required information.
2- Creates/Process the order
3- Returns information with the result of the process, including error information in case there were errors during the process.
Steps To ReproduceIn description
Proposed SolutionSee:

https://code.openbravo.com/erp/pmods/org.openbravo.service.integration.magento.mappings/file/tip/src/org/openbravo/service/integration/magento/mappings/inbound/orders/MagentoExternalOrderLoader.java [^]

Note that the idea is to replace this class once this issue is fixed.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0107782)
aferraz (developer)
2018-11-07 17:38

Check also ExternalOrderLoader.isSynchronizedRequest() method. Right now it is raising a NPE because RequestContext.get().getRequest() is null.
(0108172)
hgbot (developer)
2018-11-30 09:22

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: 96b159bdd3a4c8196e3136bc60d92dc83942855b
Author: Javier Rodriguez <javier.rodriguez <at> openbravo.com>
Date: Mon Nov 26 16:46:32 2018 +0100
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/96b159bdd3a4c8196e3136bc60d92dc83942855b [^]

Fixed issue 39265: Add a method in ExternalOrderLoader to transform and process orders in a synchronous way

---
M src/org/openbravo/retail/posterminal/ExternalOrderLoader.java
---
(0108245)
hgbot (developer)
2018-12-04 11:14

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: 55a01f329e642e4c08be103525eba6603fcffe24
Author: Javier Rodriguez <javier.rodriguez <at> openbravo.com>
Date: Tue Dec 04 11:11:11 2018 +0100
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/55a01f329e642e4c08be103525eba6603fcffe24 [^]

Related to issue 39265: fixed db consistency

---
M src/org/openbravo/retail/posterminal/ExternalOrderLoader.java
---
(0108246)
hgbot (developer)
2018-12-04 11:18

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: cf84f1535b309010f25052182e9aba972b485d02
Author: Javier Rodriguez <javier.rodriguez <at> openbravo.com>
Date: Tue Dec 04 11:17:51 2018 +0100
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/cf84f1535b309010f25052182e9aba972b485d02 [^]

Related to issue 39265

---
M src/org/openbravo/retail/posterminal/PaidReceiptsFilter.java
---
(0108308)
hgbot (developer)
2018-12-05 23:41

Repository: erp/pmods/org.openbravo.service.integration.magento.mappings
Changeset: d554bb1089c075af309d9ae63f0d84a6b8531e5c
Author: Armaignac <collazoandy4 <at> gmail.com>
Date: Wed Dec 05 14:31:21 2018 -0500
URL: http://code.openbravo.com/erp/pmods/org.openbravo.service.integration.magento.mappings/rev/d554bb1089c075af309d9ae63f0d84a6b8531e5c [^]

Related to issue 39265:Removed temporary class MagentoExternalOrderLoader

The MagentoExternalOrderLoader was removed and the code was updated with
ExternalOrderLoader

---
M src/org/openbravo/service/integration/magento/mappings/inbound/orders/OrderImporter.java
R src/org/openbravo/service/integration/magento/mappings/inbound/orders/MagentoExternalOrderLoader.java
---

- Issue History
Date Modified Username Field Change
2018-09-11 16:15 caristu New Issue
2018-09-11 16:15 caristu Assigned To => Retail
2018-09-11 16:15 caristu Triggers an Emergency Pack => No
2018-11-07 17:38 aferraz Note Added: 0107782
2018-11-13 14:03 caristu Proposed Solution updated
2018-11-30 09:22 hgbot Checkin
2018-11-30 09:22 hgbot Note Added: 0108172
2018-11-30 09:22 hgbot Status new => resolved
2018-11-30 09:22 hgbot Resolution open => fixed
2018-11-30 09:22 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/96b159bdd3a4c8196e3136bc60d92dc83942855b [^]
2018-12-04 11:14 hgbot Checkin
2018-12-04 11:14 hgbot Note Added: 0108245
2018-12-04 11:18 hgbot Checkin
2018-12-04 11:18 hgbot Note Added: 0108246
2018-12-05 23:41 hgbot Checkin
2018-12-05 23:41 hgbot Note Added: 0108308
2018-12-13 11:55 marvintm Assigned To Retail => javierRodriguez
2018-12-13 15:01 marvintm Review Assigned To => marvintm
2018-12-13 15:01 marvintm Status resolved => closed
2018-12-13 15:01 marvintm Fixed in Version => RR19Q1


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker