Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0039227
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminorhave not tried2018-09-05 10:292019-10-09 12:21
ReporteranderarangurenView Statuspublic 
Assigned Tocaristu 
PriorityhighResolutionfixedFixed in Version3.0PR19Q1
StatusclosedFix in branchFixed in SCM revisione5566da8d2a0
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0039227: Error with tree reference fields in the form personalization button

DescriptionCannot read property 'length' of undefined when trying to edit the form from the 'form personalization' button on the backend
It happends when there is a tree reference field
Steps To ReproduceLogin in the backend
Go to 'Discounts and Promotions' window
Select a record with characteristics
Go to 'Characteristics' tab
Click the 'form personalization' button
In the developers window console appears an error with the following: "Cannot read property 'length' of undefined" and the form view is not opened
TagsNo tags attached.
Attached Filespng file icon treeReference.png [^] (224,541 bytes) 2018-09-05 10:29

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0032153 closedNaroaIriarte [RR16Q1] "Update Characteristics" process does not show characteristics to choose them after creating a new record 
related to defect 00182063.0MP4 closedmtaal [Personalize form layout] Image type item has not the upload icon 
related to defect 0039269 acknowledgedplatform Form Personalization > Restore Defaults button does not work properly in some tabs 

-  Notes
(0106686)
hgbot (developer)
2018-09-11 18:15

Repository: erp/devel/pi
Changeset: e5566da8d2a096a4d5fd74d818959515a64a7311
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Tue Sep 11 17:50:57 2018 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/e5566da8d2a096a4d5fd74d818959515a64a7311 [^]

fixes issue 39227: Form Personalization doesn't work having tree based fields

  The Form Personalization feature was not working when having fields based on a tree reference. This was happening because when building the pre-visualization form not all the information required by an OBTreeItem instance was provided.

  Now we are taking into account if the OBTreeItem instance is being built for the personalization form and in that case we skip the initialization of its components: it will be shown just as a text field.

  Besides, we are adding a check within the "moved" function to verify whether the "tree" property exists. This is done to avoid a JS error at that point after opening the personalization form.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-tree.js
---
(0106733)
hudsonbot (developer)
2018-09-12 21:33

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/ad75d3cb1744 [^]
Maturity status: Test
(0106918)
alostale (developer)
2018-09-21 09:18

Reviewed + tested

- Issue History
Date Modified Username Field Change
2018-09-05 10:29 anderaranguren New Issue
2018-09-05 10:29 anderaranguren Assigned To => platform
2018-09-05 10:29 anderaranguren File Added: treeReference.png
2018-09-05 10:29 anderaranguren Modules => Core
2018-09-05 10:29 anderaranguren Triggers an Emergency Pack => No
2018-09-05 10:30 anderaranguren Priority urgent => high
2018-09-05 10:30 anderaranguren Severity major => minor
2018-09-05 10:50 jfrances Issue Monitored: jfrances
2018-09-10 10:00 caristu Relationship added related to 0032153
2018-09-10 12:29 caristu Assigned To platform => caristu
2018-09-10 12:29 caristu Status new => scheduled
2018-09-11 18:15 hgbot Checkin
2018-09-11 18:15 hgbot Note Added: 0106686
2018-09-11 18:15 hgbot Status scheduled => resolved
2018-09-11 18:15 hgbot Resolution open => fixed
2018-09-11 18:15 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/e5566da8d2a096a4d5fd74d818959515a64a7311 [^]
2018-09-11 18:18 caristu Relationship added related to 0018206
2018-09-11 18:19 caristu Review Assigned To => alostale
2018-09-11 18:36 caristu Relationship added related to 0039269
2018-09-12 21:33 hudsonbot Checkin
2018-09-12 21:33 hudsonbot Note Added: 0106733
2018-09-21 09:18 alostale Note Added: 0106918
2018-09-21 09:18 alostale Status resolved => closed
2018-09-21 09:18 alostale Fixed in Version => 3.0PR19Q1
2019-10-09 12:21 rafaroda Issue Monitored: rafaroda


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker