Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0038772
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] I. Performancemajoralways2018-06-15 15:362019-06-13 09:55
Reportermarkmm82View Statuspublic 
Assigned Tomarkmm82 
PriorityhighResolutionfixedFixed in Version3.0PR18Q3
StatusclosedFix in branchFixed in SCM revisionde5ea8bf7fce
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tovmromanos
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0038772: Needed index on M_MATCHPO to improve performance in Create Lines From popup on Invoice windows

DescriptionThe Create Lines From popup is very slow when having a high number of Orders realted to a business partner. From both Purchase and Sales Invoice windows.
It is caused by a query that is executed for every candidate order validating that exists lines that can be invoiced and to do that is requested information from M_MATCHPO.
Steps To ReproduceOn a environment with a high volume of orderds. Around 8 million.
Create a new Purchase Invoice Header and open the Create Lines popup.
In the customer environment it takes minutes to load the popup.
Proposed SolutionCreate a new index on M_MatchPO (c_orderline_id, c_invoiceline_id) where c_invoiceline_id is not null
TagsPerformance
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00387733.0PR18Q2.1 closedmarkmm82 Needed index on M_MATCHPO to improve performance in Create Lines From popup on Invoice windows 
depends on backport 00387743.0PR18Q1.4 closedmarkmm82 Needed index on M_MATCHPO to improve performance in Create Lines From popup on Invoice windows 

-  Notes
(0105251)
hgbot (developer)
2018-06-19 13:42

Repository: erp/devel/pi
Changeset: de5ea8bf7fce059eb002ff346480e531ded1ecee
Author: Mark <markmm82 <at> gmail.com>
Date: Thu Jun 14 19:20:21 2018 -0400
URL: http://code.openbravo.com/erp/devel/pi/rev/de5ea8bf7fce059eb002ff346480e531ded1ecee [^]

Fixes issue 38772:Index on M_MATCHPO to improve performance in Create Lines From

Caused by a query that is executed for every candidate order validating that exists lines that can be
invoiced requesting information from M_MATCHPO, the Create Lines From process on Invoice windows has
bad performance and to be improved waa needed to add a new index in C_ORDERLINE_ID and C_INVOICELINE_ID
columns taking into account those records where C_INVOICELINE_ID IS NOT NULL.

---
M src-db/database/model/tables/M_MATCHPO.xml
---
(0105254)
vmromanos (developer)
2018-06-19 13:45

Code review + testing OK
(0105263)
hudsonbot (developer)
2018-06-19 17:43

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/1adac736b09e [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2018-06-15 15:36 markmm82 New Issue
2018-06-15 15:36 markmm82 Assigned To => markmm82
2018-06-15 15:36 markmm82 Modules => Core
2018-06-15 15:36 markmm82 Triggers an Emergency Pack => No
2018-06-15 16:19 markmm82 Status new => scheduled
2018-06-19 13:42 hgbot Checkin
2018-06-19 13:42 hgbot Note Added: 0105251
2018-06-19 13:42 hgbot Status scheduled => resolved
2018-06-19 13:42 hgbot Resolution open => fixed
2018-06-19 13:42 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/de5ea8bf7fce059eb002ff346480e531ded1ecee [^]
2018-06-19 13:45 vmromanos Review Assigned To => vmromanos
2018-06-19 13:45 vmromanos Note Added: 0105254
2018-06-19 13:45 vmromanos Status resolved => closed
2018-06-19 13:45 vmromanos Fixed in Version => 3.0PR18Q3
2018-06-19 17:43 hudsonbot Checkin
2018-06-19 17:43 hudsonbot Note Added: 0105263
2019-06-13 09:55 Sandrahuguet Tag Attached: Performance


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker