Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0038773
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] I. Performancemajoralways2018-06-15 15:362018-06-19 13:44
Reportermarkmm82View Statuspublic 
Assigned Tomarkmm82 
PriorityhighResolutionfixedFixed in Version3.0PR18Q2.1
StatusclosedFix in branchFixed in SCM revision42688f7eac68
ProjectionnoneETAnoneTarget Version3.0PR18Q2.1
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tovmromanos
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0038773: Needed index on M_MATCHPO to improve performance in Create Lines From popup on Invoice windows

DescriptionThe Create Lines From popup is very slow when having a high number of Orders realted to a business partner. From both Purchase and Sales Invoice windows.
It is caused by a query that is executed for every candidate order validating that exists lines that can be invoiced and to do that is requested information from M_MATCHPO.
Steps To ReproduceOn a environment with a high volume of orderds. Around 8 million.
Create a new Purchase Invoice Header and open the Create Lines popup.
In the customer environment it takes minutes to load the popup.
Proposed SolutionCreate a new index on M_MatchPO (c_orderline_id, c_invoiceline_id) where c_invoiceline_id is not null
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 0038772 closedmarkmm82 Needed index on M_MATCHPO to improve performance in Create Lines From popup on Invoice windows 

-  Notes
(0105248)
hgbot (developer)
2018-06-19 13:41

Repository: erp/backports/3.0PR18Q2.1
Changeset: 42688f7eac68ddbc2fcecbf750d042c2fc1e2962
Author: Mark <markmm82 <at> gmail.com>
Date: Thu Jun 14 19:20:21 2018 -0400
URL: http://code.openbravo.com/erp/backports/3.0PR18Q2.1/rev/42688f7eac68ddbc2fcecbf750d042c2fc1e2962 [^]

Fixes issue 38773:Index on M_MATCHPO to improve performance in Create Lines From

Caused by a query that is executed for every candidate order validating that exists lines that can be
invoiced requesting information from M_MATCHPO, the Create Lines From process on Invoice windows has
bad performance and to be improved waa needed to add a new index in C_ORDERLINE_ID and C_INVOICELINE_ID
columns taking into account those records where C_INVOICELINE_ID IS NOT NULL.

---
M src-db/database/model/tables/M_MATCHPO.xml
---
(0105252)
vmromanos (developer)
2018-06-19 13:44

Code review + testing OK

- Issue History
Date Modified Username Field Change
2018-06-15 16:19 markmm82 Type defect => backport
2018-06-15 16:19 markmm82 Target Version => 3.0PR18Q2.1
2018-06-19 13:41 hgbot Checkin
2018-06-19 13:41 hgbot Note Added: 0105248
2018-06-19 13:41 hgbot Status scheduled => resolved
2018-06-19 13:41 hgbot Resolution open => fixed
2018-06-19 13:41 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/backports/3.0PR18Q2.1/rev/42688f7eac68ddbc2fcecbf750d042c2fc1e2962 [^]
2018-06-19 13:44 vmromanos Review Assigned To => vmromanos
2018-06-19 13:44 vmromanos Note Added: 0105252
2018-06-19 13:44 vmromanos Status resolved => closed
2018-06-19 13:44 vmromanos Fixed in Version => 3.0PR18Q2.1


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker