Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0038653
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] A. Platformmajoralways2018-05-25 14:132018-06-01 09:46
ReporterlorenzofidalgoView Statuspublic 
Assigned Tocaristu 
PriorityimmediateResolutionfixedFixed in Version3.0PR18Q2.1
StatusclosedFix in branchFixed in SCM revision0c1cad7ac1a8
ProjectionnoneETAnoneTarget Version3.0PR18Q2.1
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression levelProduction - QA Approved
Regression date2018-02-23
Regression introduced in release3.0PR18Q2
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/4a1f3df29564b6dd12259981f941d0d5d74bebab [^]
Triggers an Emergency PackNo
Summary

0038653: Wrong values sent while creating a record under specific circumstances

DescriptionCreating records, it is possible send different data than the values that are selected by the user. It seems to be induced by a callout launched using the backspace key to remove the default value.
Steps To Reproduce0-Login ERP and, using F&B International Group Admin role, go to "Role" window.
1-In the Header tab, select "F&B España, S.A - Finance" (column: name) record.
2-Go to "Org Access" tab.
3-If present, delete "F&B España, S.A" record.
4-Click "Create a new record in form view" button.
5-Click in "Organization" input field and remove the "*" character using the backspace key. Now, click at the arrow key to select a value, and choose "F&B España, S.A". Click Save button.
6-DEFECT: The following error will be shown: "Saving failed. There is already a Role Organization Access with the same (Organization, Role). (Organization, Role) must be unique. You must change the values entered." The role that has been sent by the application is wrong.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 0038635 closedcaristu Wrong values sent while creating a record under specific circumstances 

-  Notes
(0104802)
hgbot (developer)
2018-05-30 10:57

Repository: erp/backports/3.0PR18Q2.1
Changeset: 0c1cad7ac1a8456104726b2074aff7c1052a696b
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Wed May 30 10:43:21 2018 +0200
URL: http://code.openbravo.com/erp/backports/3.0PR18Q2.1/rev/0c1cad7ac1a8456104726b2074aff7c1052a696b [^]

fixes issue 38653: Wrong combo values if the org id is not received by the FIC

  Before the changes on issue 0037980 when retrieving an empty organization in the FIC, the query to calculate the selected combo value was filtering by every organization in the client. After that changes, the query to calculate the combo is filtering by an empty organization list, avoiding to retrieve the correct value.

  This is eventually caused by a change on how the Utility.getReferenceableOrg() method behaves. It now returns an empty list ('') if no organization is provided.

  To fix the problem we are now not including the org filtering in the query generated by UIDefinition.getValueInComboReference() method if an empty organization list is provided when building the query. In this case, filtering by client should be enough.

---
M src/org/openbravo/erpCommon/utility/ComboTableData.java
M src/org/openbravo/erpCommon/utility/StringCollectionUtils.java
---
(0104859)
alostale (developer)
2018-06-01 09:46

reviewed + tested

- Issue History
Date Modified Username Field Change
2018-05-29 17:44 caristu Type defect => backport
2018-05-29 17:44 caristu Target Version => 3.0PR18Q2.1
2018-05-30 10:57 hgbot Checkin
2018-05-30 10:57 hgbot Note Added: 0104802
2018-05-30 10:57 hgbot Status scheduled => resolved
2018-05-30 10:57 hgbot Resolution open => fixed
2018-05-30 10:57 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/backports/3.0PR18Q2.1/rev/0c1cad7ac1a8456104726b2074aff7c1052a696b [^]
2018-05-30 10:57 caristu Review Assigned To => alostale
2018-06-01 09:46 alostale Note Added: 0104859
2018-06-01 09:46 alostale Status resolved => closed
2018-06-01 09:46 alostale Fixed in Version => 3.0PR18Q2.1


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker