Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0038635
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2018-05-25 14:132018-06-08 07:29
ReporterlorenzofidalgoView Statuspublic 
Assigned Tocaristu 
PriorityimmediateResolutionfixedFixed in Version3.0PR18Q3
StatusclosedFix in branchFixed in SCM revision3b8a64571ce8
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression levelProduction - QA Approved
Regression date2018-02-23
Regression introduced in release3.0PR18Q2
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/4a1f3df29564b6dd12259981f941d0d5d74bebab [^]
Triggers an Emergency PackNo
Summary

0038635: Wrong values sent while creating a record under specific circumstances

DescriptionCreating records, it is possible send different data than the values that are selected by the user. It seems to be induced by a callout launched using the backspace key to remove the default value.
Steps To Reproduce0-Login ERP and, using F&B International Group Admin role, go to "Role" window.
1-In the Header tab, select "F&B España, S.A - Finance" (column: name) record.
2-Go to "Org Access" tab.
3-If present, delete "F&B España, S.A" record.
4-Click "Create a new record in form view" button.
5-Click in "Organization" input field and remove the "*" character using the backspace key. Now, click at the arrow key to select a value, and choose "F&B España, S.A". Click Save button.
6-DEFECT: The following error will be shown: "Saving failed. There is already a Role Organization Access with the same (Organization, Role). (Organization, Role) must be unique. You must change the values entered." The role that has been sent by the application is wrong.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00386533.0PR18Q2.1 closedcaristu Wrong values sent while creating a record under specific circumstances 
caused by feature request 0037980 closedalostale Improve organization cache in session 

-  Notes
(0104781)
caristu (developer)
2018-05-29 17:43
edited on: 2018-05-30 10:41

The issue is caused by a change in the behavior of the UIDefinition.getValueInComboReference() method. This change can happen when clearing an Organization (AD_Org) combo.

Before 0037980 when retrieving an empty organization in the FIC, the query to calculate the combo was filtering by every organization. Now the query to calculate the combo is adding the following clause:

..AND td0.AD_Org_ID IN ('').

Note that we are filtering by an empty list (''). Therefore, no values are calculated, causing subsequent problems like the reported in this issue.

(0104801)
hgbot (developer)
2018-05-30 10:55

Repository: erp/devel/pi
Changeset: 3b8a64571ce8c66944a72e062fab9f57000693be
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Wed May 30 10:43:21 2018 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/3b8a64571ce8c66944a72e062fab9f57000693be [^]

fixes issue 38635: Wrong combo values if the org id is not received by the FIC

  Before the changes on issue 0037980 when retrieving an empty organization in the FIC, the query to calculate the selected combo value was filtering by every organization in the client. After that changes, the query to calculate the combo is filtering by an empty organization list, avoiding to retrieve the correct value.

  This is eventually caused by a change on how the Utility.getReferenceableOrg() method behaves. It now returns an empty list ('') if no organization is provided.

  To fix the problem we are now not including the org filtering in the query generated by UIDefinition.getValueInComboReference() method if an empty organization list is provided when building the query. In this case, filtering by client should be enough.

---
M src/org/openbravo/erpCommon/utility/ComboTableData.java
M src/org/openbravo/erpCommon/utility/StringCollectionUtils.java
---
(0104813)
hudsonbot (developer)
2018-05-30 17:11

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/10bad01a186a [^]
Maturity status: Test
(0104858)
alostale (developer)
2018-06-01 09:46

reviewed + tested
(0104939)
hgbot (developer)
2018-06-05 13:19

Repository: erp/devel/pi
Changeset: cf31b874f2d21cca2fbea33e6d8e68ab7791e4fb
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Tue Jun 05 13:19:34 2018 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/cf31b874f2d21cca2fbea33e6d8e68ab7791e4fb [^]

related to issue 38635: added test case

---
M src-test/src/org/openbravo/test/datasource/FICTest.java
---
(0105012)
hudsonbot (developer)
2018-06-08 07:29

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/4e0c05c97edf [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2018-05-25 14:13 lorenzofidalgo New Issue
2018-05-25 14:13 lorenzofidalgo Assigned To => platform
2018-05-25 14:13 lorenzofidalgo Modules => Core
2018-05-25 14:13 lorenzofidalgo Regression level => Production - QA Approved
2018-05-25 14:13 lorenzofidalgo Regression introduced in release => 3.0PR18Q2
2018-05-25 14:13 lorenzofidalgo Triggers an Emergency Pack => No
2018-05-25 14:14 lorenzofidalgo Summary Wrong role sent while creating a record under specific circumstances => Wrong values sent while creating a record under specific circumstances
2018-05-25 14:15 lorenzofidalgo Description Updated View Revisions
2018-05-25 14:17 lorenzofidalgo Steps to Reproduce Updated View Revisions
2018-05-29 17:35 caristu Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/4a1f3df29564b6dd12259981f941d0d5d74bebab [^]
2018-05-29 17:35 caristu Relationship added caused by 0037980
2018-05-29 17:36 caristu Regression date => 2018-02-23
2018-05-29 17:43 caristu Note Added: 0104781
2018-05-29 17:43 caristu Assigned To platform => caristu
2018-05-29 17:43 caristu Status new => acknowledged
2018-05-29 17:44 caristu Status acknowledged => scheduled
2018-05-30 10:41 caristu Note Edited: 0104781 View Revisions
2018-05-30 10:55 hgbot Checkin
2018-05-30 10:55 hgbot Note Added: 0104801
2018-05-30 10:55 hgbot Status scheduled => resolved
2018-05-30 10:55 hgbot Resolution open => fixed
2018-05-30 10:55 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/3b8a64571ce8c66944a72e062fab9f57000693be [^]
2018-05-30 10:58 caristu Review Assigned To => alostale
2018-05-30 17:11 hudsonbot Checkin
2018-05-30 17:11 hudsonbot Note Added: 0104813
2018-06-01 09:46 alostale Note Added: 0104858
2018-06-01 09:46 alostale Status resolved => closed
2018-06-01 09:46 alostale Fixed in Version => 3.0PR18Q3
2018-06-05 13:19 hgbot Checkin
2018-06-05 13:19 hgbot Note Added: 0104939
2018-06-08 07:29 hudsonbot Checkin
2018-06-08 07:29 hudsonbot Note Added: 0105012


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker