Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0038555
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminorhave not tried2018-05-16 08:322018-05-18 09:07
ReportercaristuView Statuspublic 
Assigned Tocaristu 
PriorityurgentResolutionfixedFixed in Version3.0PR18Q3
StatusclosedFix in branchFixed in SCM revisione8f606ccb519
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0038555: JS Error after opening a window under some circumstances

DescriptionA JS Error is thrown after opening a window having:

- Lazy filtering enabled
- A deleted saved view that contained at least one summary function

The error retrieved in this case: Uncaught TypeError: Cannot read property 'hide' of undefined
Steps To ReproduceIn an environment with the instance activated and no modules in "in development" status.

As System Administrator
0) Go to the Grid Configuration at System Level window and create a new record, enabling the lazy filtering.

As Group Admin
1) Open the Sales Order window
2) Navigate to the lines tab and add a summary function to the UOM field
3) Show the "Creation Date" field in the grid and move it to a new position in the grid
4) Save the view and mark it as default
5) Close the window and open it again
6) Delete the newly created view, do not set the default view.
7) Close the window and open it again. The error is thrown.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
caused by defect 0028281 closedNaroaIriarte Funnel icon is not hidden after clearing the filters when using lazy filtering 

-  Notes
(0104538)
hgbot (developer)
2018-05-16 09:03

Repository: erp/devel/pi
Changeset: e8f606ccb519eba2eab37f4cdaa25e1fa6e92c56
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Wed May 16 08:54:42 2018 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/e8f606ccb519eba2eab37f4cdaa25e1fa6e92c56 [^]

fixes issue 38555: JS Error after opening a window under some circumstances

  When opening a window having the lazy filtering enabled, the funnel icon is hidden automatically. But when opening a window with some particular configuration it is possible to reach the code that hides the funnel icon without having it initialized yet. In this case a JS error was thrown avoiding the correct loading of the window.

  To fix the problem we just check whether the funnel icon has been initialized before trying to hide it.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-grid.js
---
(0104540)
hudsonbot (developer)
2018-05-16 13:24

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/46253db4f9d3 [^]
Maturity status: Test
(0104587)
alostale (developer)
2018-05-18 09:07

reviewed + tested

- Issue History
Date Modified Username Field Change
2018-05-16 08:32 caristu New Issue
2018-05-16 08:32 caristu Assigned To => platform
2018-05-16 08:32 caristu Modules => Core
2018-05-16 08:32 caristu Triggers an Emergency Pack => No
2018-05-16 08:38 caristu Assigned To platform => caristu
2018-05-16 08:38 caristu Steps to Reproduce Updated View Revisions
2018-05-16 08:42 caristu Steps to Reproduce Updated View Revisions
2018-05-16 08:52 caristu Relationship added related to 0028281
2018-05-16 08:53 caristu Relationship deleted related to 0028281
2018-05-16 08:53 caristu Relationship added caused by 0028281
2018-05-16 09:03 hgbot Checkin
2018-05-16 09:03 hgbot Note Added: 0104538
2018-05-16 09:03 hgbot Status new => resolved
2018-05-16 09:03 hgbot Resolution open => fixed
2018-05-16 09:03 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/e8f606ccb519eba2eab37f4cdaa25e1fa6e92c56 [^]
2018-05-16 09:03 caristu Review Assigned To => alostale
2018-05-16 13:24 hudsonbot Checkin
2018-05-16 13:24 hudsonbot Note Added: 0104540
2018-05-18 09:07 alostale Note Added: 0104587
2018-05-18 09:07 alostale Status resolved => closed
2018-05-18 09:07 alostale Fixed in Version => 3.0PR18Q3


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker