Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0028281
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminorhave not tried2014-11-25 17:162014-12-30 23:26
ReporterAugustoMauchView Statuspublic 
Assigned ToNaroaIriarte 
PrioritynormalResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision8571b27d5fa0
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToAugustoMauch
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0028281: Funnel icon is not hidden after clearing the filters when using lazy filtering

DescriptionIf the user clicks on the funnel icon to clear the filters while having lazy filter configured in that tab, the funnel icon will not be hidden until the changes in the filters are applied.

It would be better to hide the icon right after is clicked to give feedback to the user
Steps To ReproduceAs System Admin:
- Open the Grid Configurationa at System Level window
- Create a new record a set the Lazy Filtering on Grid property to true.
- Open the Unit of Measure window
- Write something in the filter editor and apply the changes. The funnel icon will be shown, that is OK.
- Click on the funnel icon. It is not hidden, this is wrong.
- Apply the changes. The funnel icon is hidden now.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to feature request 0028284 closedAugustoMauch Grid Configuration for High Volume Windows 
causes defect 0038555 closedcaristu JS Error after opening a window under some circumstances 

-  Notes
(0072134)
NaroaIriarte (developer)
2014-11-28 13:55

Some tests have been performed:
-Enabling the checkbox for lazy filtering on grid in the "Grid Configuration at System Level" window and testing this cases:
        1- Selecting the header tab of "Unit Measure" in the "Grid Configuration at Window/Tab/Field Level" window, and setting the field "Lazy Filtering Grid" as "default".
The expected behavior was the "Unit Measure" window to appear as Lazy filtered.
When the filters are cleared using the funnel icon, the icon disappears as expected.
        2- Selecting the header tab of "Unit Measure" in the "Grid Configuration at Window/Tab/Field Level" window, and setting the field "Lazy Filtering Grid" as "NO".
The expected behavior was the "Unit Measure" window not to appear as Lazy filtered.
When the filters are cleared using the funnel icon, the icon disappears as expected.
        3- Selecting the header tab of "Unit Measure" in the "Grid Configuration at Window/Tab/Field Level" window, and setting the field "Lazy Filtering Grid" as "YES".
The expected behavior was the "Unit Measure" window to appear as Lazy filtered.
When the filters are cleared using the funnel icon, the icon disappears as expected.

- Disabling the checkbox for lazy filtering on grid in the "Grid Configuration at System Level" window and testing this cases:
         1- Selecting the header tab of "Unit Measure" in the "Grid Configuration at Window/Tab/Field Level" window, and setting the field "Lazy Filtering Grid" as "default".
The expected behavior was the "Unit Measure" window not to appear as Lazy filtered.
When the filters are cleared using the funnel icon, the icon disappears as expected.
         2- Selecting the header tab of "Unit Measure" in the "Grid Configuration at Window/Tab/Field Level" window, and setting the field "Lazy Filtering Grid" as "NO".
The expected behavior was the "Unit Measure" window not to appear as Lazy filtered.
When the filters are cleared using the funnel icon, the icon disappears as expected.
         3- Selecting the header tab of "Unit Measure" in the "Grid Configuration at Window/Tab/Field Level" window, and setting the field "Lazy Filtering Grid" as "YES".
The expected behavior was the "Unit Measure" window to appear as Lazy filtered.
When the filters are cleared using the funnel icon, the icon disappears as expected.
(0072208)
hgbot (developer)
2014-12-01 16:59

Repository: erp/devel/pi
Changeset: 8571b27d5fa06b32cb7425b8ec90b6cca861919b
Author: Naroa Iriarte <naroa.iriarte <at> openbravo.com>
Date: Fri Nov 28 14:11:01 2014 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/8571b27d5fa06b32cb7425b8ec90b6cca861919b [^]

Fixed issue 28281: When using lazy filtering, funnel icon is not hidden.

When the lazy filtering is enabled, the funnel icon for clearing the filters was not hidden after clicking it.
The problem was in the "ob-grid.js" file.
The "this.filterImage.hide()" line has been added to the "clear filter" function for hidding the funnel icon. Now, when the lazy filtering is enabled
and the funnel icon is clicked for clearing the filters, the funnel icon disappears as expected.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-grid.js
---
(0072209)
AugustoMauch (developer)
2014-12-01 17:00

Code reviewed and verified in pi@8571b27d5fa0
(0073159)
hudsonbot (developer)
2014-12-30 23:26

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6525fe229e06 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2014-11-25 17:16 AugustoMauch New Issue
2014-11-25 17:16 AugustoMauch Assigned To => AugustoMauch
2014-11-25 17:16 AugustoMauch Modules => Core
2014-11-25 17:16 AugustoMauch Triggers an Emergency Pack => No
2014-11-26 08:05 alostale Relationship added related to 0028284
2014-11-28 09:18 alostale Assigned To AugustoMauch => NaroaIriarte
2014-11-28 13:55 NaroaIriarte Note Added: 0072134
2014-12-01 16:56 AugustoMauch Review Assigned To => AugustoMauch
2014-12-01 16:59 hgbot Checkin
2014-12-01 16:59 hgbot Note Added: 0072208
2014-12-01 16:59 hgbot Status new => resolved
2014-12-01 16:59 hgbot Resolution open => fixed
2014-12-01 16:59 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/8571b27d5fa06b32cb7425b8ec90b6cca861919b [^]
2014-12-01 17:00 AugustoMauch Note Added: 0072209
2014-12-01 17:00 AugustoMauch Status resolved => closed
2014-12-30 23:26 hudsonbot Checkin
2014-12-30 23:26 hudsonbot Note Added: 0073159
2018-05-16 08:52 caristu Relationship added related to 0038555
2018-05-16 08:53 caristu Relationship deleted related to 0038555
2018-05-16 08:53 caristu Relationship added causes 0038555


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker