Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0038516
TypeCategorySeverityReproducibilityDate SubmittedLast Update
feature request[Openbravo ERP] A. Platformminorhave not tried2018-05-10 13:112019-03-28 14:55
ReporterSandrahuguetView Statuspublic 
Assigned Tocaristu 
PrioritynormalResolutionfixedFixed in Version3.0PR19Q2
StatusclosedFix in branchFixed in SCM revision66f246023571
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0038516: Add a feature to allow to disable transactional filters in transactional windows easily without code changes

DescriptionThe filter being present by default in transactional windows[1] filters by not process or modified in last x days was intended to reduce set of rows shown by default and improve performance.

However without extra matching indexes that filter in fact can hurt performance in high data volumes.

It would be nice if it would be possible to deactivate that filter.

Note:
The window type (Maintain vs. Transactional) also controls that filter but changing it affects other areas (UI template, Utility.getContext) so does not seem a good choice just to disable the filter

See project page for additional information: http://wiki.openbravo.com/wiki/Projects:Disable_Transactional_Filters [^]

[1] http://wiki.openbravo.com/wiki/Standard_Windows#Transactional_Windows [^]
Steps To ReproduceN/A
Proposed SolutionIt should be possible to disable it per configuration. As most window configuration is already centralized in the "Grid configuration" that seems to be a good place for such an option.
Alternative could be a preference similar to "Disabling Linked Items".
TagsPerformance
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0038697 acknowledgedplatform in transactional filters incorrect range is displayed after modifying it 

-  Notes
(0109015)
hgbot (developer)
2019-01-18 12:57

Repository: erp/devel/pi
Changeset: 75217c44f638dfc833f567ca030c219478ea4ff3
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Fri Jan 18 12:54:55 2019 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/75217c44f638dfc833f567ca030c219478ea4ff3 [^]

related to issue 38516: Initial code cleanup

  - Use diamond operator
  - Remove the usage of the literal "false" boolean value.
  - Replaced if-then-else statement by a single return statement in isDataSourceTable()
  - Use isEmpty() to check whether the collection is empty or not
  - Removed commented-out line of code
  - Add missing "@Override" annotation above getComponentTemplate() signature
  - Iterate over the "entrySet" instead of the "keySet"
  - Put single-quotes around '/' to use the faster "indexOf(char)" method.
  - Define a constant instead of duplicating literal "OBUIAPP_PickAndExecute" 5 times

---
M modules/org.openbravo.client.application/src/org/openbravo/client/application/window/OBViewTab.java
---
(0109031)
hgbot (developer)
2019-01-21 10:04

Repository: erp/devel/pi
Changeset: 66f246023571bda1da290c9c43195b7cc5e77dbf
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Mon Jan 21 10:01:56 2019 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/66f246023571bda1da290c9c43195b7cc5e77dbf [^]

fixes issue 38516: Add ability to disable the transactional filters

---
M modules/org.openbravo.client.application/src-db/database/model/tables/OBUIAPP_GC_SYSTEM.xml
M modules/org.openbravo.client.application/src-db/database/sourcedata/AD_COLUMN.xml
M modules/org.openbravo.client.application/src-db/database/sourcedata/AD_ELEMENT.xml
M modules/org.openbravo.client.application/src-db/database/sourcedata/AD_FIELD.xml
M modules/org.openbravo.client.application/src/org/openbravo/client/application/window/OBViewTab.java
---
(0109032)
hgbot (developer)
2019-01-21 10:04

Repository: erp/devel/pi
Changeset: 9865035f0712040c0fb3c9e7b4b02795a21fcf22
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Mon Jan 21 10:03:30 2019 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/9865035f0712040c0fb3c9e7b4b02795a21fcf22 [^]

related to issue 38516: Add test cases

  - Add new ViewGenerationTest base test that can be extended when testing view generation features
  - The existing ViewGeneration test now extends ViewGenerationTest
  - Add new ConfigurableTransactionalFilters test class

---
M src-test/src/org/openbravo/test/AllAntTaskTests.java
M src-test/src/org/openbravo/test/base/TestConstants.java
M src-test/src/org/openbravo/test/views/ViewGeneration.java
M src-test/src/org/openbravo/test/views/ViewGenerationWithDifferentConfigLevelTest.java
A src-test/src/org/openbravo/test/views/ConfigurableTransactionalFilters.java
A src-test/src/org/openbravo/test/views/ViewGenerationTest.java
---
(0109033)
hgbot (developer)
2019-01-21 10:10

Repository: erp/devel/pi
Changeset: 46f6eb5a22dc360a75a0a4853056da9fb763a003
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Mon Jan 21 10:10:25 2019 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/46f6eb5a22dc360a75a0a4853056da9fb763a003 [^]

related to issue 38516: revert unintended change

---
M src-test/src/org/openbravo/test/views/ViewGenerationWithDifferentConfigLevelTest.java
---
(0109035)
caristu (developer)
2019-01-21 10:25

Documentation: http://wiki.openbravo.com/wiki/User_Interface_Introduction#Grid_Configuration [^]
(0109244)
alostale (developer)
2019-01-25 10:22

reviewed + tested
(0110738)
hudsonbot (developer)
2019-03-28 14:55

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b2fbc1588df4 [^]
Maturity status: Test
(0110742)
hudsonbot (developer)
2019-03-28 14:55

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b2fbc1588df4 [^]
Maturity status: Test
(0110743)
hudsonbot (developer)
2019-03-28 14:55

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b2fbc1588df4 [^]
Maturity status: Test
(0110744)
hudsonbot (developer)
2019-03-28 14:55

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b2fbc1588df4 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2018-05-10 13:11 Sandrahuguet New Issue
2018-05-10 13:11 Sandrahuguet Assigned To => platform
2018-05-10 13:11 Sandrahuguet Modules => Core
2018-05-10 13:11 Sandrahuguet Triggers an Emergency Pack => No
2018-05-10 13:12 Sandrahuguet Tag Attached: Performance
2018-05-10 13:13 Sandrahuguet Description Updated View Revisions
2018-05-10 13:19 shuehner Summary It would be fine to be able to disable implicit filters in transactional windows => Add a feature to allow to disable implicit filters in transactional windows easily without code changes
2018-05-10 13:19 shuehner Description Updated View Revisions
2018-06-05 09:52 alostale Relationship added related to 0038697
2019-01-18 11:24 caristu Assigned To platform => caristu
2019-01-18 11:24 caristu Summary Add a feature to allow to disable implicit filters in transactional windows easily without code changes => Add a feature to allow to disable transactional filters in transactional windows easily without code changes
2019-01-18 11:24 caristu Description Updated View Revisions
2019-01-18 11:24 caristu Proposed Solution updated
2019-01-18 11:24 caristu Proposed Solution updated
2019-01-18 11:25 caristu Description Updated View Revisions
2019-01-18 12:57 hgbot Checkin
2019-01-18 12:57 hgbot Note Added: 0109015
2019-01-21 10:04 hgbot Checkin
2019-01-21 10:04 hgbot Note Added: 0109031
2019-01-21 10:04 hgbot Status new => resolved
2019-01-21 10:04 hgbot Resolution open => fixed
2019-01-21 10:04 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/66f246023571bda1da290c9c43195b7cc5e77dbf [^]
2019-01-21 10:04 hgbot Checkin
2019-01-21 10:04 hgbot Note Added: 0109032
2019-01-21 10:10 hgbot Checkin
2019-01-21 10:10 hgbot Note Added: 0109033
2019-01-21 10:25 caristu Note Added: 0109035
2019-01-21 10:25 caristu Review Assigned To => alostale
2019-01-21 11:31 caristu Description Updated View Revisions
2019-01-23 17:42 caristu Description Updated View Revisions
2019-01-25 10:22 alostale Note Added: 0109244
2019-01-25 10:22 alostale Status resolved => closed
2019-01-25 10:22 alostale Fixed in Version => 3.0PR19Q2
2019-03-28 14:55 hudsonbot Checkin
2019-03-28 14:55 hudsonbot Note Added: 0110738
2019-03-28 14:55 hudsonbot Checkin
2019-03-28 14:55 hudsonbot Note Added: 0110742
2019-03-28 14:55 hudsonbot Checkin
2019-03-28 14:55 hudsonbot Note Added: 0110743
2019-03-28 14:55 hudsonbot Checkin
2019-03-28 14:55 hudsonbot Note Added: 0110744


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker