Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0038466
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSmajoralways2018-04-27 13:532018-06-14 12:36
ReportermaiteView Statuspublic 
Assigned Togorka_gil 
PriorityimmediateResolutionfixedFixed in VersionRR18Q3
StatusclosedFix in branchFixed in SCM revision2523a678697a
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tomarvintm
Regression level
Regression date
Regression introduced in releasemain
Regression introduced by commithttp://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/f4fb9c07eb350e512bafe7547473d226da3b7efa [^]
Triggers an Emergency PackNo
Summary

0038466: getPaymentAmount() is not being rounded and causes ticket is identified as "hasReceiptChange"=true

DescriptionWhen ticket is paid using higher amount but change is given in same currency, it should not be identified as "change"
Steps To Reproduce0. Access Terminal, select any product and set price=1500.40
1. Pay ticket setting amount=1550 (so change of 49.6 is calculated) and press done
2. Access backoffice to review the sales order and realize that payment plan information is incorrect as change amount has been identified as outstanding amount. Also, navigate to Payment document and realize that details are incorrect as gl item has been used when it should not.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 0038467RR18Q2 closedgorka_gil getPaymentAmount() is not being rounded and causes ticket is identified as "hasReceiptChange"=true 
depends on backport 0038468RR18Q1.3 closedgorka_gil getPaymentAmount() is not being rounded and causes ticket is identified as "hasReceiptChange"=true 
caused by defect 0038038 closedranjith_qualiantech_com Wrong payment documents registered in backoffice when giving change in another currency from WebPOS 

-  Notes
(0104201)
hgbot (developer)
2018-05-02 12:28

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: 2523a678697ae80e8f2557675a473eedee02c9cf
Author: Gorka Gil <gorka.gil <at> openbravo.com>
Date: Wed May 02 12:26:25 2018 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/2523a678697ae80e8f2557675a473eedee02c9cf [^]

Fixes issue 38466: Fix precision of payment amount read from json in the order loader.

Payment amount when read from json was passed to Double and then to BigDecimal which produce precision problems.
The precision problems makes that the check if there is change to be true, when in really there isn't change,
which produce the behaviour reported in the issue.

Now readed as string from json and passed directly to BigDecimal.

---
M src/org/openbravo/retail/posterminal/OrderLoader.java
---

- Issue History
Date Modified Username Field Change
2018-04-27 13:53 maite New Issue
2018-04-27 13:53 maite Assigned To => Retail
2018-04-27 13:53 maite Triggers an Emergency Pack => No
2018-04-27 13:54 maite Relationship added caused by 0038038
2018-04-27 13:54 maite Issue Monitored: networkb
2018-04-27 13:59 maite Proposed Solution updated
2018-04-27 13:59 marvintm Regression introduced in release => main
2018-04-27 13:59 marvintm Regression introduced by commit => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/f4fb9c07eb350e512bafe7547473d226da3b7efa [^]
2018-04-27 13:59 marvintm Proposed Solution updated
2018-04-27 14:01 marvintm Status new => scheduled
2018-04-30 15:35 gorka_gil Assigned To Retail => gorka_gil
2018-05-02 12:28 hgbot Checkin
2018-05-02 12:28 hgbot Note Added: 0104201
2018-05-02 12:28 hgbot Status scheduled => resolved
2018-05-02 12:28 hgbot Resolution open => fixed
2018-05-02 12:28 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/2523a678697ae80e8f2557675a473eedee02c9cf [^]
2018-05-02 13:27 marvintm Review Assigned To => marvintm
2018-05-02 13:27 marvintm Status resolved => closed
2018-05-02 13:27 marvintm Fixed in Version => RR18Q3
2018-06-13 09:07 hgbot Checkin
2018-06-13 09:07 hgbot Note Added: 0105108
2018-06-13 09:07 hgbot Status closed => resolved
2018-06-13 09:07 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/2523a678697ae80e8f2557675a473eedee02c9cf [^] => http://code.openbravo.com/erp/pmods/org.openbravo.client.analytics/rev/b5a9a67f729b4cdf06b52cf730c962415307a88a [^]
2018-06-14 12:36 jarmendariz Status resolved => closed
2018-06-14 12:36 jarmendariz Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.client.analytics/rev/b5a9a67f729b4cdf06b52cf730c962415307a88a [^] => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/2523a678697ae80e8f2557675a473eedee02c9cf [^]
2018-06-14 12:36 jarmendariz Note Deleted: 0105108


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker