Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0038465
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSmajoralways2018-04-27 13:142018-05-04 15:04
ReporterjonibcView Statuspublic 
Assigned Toranjith_qualiantech_com 
PriorityhighResolutionfixedFixed in VersionRR18Q3
StatusclosedFix in branchFixed in SCM revisiona3bbf5b2f6a2
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tomarvintm
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0038465: Cancel & Replace error: Property 'canceledorder' is not rebuilt as Backbone model.

DescriptionProperty 'canceledorder' is not rebuilt as Backbone model if an error is raised synchronizing the layaway.
Steps To ReproduceLog into Web POS:
1- Create a layaway partially paid
2- Complete the layaway
3- Open the layaway created in the previous steps.
4- Open lateral menu, select option Cancel & Replace.
5- Check that property 'canceledorder' of the receipt is present, and it is a backbone model. (Check in Chrome Developer Tools console OB.MobileApp.model.receipt.get('canceledorder'))
6- In this point modify the order to make impossible to synchronize it. (For example set in Chrome Developer Tools console : OB.MobileApp.model.receipt.get('bp').set('id','a')
7- Click on total amount, and layaway button.
8- Check that property 'canceledorder' is present in Order model, but it is a JSON Object and not a backbone model(Check in Chrome Developer Tools console OB.MobileApp.model.receipt.get('canceledorder'))
Proposed SolutionRebuilt specifically the property 'canceledorder' as Backbone model and set it correctly to the order.

Seems that the problem is in the clearWith function, that does not recover correctly the canceled order property.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0038464 closedranjith_qualiantech_com Error in Cancel & Replace: Order model is not complete after refresh the browser 

-  Notes
(0104266)
hgbot (developer)
2018-05-04 08:37

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: a3bbf5b2f6a2edad5209d6ef50888691d4fc25aa
Author: Ranjith S R <ranjith <at> qualiantech.com>
Date: Fri May 04 12:06:53 2018 +0530
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/a3bbf5b2f6a2edad5209d6ef50888691d4fc25aa [^]

Fixed issue 38465 : Added canceledorder to receipt as model instead of json on reloading the instance

---
M web/org.openbravo.retail.posterminal/js/model/order.js
---

- Issue History
Date Modified Username Field Change
2018-04-27 13:14 jonibc New Issue
2018-04-27 13:14 jonibc Assigned To => Retail
2018-04-27 13:14 jonibc Triggers an Emergency Pack => No
2018-04-27 13:14 jonibc Proposed Solution updated
2018-05-02 09:05 ranjith_qualiantech_com Assigned To Retail => ranjith_qualiantech_com
2018-05-02 11:47 ranjith_qualiantech_com Status new => scheduled
2018-05-02 12:29 ranjith_qualiantech_com Relationship added related to 0038464
2018-05-04 08:37 hgbot Checkin
2018-05-04 08:37 hgbot Note Added: 0104266
2018-05-04 08:37 hgbot Status scheduled => resolved
2018-05-04 08:37 hgbot Resolution open => fixed
2018-05-04 08:37 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/a3bbf5b2f6a2edad5209d6ef50888691d4fc25aa [^]
2018-05-04 15:04 marvintm Review Assigned To => marvintm
2018-05-04 15:04 marvintm Status resolved => closed
2018-05-04 15:04 marvintm Fixed in Version => RR18Q3


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker