Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0038464
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSmajoralways2018-04-27 12:532018-05-21 09:27
ReporterjonibcView Statuspublic 
Assigned Toranjith_qualiantech_com 
PriorityhighResolutionfixedFixed in VersionRR18Q3
StatusclosedFix in branchFixed in SCM revision66e06019d542
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tomarvintm
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0038464: Error in Cancel & Replace: Order model is not complete after refresh the browser

DescriptionOrder model is not complete after refresh the browser.

After refreshing the application the property 'canceledorder' (Backbone model representing the original order) is missing.
Steps To ReproduceLog into Web POS:
1- Create a layaway partially paid
2- Complete the layaway
3- Open the layaway created in the previous steps.
4- Open lateral menu, select option Cancel & Replace.
5- Check that property 'canceledorder' of the receipt is present. (Check in Chrome Developer Tools console OB.MobileApp.model.receipt.get('canceledorder'))
6- Refresh the browser.
7- Check that property 'canceledorder' is missed in Order model.(Check in Chrome Developer Tools console OB.MobileApp.model.receipt.get('canceledorder'))
Proposed SolutionSeems that the problem is in the clearWith function, that does not recover correctly the canceled order property.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0038465 closedranjith_qualiantech_com Cancel & Replace error: Property 'canceledorder' is not rebuilt as Backbone model. 

-  Notes
(0104512)
hgbot (developer)
2018-05-15 08:38

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: 66e06019d5422d3424e8c4365b92f6db3284a153
Author: Ranjith S R <ranjith <at> qualiantech.com>
Date: Tue May 15 12:08:25 2018 +0530
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/66e06019d5422d3424e8c4365b92f6db3284a153 [^]

Fixed issue 38464 : Added doCancelAndReplace to receipt on reloading the POS

---
M web/org.openbravo.retail.posterminal/js/model/order.js
---

- Issue History
Date Modified Username Field Change
2018-04-27 12:53 jonibc New Issue
2018-04-27 12:53 jonibc Assigned To => Retail
2018-04-27 12:53 jonibc Triggers an Emergency Pack => No
2018-05-02 09:04 ranjith_qualiantech_com Assigned To Retail => ranjith_qualiantech_com
2018-05-02 11:46 ranjith_qualiantech_com Status new => scheduled
2018-05-02 12:29 ranjith_qualiantech_com Relationship added related to 0038465
2018-05-15 08:38 hgbot Checkin
2018-05-15 08:38 hgbot Note Added: 0104512
2018-05-15 08:38 hgbot Status scheduled => resolved
2018-05-15 08:38 hgbot Resolution open => fixed
2018-05-15 08:38 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/66e06019d5422d3424e8c4365b92f6db3284a153 [^]
2018-05-21 09:27 marvintm Review Assigned To => marvintm
2018-05-21 09:27 marvintm Status resolved => closed
2018-05-21 09:27 marvintm Fixed in Version => RR18Q3


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker