Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0038451
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] A. Platformminorhave not tried2018-04-25 14:182018-04-27 13:09
ReportercaristuView Statuspublic 
Assigned Tocaristu 
PriorityhighResolutionfixedFixed in Version3.0PR18Q2
StatusclosedFix in branchFixed in SCM revisionb139b9c81651
ProjectionnoneETAnoneTarget Version3.0PR18Q2
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0038451: Allow to download attachments in temporary files using the attachment name without concurrency problems

DescriptionAllow to download attachments in temporary files using the attachment name itself without having (possible) concurrency problems in case two users download the same attachment at the same time.

Steps To ReproduceIn description
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 0038450 closedcaristu Allow to download attachments in temporary files using the attachment name without concurrency problems 

-  Notes
(0104081)
hgbot (developer)
2018-04-25 16:02

Repository: erp/backports/3.0PR18Q2
Changeset: b139b9c81651c2bac8e03bf0483a997970cdd13d
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Wed Apr 25 15:50:10 2018 +0200
URL: http://code.openbravo.com/erp/backports/3.0PR18Q2/rev/b139b9c81651c2bac8e03bf0483a997970cdd13d [^]

fixes bug 38451: Remove temp file's directory used to download the attachment

  Now the AttachImplementationManager deletes also the temp file's directory used to download the attachment. This change only affects to those attach implementations which return the downloaded attachment inside a temporary file.

  With this change now that attach implementations are able generate those temporary files with any name by creating them inside folders with random names. This is intended to avoid concurrency problems in case two users download the same attachment at the same time.

---
M modules/org.openbravo.client.application/src/org/openbravo/client/application/attachment/AttachImplementationManager.java
---
(0104083)
hgbot (developer)
2018-04-25 16:16

Repository: erp/backports/3.0PR18Q2
Changeset: 5e0d86cedd3380dec7aa7df9fd9692367c692053
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Wed Apr 25 16:14:22 2018 +0200
URL: http://code.openbravo.com/erp/backports/3.0PR18Q2/rev/5e0d86cedd3380dec7aa7df9fd9692367c692053 [^]

related to issue 38451: apply the logic on "Download All" also

---
M modules/org.openbravo.client.application/src/org/openbravo/client/application/attachment/AttachImplementationManager.java
---
(0104159)
alostale (developer)
2018-04-27 13:09

reviewed + tested

- Issue History
Date Modified Username Field Change
2018-04-25 14:18 caristu Type defect => backport
2018-04-25 14:18 caristu Target Version => 3.0PR18Q2
2018-04-25 16:02 hgbot Checkin
2018-04-25 16:02 hgbot Note Added: 0104081
2018-04-25 16:02 hgbot Status scheduled => resolved
2018-04-25 16:02 hgbot Resolution open => fixed
2018-04-25 16:02 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/backports/3.0PR18Q2/rev/b139b9c81651c2bac8e03bf0483a997970cdd13d [^]
2018-04-25 16:03 caristu Assigned To platform => caristu
2018-04-25 16:04 caristu Review Assigned To => alostale
2018-04-25 16:16 hgbot Checkin
2018-04-25 16:16 hgbot Note Added: 0104083
2018-04-27 13:09 alostale Note Added: 0104159
2018-04-27 13:09 alostale Status resolved => closed
2018-04-27 13:09 alostale Fixed in Version => 3.0PR18Q2


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker