Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0038450
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminorhave not tried2018-04-25 14:182018-05-09 19:29
ReportercaristuView Statuspublic 
Assigned Tocaristu 
PriorityhighResolutionfixedFixed in Version3.0PR18Q3
StatusclosedFix in branchFixed in SCM revision87ee63f96d1f
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0038450: Allow to download attachments in temporary files using the attachment name without concurrency problems

DescriptionAllow to download attachments in temporary files using the attachment name itself without having (possible) concurrency problems in case two users download the same attachment at the same time.

Steps To ReproduceIn description
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0038188 closedcaristu Concurrency problem when downloading attachments with attachment methods that downloads temp files 
depends on backport 00384513.0PR18Q2 closedcaristu Allow to download attachments in temporary files using the attachment name without concurrency problems 

-  Notes
(0104080)
hgbot (developer)
2018-04-25 15:59

Repository: erp/devel/pi
Changeset: 87ee63f96d1f75f0539a54f9c340e8e83571a43e
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Wed Apr 25 15:50:10 2018 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/87ee63f96d1f75f0539a54f9c340e8e83571a43e [^]

fixes bug 38450: Remove temp file's directory used to download the attachment

  Now the AttachImplementationManager deletes also the temp file's directory used to download the attachment. This change only affects to those attach implementations which return the downloaded attachment inside a temporary file.

  With this change now that attach implementations are able generate those temporary files with any name by creating them inside folders with random names. This is intended to avoid concurrency problems in case two users download the same attachment at the same time.

---
M modules/org.openbravo.client.application/src/org/openbravo/client/application/attachment/AttachImplementationManager.java
---
(0104082)
hgbot (developer)
2018-04-25 16:15

Repository: erp/devel/pi
Changeset: d79617fce296c7e92706dddb63d4459dda7959c2
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Wed Apr 25 16:14:22 2018 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/d79617fce296c7e92706dddb63d4459dda7959c2 [^]

related to issue 38450: apply the logic on "Download All" also

---
M modules/org.openbravo.client.application/src/org/openbravo/client/application/attachment/AttachImplementationManager.java
---
(0104158)
alostale (developer)
2018-04-27 13:09

reviewed + tested
(0104398)
hudsonbot (developer)
2018-05-09 19:29

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/2be7d3efe606 [^]
Maturity status: Test
(0104399)
hudsonbot (developer)
2018-05-09 19:29

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/2be7d3efe606 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2018-04-25 14:18 caristu New Issue
2018-04-25 14:18 caristu Assigned To => platform
2018-04-25 14:18 caristu Modules => Core
2018-04-25 14:18 caristu Triggers an Emergency Pack => No
2018-04-25 14:18 caristu Status new => scheduled
2018-04-25 15:48 caristu Relationship added related to 0038188
2018-04-25 15:59 hgbot Checkin
2018-04-25 15:59 hgbot Note Added: 0104080
2018-04-25 15:59 hgbot Status scheduled => resolved
2018-04-25 15:59 hgbot Resolution open => fixed
2018-04-25 15:59 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/87ee63f96d1f75f0539a54f9c340e8e83571a43e [^]
2018-04-25 16:00 caristu Assigned To platform => caristu
2018-04-25 16:00 caristu Review Assigned To => alostale
2018-04-25 16:15 hgbot Checkin
2018-04-25 16:15 hgbot Note Added: 0104082
2018-04-27 13:09 alostale Note Added: 0104158
2018-04-27 13:09 alostale Status resolved => closed
2018-04-27 13:09 alostale Fixed in Version => 3.0PR18Q3
2018-05-09 19:29 hudsonbot Checkin
2018-05-09 19:29 hudsonbot Note Added: 0104398
2018-05-09 19:29 hudsonbot Checkin
2018-05-09 19:29 hudsonbot Note Added: 0104399


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker