Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0038386
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 04. Warehouse managementmajoralways2018-04-17 11:162018-05-15 20:43
ReporterVictorVillarView Statuspublic 
Assigned ToAtulOpenbravo 
PriorityurgentResolutionfixedFixed in Version3.0PR18Q3
StatusclosedFix in branchFixed in SCM revision4bf53115b637
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toaferraz
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0038386: Same search key can be used twice in warehouse definition

DescriptionSame search key can be used twice in warehouse definition and it should not.
Steps To ReproduceGo to Warehouse Definition window
  Create two new warehouses with the same Search Keys.

Same search key can be used twice in warehouse definition and it should not.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on defect 0038504 closedAtulOpenbravo API Change request 

-  Notes
(0104210)
collazoandy4 (developer)
2018-05-02 17:33

Go to Warehouse Definition window
  Create two new warehouses with the same Search Keys and check when you try to save the second an error message is shown indicating an unique constraints
(0104467)
aferraz (developer)
2018-05-11 11:15

We need to include a build validation to check if exists data violating the new contraint.
(0104518)
AtulOpenbravo (developer)
2018-05-15 12:17

Test plan to test build validation

- In a latest pi instance with Core Module version 3.0.33954, apply the patch.
- In database or from GUI, navigate to warehouse record with name "España Región Sur" and search key (value) as RN.
- Run update.database or smartbuild -Dlocal=no -Dforce=true task.
- Realize that in the console following error is shown

Due to a database constraint modification, is no longer allowed to have the same Warehouse search key more than once within client. There exists data in your database that do not fit this new constraint. Please review following:-

Client: F&B International Group, Search Key: RN, Warehouse: España Región Norte
Client: F&B International Group, Search Key: RN, Warehouse: España Región Sur

- In database or GUI, navigate to warehouse record with name "España Región Sur" and set search key (value) back to RS.
- Run update.database or smartbuild -Dlocal=no -Dforce=true task.
- Realize that compilation is executed further without any error.

Above test plan executed successfully in oracle instance.
(0104521)
hgbot (developer)
2018-05-15 16:24

Repository: erp/devel/api-checks
Changeset: 572d07a104069869dd0a0ae27b00cb9b278dd3cd
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Tue May 15 16:07:23 2018 +0200
URL: http://code.openbravo.com/erp/devel/api-checks/rev/572d07a104069869dd0a0ae27b00cb9b278dd3cd [^]

Fixes issue 38504: API change for issue 38386

---
M model/src-db/database/model/tables/M_WAREHOUSE.xml
---
(0104523)
hgbot (developer)
2018-05-15 16:24

Repository: erp/devel/pi
Changeset: 4bf53115b63752e1c7a0053811aae3a9e12e0965
Author: Armaignac <collazoandy4 <at> gmail.com>
Date: Tue May 01 18:01:20 2018 -0400
URL: http://code.openbravo.com/erp/devel/pi/rev/4bf53115b63752e1c7a0053811aae3a9e12e0965 [^]

Fixes issue 38386: Same search key can be used twice in warehouse definition

The same Search Key in warehouse and storage bin can be used twice because a missing
constraint

An unique constraints was added to warehouse definition.

---
M src-db/database/model/tables/M_WAREHOUSE.xml
---
(0104524)
hgbot (developer)
2018-05-15 16:24

Repository: erp/devel/pi
Changeset: 78f6e305eb5e34f21d1c36d1f0f4fb1f40eba378
Author: Atul Gaware <atul.gaware <at> openbravo.com>
Date: Tue May 15 15:33:25 2018 +0530
URL: http://code.openbravo.com/erp/devel/pi/rev/78f6e305eb5e34f21d1c36d1f0f4fb1f40eba378 [^]

Related to issue 38386: Same search key can be used twice in
warehouse definition

A build validation to check whether there exists a warehouse
with same value within client to avoid failure of build
when adding a unique constraint for client and value in
m_warehouse table.

---
A src-util/buildvalidation/build/classes/org/openbravo/buildvalidation/DuplicatedClientWarehouseValue.class
A src-util/buildvalidation/build/classes/org/openbravo/buildvalidation/DuplicatedClientWarehouseValueData.class
A src-util/buildvalidation/src/org/openbravo/buildvalidation/DuplicatedClientWarehouseValue.java
A src-util/buildvalidation/src/org/openbravo/buildvalidation/DuplicatedClientWarehouseValue_data.xsql
---
(0104526)
aferraz (developer)
2018-05-15 16:34

Code review + Testing OK
(0104535)
hudsonbot (developer)
2018-05-15 20:43

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/79b08258a2aa [^]
Maturity status: Test
(0104536)
hudsonbot (developer)
2018-05-15 20:43

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/79b08258a2aa [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2018-04-17 11:16 VictorVillar New Issue
2018-04-17 11:16 VictorVillar Assigned To => dmiguelez
2018-04-17 12:28 ngarcia Issue Monitored: ngarcia
2018-04-18 16:45 dmiguelez Assigned To dmiguelez => Triage Finance
2018-04-19 13:18 dmiguelez Project Modules => Openbravo ERP
2018-04-19 13:21 dmiguelez Modules => Core
2018-04-19 13:21 dmiguelez Triggers an Emergency Pack => No
2018-04-19 13:21 dmiguelez Category Advance Warehouse Operations => 04. Warehouse management
2018-04-20 11:20 dmiguelez Assigned To Triage Finance => collazoandy4
2018-04-25 10:08 dmiguelez Assigned To collazoandy4 => AtulOpenbravo
2018-04-30 23:27 collazoandy4 Assigned To AtulOpenbravo => collazoandy4
2018-04-30 23:27 collazoandy4 Status new => scheduled
2018-05-02 17:33 collazoandy4 Note Added: 0104210
2018-05-08 17:31 collazoandy4 Relationship added blocks 0038504
2018-05-08 17:52 aferraz Relationship replaced depends on 0038504
2018-05-11 11:08 aferraz Assigned To collazoandy4 => AtulOpenbravo
2018-05-11 11:15 aferraz Note Added: 0104467
2018-05-11 11:15 aferraz Status scheduled => feedback
2018-05-11 11:15 aferraz Status feedback => new
2018-05-14 10:16 AtulOpenbravo Status new => scheduled
2018-05-15 12:17 AtulOpenbravo Note Added: 0104518
2018-05-15 16:24 hgbot Checkin
2018-05-15 16:24 hgbot Note Added: 0104521
2018-05-15 16:24 hgbot Checkin
2018-05-15 16:24 hgbot Note Added: 0104523
2018-05-15 16:24 hgbot Status scheduled => resolved
2018-05-15 16:24 hgbot Resolution open => fixed
2018-05-15 16:24 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/4bf53115b63752e1c7a0053811aae3a9e12e0965 [^]
2018-05-15 16:24 hgbot Checkin
2018-05-15 16:24 hgbot Note Added: 0104524
2018-05-15 16:34 aferraz Review Assigned To => aferraz
2018-05-15 16:34 aferraz Note Added: 0104526
2018-05-15 16:34 aferraz Status resolved => closed
2018-05-15 16:34 aferraz Fixed in Version => 3.0PR18Q3
2018-05-15 20:43 hudsonbot Checkin
2018-05-15 20:43 hudsonbot Note Added: 0104535
2018-05-15 20:43 hudsonbot Checkin
2018-05-15 20:43 hudsonbot Note Added: 0104536


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker