Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0038158
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] Z. Othersmajoralways2018-03-16 11:562018-05-09 19:29
ReporterngarciaView Statuspublic 
Assigned Tocaristu 
PriorityurgentResolutionfixedFixed in Version3.0PR18Q3
StatusclosedFix in branchFixed in SCM revision4ed727aa048a
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesAdvanced Payables and Receivables Mngmt
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0038158: Payment details are lost if the payment is reactivated and Transaction Type is changed: credit is generated instead

DescriptionPayment details are lost if the payment is reactivated and Transaction Type is changed: credit is generated instead
Steps To ReproduceAs group admin role:
   Create two sales orders for same business partner, set their invoice terms as Immediate and book them
   Create a sales invoice for that business partner and add previously created two orders
   Complete it
   Create a Payment In header, set that business partner
   When adding details, select Transaction Type: Invoices
   Add the pending amount amount and process it
   Go to Financial Account, reactivate and remove the associated transaction in case it was automatically created
   Reactivate the payment selecting the Reactivate option (not deleting lines)
   Add details
   Change Transaction Type to Orders and invoices
   Check the lines are shown as selected
   Process it
   Check the payment lines disappear and a line with the generated credit is shown
   Payment In header is updated with the generated credit and description
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0103713)
caristu (developer)
2018-04-06 13:15
edited on: 2018-04-11 16:15

When clicking on "Done" first a validation is executed on the server, when returning, the standard action handler is called using the actionHandlerCall() function[1]

At this point, the selection of the grid is not retrieved properly and this is because at this point the pneSelectedRecords[2] is empty (but there are records indeed selected on the grid load).

It must be reviewed why pneSelectedRecords is empty at that point.

[1] https://code.openbravo.com/erp/devel/pi/file/tip/modules/org.openbravo.advpaymentmngt/web/org.openbravo.advpaymentmngt/js/ob-aprm-addPayment.js#l1191 [^]
[2] https://code.openbravo.com/erp/devel/pi/file/tip/modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-pickeditgrid.js#l101 [^]

(0103821)
hgbot (developer)
2018-04-11 16:12

Repository: erp/devel/pi
Changeset: 4ed727aa048a7b09aaa54b5a992c06b50dfff762
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Wed Apr 11 10:24:48 2018 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/4ed727aa048a7b09aaa54b5a992c06b50dfff762 [^]

fixes bug 38158: wrong selection handling on trx type change in Add Payment

  The order_invoice grid of the Add Payment process implements its own mechanism to keep the selected records when changing the transaction type. This mechanism was not keeping the pneSelectedRecords array properly updated which in this case is the source eventually used to send the selection to the backend.

---
M modules/org.openbravo.advpaymentmngt/web/org.openbravo.advpaymentmngt/js/ob-aprm-addPayment.js
---
(0103867)
alostale (developer)
2018-04-13 09:05

reviewed + tested
(0104372)
hudsonbot (developer)
2018-05-09 19:29

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/2be7d3efe606 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2018-03-16 11:56 ngarcia New Issue
2018-03-16 11:56 ngarcia Assigned To => Triage Finance
2018-03-16 11:56 ngarcia Modules => Advanced Payables and Receivables Mngmt
2018-03-16 11:56 ngarcia Triggers an Emergency Pack => No
2018-03-16 12:54 aferraz Assigned To Triage Finance => AtulOpenbravo
2018-03-16 14:46 ngarcia Issue Monitored: networkb
2018-04-04 19:39 AtulOpenbravo Status new => scheduled
2018-04-06 12:06 dmiguelez Assigned To AtulOpenbravo => caristu
2018-04-06 13:15 caristu Note Added: 0103713
2018-04-06 13:15 caristu Assigned To caristu => platform
2018-04-06 13:16 caristu Status scheduled => acknowledged
2018-04-10 19:25 caristu Assigned To platform => caristu
2018-04-10 19:26 caristu Status acknowledged => scheduled
2018-04-11 16:12 hgbot Checkin
2018-04-11 16:12 hgbot Note Added: 0103821
2018-04-11 16:12 hgbot Status scheduled => resolved
2018-04-11 16:12 hgbot Resolution open => fixed
2018-04-11 16:12 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/4ed727aa048a7b09aaa54b5a992c06b50dfff762 [^]
2018-04-11 16:15 caristu Review Assigned To => alostale
2018-04-11 16:15 caristu Note Edited: 0103713 View Revisions
2018-04-13 09:05 alostale Note Added: 0103867
2018-04-13 09:05 alostale Status resolved => closed
2018-04-13 09:05 alostale Fixed in Version => 3.0PR18Q3
2018-05-09 19:29 hudsonbot Checkin
2018-05-09 19:29 hudsonbot Note Added: 0104372


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker