Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0037881
TypeCategorySeverityReproducibilityDate SubmittedLast Update
feature request[Openbravo ERP] 09. Financial managementminorhave not tried2018-02-11 13:232018-04-11 17:05
ReportershuehnerView Statuspublic 
Assigned Toshuehner 
PrioritynormalResolutionfixedFixed in Version3.0PR18Q3
StatusclosedFix in branchFixed in SCM revisionef587ec4fac7
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tovmromanos
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0037881: Remove report "Promissory Note" based on old fop technology and only use for old pre-aprm flow in deactivated window.

DescriptionThe report "Promissory Note" is used for print button in 3 tabs:
- Sales Invoice, tab "Payment"
- Purchase Invoice, tab "Payment"
Both above are deactivated tabs.
- Settlement, tab "Created Payments"
For this one the whole window is not active by default.

The report uses the old fop rendering technology planned to be removed eventually.

Apart is prints data from old pre-aprm system using table c_debt_payment.
APRM is mandatory since start of 3.0
Steps To Reproduce-
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0038320 closedshuehner Openbravo ERP API-Change for removal of 4 obsolete fop-related reports (RptM_Inout, RptM_Movement, RptC_Settlement, PromissoryNote) 
related to defect 0038321 closedshuehner Retail Modules Retail issue to update all 3 retail sampledata's in relation to 4 ad_process deletions in pi. 
blocks feature request 0037874 closedalostale Openbravo ERP Remove support for fop rendering from core product as very nearly not used 

-  Notes
(0102310)
shuehner (administrator)
2018-02-11 13:25

Note use of the ad_process_id 800101 could be found in pi or getAllModules except the 3 tabs mentioned above.
(0102311)
shuehner (administrator)
2018-02-11 13:28

Apart parts of that report (function debtPaymentTree) has hard-coded Spanish language text in it shown in the report. Making it useless in other languages.
(0103794)
hgbot (developer)
2018-04-10 21:13

Repository: erp/devel/pi
Changeset: ef587ec4fac7a7f972d366e049d48ee2c58b92b6
Author: Stefan Hühner <stefan.huehner <at> openbravo.com>
Date: Sun Feb 11 13:47:02 2018 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/ef587ec4fac7a7f972d366e049d48ee2c58b92b6 [^]

Fixed 37881. Remove obsolete (pre-aprm) old flow report Promissory Note.

That report uses old fop rendering technology and is related to the old
payment flow from before aprm which is mandatory since start of 3.0
It is only referenced in 3 deactivated tabs related to that old flow.

---
M referencedata/sampledata/F_B_International_Group/AD_PROCESS_ACCESS.xml
M referencedata/sampledata/QA_Testing/AD_PROCESS_ACCESS.xml
M src-db/database/sourcedata/AD_MODEL_OBJECT.xml
M src-db/database/sourcedata/AD_MODEL_OBJECT_MAPPING.xml
M src-db/database/sourcedata/AD_PROCESS.xml
M src-db/database/sourcedata/AD_TAB.xml
M src-db/database/sourcedata/AD_TEXTINTERFACES.xml
R src/org/openbravo/erpReports/RptPromissoryNote.fo
R src/org/openbravo/erpReports/RptPromissoryNote.java
R src/org/openbravo/erpReports/RptPromissoryNote.xml
R src/org/openbravo/erpReports/RptPromissoryNoteAfter.fo
R src/org/openbravo/erpReports/RptPromissoryNoteAfter.xml
R src/org/openbravo/erpReports/RptPromissoryNoteAfter_data.xsql
R src/org/openbravo/erpReports/RptPromissoryNoteError.fo
R src/org/openbravo/erpReports/RptPromissoryNoteError.xml
R src/org/openbravo/erpReports/RptPromissoryNoteError_data.xsql
R src/org/openbravo/erpReports/RptPromissoryNoteHeader.fo
R src/org/openbravo/erpReports/RptPromissoryNoteHeader.xml
R src/org/openbravo/erpReports/RptPromissoryNoteHeader_data.xsql
R src/org/openbravo/erpReports/RptPromissoryNoteTree_data.xsql
R src/org/openbravo/erpReports/RptPromissoryNote_data.xsql
---
(0103825)
vmromanos (developer)
2018-04-11 17:05

Code review OK.

Stuff belonging to old payment flow

- Issue History
Date Modified Username Field Change
2018-02-11 13:23 shuehner New Issue
2018-02-11 13:23 shuehner Assigned To => shuehner
2018-02-11 13:23 shuehner Modules => Core
2018-02-11 13:23 shuehner Triggers an Emergency Pack => No
2018-02-11 13:25 shuehner Note Added: 0102310
2018-02-11 13:28 shuehner Note Added: 0102311
2018-02-11 14:16 shuehner Relationship added blocks 0037874
2018-04-10 21:00 shuehner Relationship added related to 0038320
2018-04-10 21:04 shuehner Relationship added related to 0038321
2018-04-10 21:13 hgbot Checkin
2018-04-10 21:13 hgbot Note Added: 0103794
2018-04-10 21:13 hgbot Status new => resolved
2018-04-10 21:13 hgbot Resolution open => fixed
2018-04-10 21:13 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/ef587ec4fac7a7f972d366e049d48ee2c58b92b6 [^]
2018-04-10 21:18 shuehner Review Assigned To => vmromanos
2018-04-11 17:05 vmromanos Note Added: 0103825
2018-04-11 17:05 vmromanos Status resolved => closed
2018-04-11 17:05 vmromanos Fixed in Version => 3.0PR18Q3
2018-12-24 13:42 alostale Relationship added blocks 0039848


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker