Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0037853
TypeCategorySeverityReproducibilityDate SubmittedLast Update
feature request[Openbravo ERP] A. Platformminorhave not tried2018-02-07 14:472019-05-17 09:07
ReportershuehnerView Statuspublic 
Assigned Toalostale 
PrioritynormalResolutionfixedFixed in Version3.0PR19Q3
StatusclosedFix in branchFixed in SCM revision3ad31745f63e
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tocaristu
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0037853: ImportEntryManager.reportsStatus only does long time avg, useless to see any short term changes

DescriptionImportEntryManager tracks some performance statistics (runtime) per 'typeofdata' and prints those every 100 records processed.

Example lines:
2018-02-06 21:01:01,493 INFO org.openbravo.service.importprocess.ImportEntryManager - Timings for Order cnt: 61900 avg millis: 901
2018-02-07 09:42:31,044 INFO org.openbravo.service.importprocess.ImportEntryManager - Timings for Order cnt: 100 avg millis: 3741

However the avg is calculated as 'sum of all time of all records' / total-count

Problem is that this is then long-term average since tomcat start which is useless and can be misleading.

Example:
Spike in processing time for a while.
System recovers back to normal time.

As avg is over both it will return very very slow only to the 'current' speed.

More useful could be:
- avg of 'last 100 records'

Maybe useful to keep the long-term avg also by tracking both internally.
Steps To Reproduce-
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to design defect 0036162 acknowledgedplatform clean up openbravo.log 
related to defect 0040747 closedalostale Unnecessary wait in Import Entry Manager is causing lag in the processing of import entries even if resources are available 
related to feature request 0040765 acknowledgedplatform expose ImportEntryManager statistics via jmx 

-  Notes
(0102252)
shuehner (administrator)
2018-02-07 14:48

Apart maybe useful to expose those numbers via jmx.
Also could be useful to add a resetStats jmx-callable operation.
(0111519)
hgbot (developer)
2019-05-07 08:02

Repository: erp/devel/pi
Changeset: 3ad31745f63eb1fab22f5a6d4da526bbde7b9f94
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Fri May 03 14:06:11 2019 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/3ad31745f63eb1fab22f5a6d4da526bbde7b9f94 [^]

fixes 37853: improved ImportEntryManager logs

  - Log partial timing statistics for the last 100 entries processed keeping also
    total statisitcs since last restart
  - Include process time for each processed entry
  - ImportEntryProcessor.addEntry
     * Set key to runnable before adding entry so it gets properly logged
     * In all logs include type of data and key to know if problems occur in a
       single processor
     * Increase from debug to warn log level message when processor's quee is
       completelly full. This should really exceptional and worth to make it
       visible in log as it might indicate sever problems

---
M src/org/openbravo/service/importprocess/ImportEntryManager.java
M src/org/openbravo/service/importprocess/ImportEntryProcessor.java
---
(0111760)
caristu (developer)
2019-05-17 09:07

Reviewed

- Issue History
Date Modified Username Field Change
2018-02-07 14:47 shuehner New Issue
2018-02-07 14:47 shuehner Assigned To => platform
2018-02-07 14:47 shuehner Modules => Core
2018-02-07 14:47 shuehner Triggers an Emergency Pack => No
2018-02-07 14:48 shuehner Note Added: 0102252
2018-02-07 18:09 shuehner Type defect => feature request
2018-02-08 08:16 alostale Status new => acknowledged
2018-02-08 08:16 alostale Relationship added related to 0036162
2019-05-03 13:33 alostale Assigned To platform => alostale
2019-05-03 13:44 alostale Relationship added related to 0040747
2019-05-03 13:45 alostale Review Assigned To => caristu
2019-05-03 13:47 alostale Relationship added related to 0040765
2019-05-07 08:02 hgbot Checkin
2019-05-07 08:02 hgbot Note Added: 0111519
2019-05-07 08:02 hgbot Status acknowledged => resolved
2019-05-07 08:02 hgbot Resolution open => fixed
2019-05-07 08:02 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/3ad31745f63eb1fab22f5a6d4da526bbde7b9f94 [^]
2019-05-17 09:07 caristu Note Added: 0111760
2019-05-17 09:07 caristu Status resolved => closed
2019-05-17 09:07 caristu Fixed in Version => 3.0PR19Q3


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker