Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0037688
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSminoralways2018-01-19 11:102018-01-24 14:13
ReportermigueldejuanaView Statuspublic 
Assigned Tomigueldejuana 
PrioritynormalResolutionfixedFixed in VersionRR18Q2
StatusclosedFix in branchFixed in SCM revisionb3f034cd8aef
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tomarvintm
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0037688: Remove unneeded receipt save which causes performance problems

DescriptionAfter every change in the receipt, calculateReceipt is executed. Inside this function, we do a save of the order in the local database.

All the interactions with the local database must be avoided because the performance get affected.

We need to remove all saves of the receipt done before doing calculateReceipt because they are not needed and make performance to be bad.
Steps To ReproduceSee Desc.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 0037690RR18Q1 closedmigueldejuana Remove unneeded receipt save which causes performance problems 
depends on backport 0037691RR17Q4.1 closedmigueldejuana Remove unneeded receipt save which causes performance problems 
depends on backport 0037692RR17Q3.3 closedmigueldejuana Remove unneeded receipt save which causes performance problems 

-  Notes
(0101778)
hgbot (developer)
2018-01-19 11:12

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: b6d3bbc589ba8c79d86245b6f067364b87040ffe
Author: Miguel de Juana <miguel.dejuana <at> openbravo.com>
Date: Fri Jan 19 11:11:45 2018 +0100
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/b6d3bbc589ba8c79d86245b6f067364b87040ffe [^]

Fixed issue 0037688: Remove unneeded receipt save which causes performance problems

- Remove unneeded receipt save to improve performance

---
M web/org.openbravo.retail.posterminal/js/model/order.js
---
(0101785)
marvintm (developer)
2018-01-19 12:15

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: 8687c3aebeb893002b171d0f696ae540358ca0ff
Author: Miguel de Juana <miguel.dejuana <at> openbravo.com>
Date: Fri Jan 19 12:08:50 2018 +0100
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/8687c3aebeb893002b171d0f696ae540358ca0ff [^] [^]

Fixed issue 0036893: If WebPOS is on Payment Tab it should not be possible to add products

-Mantain the check for corner case when a line is added while the order is be send to backend. Remove from rfid buffers the line because it is not added

---
M web/org.openbravo.retail.posterminal/js/model/order.js
---
(0101786)
marvintm (developer)
2018-01-19 12:15

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: d61149f258b8f73a8abda9dd265720369aeefba7
Author: Miguel de Juana <miguel.dejuana <at> openbravo.com>
Date: Fri Jan 19 12:13:01 2018 +0100
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/d61149f258b8f73a8abda9dd265720369aeefba7 [^] [^]

Fixed issue 0036893: If WebPOS is on Payment Tab it should not be possible to add products

- if isCalculateReceiptLocked is TRUE we must log the problem and remove from rfid buffers the product

---
M web/org.openbravo.retail.posterminal/js/model/order.js
---
(0101900)
hgbot (developer)
2018-01-23 11:47

Repository: retail/backports/3.0RR17Q3.3/org.openbravo.retail.posterminal
Changeset: b3f034cd8aefcd826dd352363a3bb63c03b90596
Author: Miguel de Juana <miguel.dejuana <at> openbravo.com>
Date: Tue Jan 23 11:47:12 2018 +0100
URL: http://code.openbravo.com/retail/backports/3.0RR17Q3.3/org.openbravo.retail.posterminal/rev/b3f034cd8aefcd826dd352363a3bb63c03b90596 [^]

Fixed issue 0037688: Remove unneeded receipt save which causes performance problems

- Remove unneeded receipt save to improve performance
-Mantain the check for corner case when a line is added while the order is be send to backend. Remove from rfid buffers the line because it is not added

---
M web/org.openbravo.retail.posterminal/js/model/order.js
---

- Issue History
Date Modified Username Field Change
2018-01-19 11:10 migueldejuana New Issue
2018-01-19 11:10 migueldejuana Assigned To => migueldejuana
2018-01-19 11:10 migueldejuana Triggers an Emergency Pack => No
2018-01-19 11:12 hgbot Checkin
2018-01-19 11:12 hgbot Note Added: 0101778
2018-01-19 11:12 hgbot Status new => resolved
2018-01-19 11:12 hgbot Resolution open => fixed
2018-01-19 11:12 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/b6d3bbc589ba8c79d86245b6f067364b87040ffe [^]
2018-01-19 12:02 jorgewederago Issue Monitored: jorgewederago
2018-01-19 12:15 marvintm Note Added: 0101785
2018-01-19 12:15 marvintm Note Added: 0101786
2018-01-19 12:17 marvintm Review Assigned To => marvintm
2018-01-19 12:17 marvintm Status resolved => closed
2018-01-19 12:17 marvintm Fixed in Version => RR18Q2
2018-01-19 12:17 marvintm Status closed => new
2018-01-19 12:17 marvintm Resolution fixed => open
2018-01-19 12:17 marvintm Fixed in Version RR18Q2 =>
2018-01-19 12:18 marvintm Status new => scheduled
2018-01-19 12:18 marvintm Status scheduled => resolved
2018-01-19 12:18 marvintm Fixed in Version => RR18Q2
2018-01-19 12:18 marvintm Resolution open => fixed
2018-01-19 12:18 marvintm Status resolved => closed
2018-01-23 11:47 hgbot Checkin
2018-01-23 11:47 hgbot Note Added: 0101900
2018-01-23 11:47 hgbot Status closed => resolved
2018-01-23 11:47 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/b6d3bbc589ba8c79d86245b6f067364b87040ffe [^] => http://code.openbravo.com/retail/backports/3.0RR17Q3.3/org.openbravo.retail.posterminal/rev/b3f034cd8aefcd826dd352363a3bb63c03b90596 [^]
2018-01-24 14:13 marvintm Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker