Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0037493
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSmajoralways2017-12-15 14:042018-09-18 13:57
ReportermalsasuaView Statuspublic 
Assigned Toranjith_qualiantech_com 
PrioritynormalResolutionfixedFixed in VersionRR18Q2
StatusclosedFix in branchFixed in SCM revision0845d04a4512
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tomarvintm
Regression levelProduction - QA Approved
Regression date
Regression introduced in releaseRR17Q3
Regression introduced by commithttps://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/6c03b70eb5d2a2b7a9a396ae49a36eb434b48c4b [^]
Triggers an Emergency PackNo
Summary

0037493: Error using credit in return receipts with complex payment terms

DescriptionIf one return receipt is paid using credit, and the payment method of business partner is complex (more than one line), the Sales Order is stuck in Error While Importing with the error:
java.lang.NullPointerException
    at sun.util.calendar.ZoneInfo.inDaylightTime(ZoneInfo.java:501)
    at org.openbravo.advpaymentmngt.utility.FIN_Utility.getDaysBetween(FIN_Utility.java:678)
    at org.openbravo.advpaymentmngt.utility.FIN_Utility.getDaysToDue(FIN_Utility.java:669)
    at org.openbravo.retail.posterminal.OrderLoader.handlePayments(OrderLoader.java:2431)
    at org.openbravo.retail.posterminal.OrderLoader.saveRecord(OrderLoader.java:542)
Steps To ReproduceBO:
. configure terminal type to allow use credit
. configure Arturo Montoro with payment term:
   "20% a 15 días, 40% a 30 días y resto a 60 días"

POS:
. create a new return receipt to Arturo Montoro
. pay it using credit

BO:
. go to Errors While Importing window
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0037573 closedranjith_qualiantech_com Cannot pay the Sales Invoice associated to a verified receipt paid on credit 
depends on backport 0037594RR18Q1 closedranjith_qualiantech_com Error using credit in return receipts with complex payment terms 
depends on backport 0037595RR17Q4.1 closedranjith_qualiantech_com Error using credit in return receipts with complex payment terms 
depends on backport 0037596RR17Q3.3 closedranjith_qualiantech_com Error using credit in return receipts with complex payment terms 
caused by design defect 0035571 closedranjith_qualiantech_com wrong payment term in sales invoice created from WebPOS using credit 
related to defect 0037753 closedranjith_qualiantech_com wrong amount in payment plan using credit and complex payment terms 

-  Notes
(0101637)
hgbot (developer)
2018-01-09 12:12

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: 0845d04a4512cc10542f5f038ca75da51efdb15e
Author: Ranjith S R <ranjith <at> qualiantech.com>
Date: Tue Jan 09 16:35:13 2018 +0530
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/0845d04a4512cc10542f5f038ca75da51efdb15e [^]

Fixed issue 37493 : Validate PaymentTerm lines for return receipt in OrderLoader

* Added new method "addPaymentSchedule" for adding invoice payment schedule in OrderLoader

---
M src/org/openbravo/retail/posterminal/OrderLoader.java
---
(0101638)
hgbot (developer)
2018-01-09 12:12

Repository: tools/automation/pi-mobile
Changeset: a95a443a15c4a6ebd095ae40459129f04086e0a8
Author: Ranjith S R <ranjith <at> qualiantech.com>
Date: Tue Jan 09 16:42:03 2018 +0530
URL: http://code.openbravo.com/tools/automation/pi-mobile/rev/a95a443a15c4a6ebd095ae40459129f04086e0a8 [^]

Verifies issue 37493 : Modified automated test 'I35571_VerifyReceiptWithMutiPaymentTerm'

---
M src-test/org/openbravo/test/mobile/retail/pack/selenium/tests/system/I35571_VerifyReceiptWithMutiPaymentTerm.java
M src-test/org/openbravo/test/mobile/retail/pack/selenium/tests/system/I36907_VerifyReceiptWithPaymentTermLine.java
M src-test/org/openbravo/test/mobile/retail/pack/selenium/tests/system/I36907_VerifyReceiptWithPaymentTermLineII.java
---

- Issue History
Date Modified Username Field Change
2017-12-15 14:04 malsasua New Issue
2017-12-15 14:04 malsasua Assigned To => Retail
2017-12-15 14:04 malsasua Triggers an Emergency Pack => No
2017-12-15 19:07 Practics Issue Monitored: Practics
2017-12-19 07:26 ranjith_qualiantech_com Assigned To Retail => ranjith_qualiantech_com
2017-12-19 07:26 ranjith_qualiantech_com Status new => scheduled
2018-01-03 12:10 ngarcia Relationship added related to 0037573
2018-01-08 11:54 marvintm Status scheduled => acknowledged
2018-01-08 11:54 marvintm Status acknowledged => scheduled
2018-01-08 11:55 marvintm Regression level => Production - Confirmed Stable
2018-01-08 11:55 marvintm Regression introduced in release => RR17Q3
2018-01-09 12:12 hgbot Checkin
2018-01-09 12:12 hgbot Note Added: 0101637
2018-01-09 12:12 hgbot Status scheduled => resolved
2018-01-09 12:12 hgbot Resolution open => fixed
2018-01-09 12:12 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/0845d04a4512cc10542f5f038ca75da51efdb15e [^]
2018-01-09 12:12 hgbot Checkin
2018-01-09 12:12 hgbot Note Added: 0101638
2018-01-11 11:00 marvintm Review Assigned To => marvintm
2018-01-11 11:00 marvintm Status resolved => closed
2018-01-11 11:00 marvintm Fixed in Version => RR18Q2
2018-01-11 11:01 marvintm Regression introduced by commit => https://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/6c03b70eb5d2a2b7a9a396ae49a36eb434b48c4b [^]
2018-01-29 18:25 ngarcia Issue Monitored: ngarcia
2018-01-31 17:36 dmitry_mezentsev Relationship added caused by 0035571
2018-02-02 14:30 ngarcia Relationship added related to 0037753
2018-09-18 13:57 dmitry_mezentsev Regression level Production - Confirmed Stable => Production - QA Approved


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker