Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0037403
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSmajoralways2017-11-28 10:092018-01-08 12:23
ReporterguillermogilView Statuspublic 
Assigned Tojorge-garcia 
PriorityhighResolutionfixedFixed in VersionRR18Q2
StatusclosedFix in branchFixed in SCM revision59443e3d54a3
ProjectionnoneETAnoneTarget VersionRR18Q1
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tomarvintm
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0037403: Log Client should have all the information of the logs, not a substring

DescriptionLog Client should have all the information of the logs, not a substring.
Maybe it makes sense to keep it as it is but for ticket closed massage it is needed to have it all as a backup
Steps To ReproduceMake a ticket of 10 lines
See its log client
Proposed SolutionChange the column at database level from varchar to clob
TagsNo tags attached.
Attached Filesdiff file icon exportSizeIncrease.diff [^] (1,325 bytes) 2017-12-27 14:58 [Show Content]
diff file icon commit_fix_multiorder_37403.diff [^] (1,169 bytes) 2017-12-28 18:48 [Show Content]

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 0037597RR18Q1 closedjorge-garcia Log Client should have all the information of the logs, not a substring 
depends on backport 0037598RR17Q4.1 closedjorge-garcia Log Client should have all the information of the logs, not a substring 
depends on backport 0037599RR17Q3.3 closedjorge-garcia Log Client should have all the information of the logs, not a substring 
causes defect 0037468RR18Q1 closedjorge-garcia API change: msg column from obmobc_logclient should be clob type instead of varchar 

-  Notes
(0101032)
hgbot (developer)
2017-12-14 10:10

Repository: erp/pmods/org.openbravo.mobile.core
Changeset: 6eb4436882d0af405b701cd862ec01b8bab89f33
Author: Jorge Garcia <jorge.garcia <at> openbravo.com>
Date: Mon Dec 11 13:28:39 2017 +0100
URL: http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/6eb4436882d0af405b701cd862ec01b8bab89f33 [^]

Fixed issue 37403: Log Client should have all the information of the logs, not
a substring

Msg field has been change from varchar to clob.

In order to work with oracle, it is necessary to define a sort field in
log client window differnet from msg field. Created has been defined to
sort in log client window.

---
M src-db/database/model/tables/OBMOBC_LOGCLIENT.xml
M src-db/database/sourcedata/AD_COLUMN.xml
M src-db/database/sourcedata/AD_FIELD.xml
M web/org.openbravo.mobile.core/source/utils/ob-utilities.js
---
(0101060)
hgbot (developer)
2017-12-15 13:03

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: fc74a985a0d40bb210e292bad4ff7fc5d46aad0d
Author: Jorge Garcia <jorge.garcia <at> openbravo.com>
Date: Thu Dec 14 17:41:51 2017 +0100
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/fc74a985a0d40bb210e292bad4ff7fc5d46aad0d [^]

Related to issue 37403: Log Client should have all the information of the logs, not
a substring

Ticket closed message should show all the receipt in logclient instead of a summary.

---
M web/org.openbravo.retail.posterminal/js/data/dataordersave.js
---
(0101175)
marvintm (developer)
2017-12-20 19:15

Current changes are correct. However, one thing needs to be reviewed: the "multiorders ticket closed" message includes the whole json, which itself includes the binary data of the product images. This can now lead to bandwidth problems as we are no longer truncating the ticket, and doesn't make sense, the image data should be removed from the json before it is added to the log client (like it currently happens in the normal receipts).
(0101262)
jorgewederago (developer)
2017-12-27 14:58
edited on: 2017-12-27 16:18

In certain situations the new defined size might not be enough causing the log client not to be saved. My suggestion is to set the new size to at least 10000000. Check the exported attachment.

Also just to avoid future issues it might be good idea to recover the truncate if the length is too big for the field.

(0101283)
hgbot (developer)
2017-12-28 18:52

Repository: erp/pmods/org.openbravo.mobile.core
Changeset: 53abc4332b891bf0c16ef3d77cea9de74e297963
Author: Gorka Gil <gorka.gil <at> openbravo.com>
Date: Thu Dec 28 18:50:34 2017 +0100
URL: http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/53abc4332b891bf0c16ef3d77cea9de74e297963 [^]

Related to issue 37403. Backed out changeset 6eb4436882d0

---
M src-db/database/model/tables/OBMOBC_LOGCLIENT.xml
M src-db/database/sourcedata/AD_COLUMN.xml
M src-db/database/sourcedata/AD_FIELD.xml
M web/org.openbravo.mobile.core/source/utils/ob-utilities.js
---
(0101284)
hgbot (developer)
2017-12-28 18:52

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: 4623a770b2225d8be6ed911ac2f9344d71594d59
Author: Gorka Gil <gorka.gil <at> openbravo.com>
Date: Thu Dec 28 18:51:16 2017 +0100
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/4623a770b2225d8be6ed911ac2f9344d71594d59 [^]

Related to issue 37403. Backed out changeset fc74a985a0d4

---
M web/org.openbravo.retail.posterminal/js/data/dataordersave.js
---
(0101285)
gorka_gil (administrator)
2017-12-28 18:58

Because the problem reported by Jorge Wederago, and after talk with QA, we have backout the fix, and we will try to fix it before the Jan 15 that is the repackage of 18q1.

For the fix of only save the json for multiorder, added the attachment: commit_fix_multiorder_37403.diff
(0101554)
hgbot (developer)
2018-01-04 12:53

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: 16c18de2a7a9888325a1ce8278a91ec4a61e688a
Author: Jorge Garcia <jorge.garcia <at> openbravo.com>
Date: Tue Jan 02 16:40:32 2018 +0100
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/16c18de2a7a9888325a1ce8278a91ec4a61e688a [^]

Related to issue 37403: Log Client should have all the information of the logs, not
a substring

Ticket closed message should show all the receipt in logclient instead of a summary.

---
M web/org.openbravo.retail.posterminal/js/data/dataordersave.js
---
(0101555)
hgbot (developer)
2018-01-04 12:54

Repository: erp/pmods/org.openbravo.mobile.core
Changeset: 59443e3d54a3e61189fa16ab4cb3582d68f1438e
Author: Jorge Garcia <jorge.garcia <at> openbravo.com>
Date: Wed Jan 03 09:40:22 2018 +0100
URL: http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/59443e3d54a3e61189fa16ab4cb3582d68f1438e [^]

Fixed issue 37403: Log Client should have all the information of the logs, not
a substring

Msg field has been change from varchar to clob.

In order to work with oracle, it is necessary to define a sort field in
log client window differnet from msg field. Created has been defined to
sort in log client window.

---
M src-db/database/model/tables/OBMOBC_LOGCLIENT.xml
M src-db/database/sourcedata/AD_COLUMN.xml
M src-db/database/sourcedata/AD_FIELD.xml
M web/org.openbravo.mobile.core/source/utils/ob-utilities.js
---
(0101617)
hgbot (developer)
2018-01-08 12:06

Repository: erp/pmods/org.openbravo.mobile.core
Changeset: 9c1327052c97eff0e3a6e1f0a1cd179315951627
Author: Jorge Garcia <jorge.garcia <at> openbravo.com>
Date: Mon Jan 08 12:01:35 2018 +0100
URL: http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/9c1327052c97eff0e3a6e1f0a1cd179315951627 [^]

Related to issue 37403: Log Client should have all the information of the logs, not
a substring

Increse msg length from one million characters to one hundred million of
characters.

---
M src-db/database/sourcedata/AD_COLUMN.xml
M src-db/database/sourcedata/AD_FIELD.xml
M web/org.openbravo.mobile.core/source/utils/ob-utilities.js
---

- Issue History
Date Modified Username Field Change
2017-11-28 10:09 guillermogil New Issue
2017-11-28 10:09 guillermogil Assigned To => Retail
2017-11-28 10:09 guillermogil Resolution time => 1513638000
2017-11-28 10:09 guillermogil Triggers an Emergency Pack => No
2017-11-29 21:49 rqueralta Assigned To Retail => rqueralta
2017-11-29 21:50 rqueralta Status new => scheduled
2017-12-12 14:59 jorge-garcia Assigned To rqueralta => jorge-garcia
2017-12-13 09:07 jorge-garcia Relationship added causes 0037468
2017-12-14 10:10 hgbot Checkin
2017-12-14 10:10 hgbot Note Added: 0101032
2017-12-14 10:10 hgbot Status scheduled => resolved
2017-12-14 10:10 hgbot Resolution open => fixed
2017-12-14 10:10 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/6eb4436882d0af405b701cd862ec01b8bab89f33 [^]
2017-12-15 13:03 hgbot Checkin
2017-12-15 13:03 hgbot Note Added: 0101060
2017-12-20 19:15 marvintm Note Added: 0101175
2017-12-20 19:15 marvintm Status resolved => new
2017-12-20 19:15 marvintm Resolution fixed => open
2017-12-27 14:58 jorgewederago Note Added: 0101262
2017-12-27 14:58 jorgewederago File Added: exportSizeIncrease.diff
2017-12-27 16:18 jorgewederago Note Edited: 0101262 View Revisions
2017-12-28 18:48 gorka_gil File Added: commit_fix_multiorder_37403.diff
2017-12-28 18:52 hgbot Checkin
2017-12-28 18:52 hgbot Note Added: 0101283
2017-12-28 18:52 hgbot Checkin
2017-12-28 18:52 hgbot Note Added: 0101284
2017-12-28 18:58 gorka_gil Note Added: 0101285
2017-12-28 19:05 gorka_gil Status new => scheduled
2017-12-28 19:06 gorka_gil Target Version => RR18Q1
2018-01-04 12:53 hgbot Checkin
2018-01-04 12:53 hgbot Note Added: 0101554
2018-01-04 12:54 hgbot Checkin
2018-01-04 12:54 hgbot Note Added: 0101555
2018-01-04 12:54 hgbot Status scheduled => resolved
2018-01-04 12:54 hgbot Resolution open => fixed
2018-01-04 12:54 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/6eb4436882d0af405b701cd862ec01b8bab89f33 [^] => http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/59443e3d54a3e61189fa16ab4cb3582d68f1438e [^]
2018-01-08 12:06 hgbot Checkin
2018-01-08 12:06 hgbot Note Added: 0101617
2018-01-08 12:22 marvintm Review Assigned To => marvintm
2018-01-08 12:22 marvintm Status resolved => closed
2018-01-08 12:22 marvintm Fixed in Version => RR18Q2
2018-01-08 12:22 marvintm Status closed => new
2018-01-08 12:22 marvintm Resolution fixed => open
2018-01-08 12:22 marvintm Fixed in Version RR18Q2 =>
2018-01-08 12:22 marvintm Status new => acknowledged
2018-01-08 12:23 marvintm Status acknowledged => scheduled
2018-01-08 12:23 marvintm Status scheduled => resolved
2018-01-08 12:23 marvintm Fixed in Version => RR18Q2
2018-01-08 12:23 marvintm Resolution open => fixed
2018-01-08 12:23 marvintm Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker