Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0037093
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminoralways2017-10-17 18:482018-01-03 12:38
ReportercaristuView Statuspublic 
Assigned Tocaristu 
PriorityhighResolutionfixedFixed in Version3.0PR18Q1
StatusclosedFix in branchFixed in SCM revision8d578e0e9bbd
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0037093: Wrong behavior after opening a record directly in a tab configured as "Default Edit Mode"

DescriptionWrong behavior after opening a record directly in a tab configured as "Default Edit Mode". In this case when cleaning the implicit filter (last document viewed filter) the following javascript error is raised:

ISC_Combined.js:254 Uncaught TypeError: Cannot read property 'startsWith' of undefined
    at _2.isNotSaved (c0f7d0022b693f8aa8b3ada129cd0556.js:29060)
    at _2.doEditRecordActions (c0f7d0022b693f8aa8b3ada129cd0556.js:29043)
    at _2.editRecord (c0f7d0022b693f8aa8b3ada129cd0556.js:28999)
    at _2.editRecord (c0f7d0022b693f8aa8b3ada129cd0556.js:25501)
    at _2.openDefaultEditView (c0f7d0022b693f8aa8b3ada129cd0556.js:25360)
    at _2.dataArrived (c0f7d0022b693f8aa8b3ada129cd0556.js:32797)
    at _2.observation [as dataArrived] (ISC_Combined.js:277)
    at _2.isc_ListGrid__dataArrived [as $66d] (ISC_Combined.js:5384)
    at _2.<anonymous> (ISC_Combined.js:5344)
    at _2.observation [as dataArrived] (ISC_Combined.js:277)
Steps To Reproduce1) Open the [Client] window. The header and the "Information" tab of this window are both configured as "Default Edit Mode" in the AD.
2) Close it
3) Click in any of the links referencing to the Client window that now appear in the "Recent Documents" section
4) Once the window is opened, close the form
5) Remove the grid filter by clicking on the funnel icon
6) Note that the grid does not appear and instead a new record is opened in form view
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0037109 closedcaristu Parent form shown in blank when direct opening a record in a child tab having parent tab configured as "Default Edit Mode" 

-  Notes
(0099933)
hgbot (developer)
2017-10-18 09:28

Repository: erp/devel/pi
Changeset: 8d578e0e9bbdbe27acdf7ceb8e1d4be7cfbe52ad
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Wed Oct 18 09:10:51 2017 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/8d578e0e9bbdbe27acdf7ceb8e1d4be7cfbe52ad [^]

fixes issue 37093: Do not open default edit view if the record is not loaded

  When the data arrives to an standard grid it tries to open the edit mode of the view in case it has to. But if the data is being loaded just in that moment, the edit mode should not be opened because it will cause javascript errors as there is no data available to be shown.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-view-grid.js
---
(0100027)
alostale (developer)
2017-10-24 13:34

reviewed + tested
(0101334)
hudsonbot (developer)
2018-01-03 12:38

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/c81e0d3cbab5 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2017-10-17 18:48 caristu New Issue
2017-10-17 18:48 caristu Assigned To => platform
2017-10-17 18:48 caristu Modules => Core
2017-10-17 18:48 caristu Triggers an Emergency Pack => No
2017-10-17 18:51 caristu Steps to Reproduce Updated View Revisions
2017-10-17 19:00 caristu Steps to Reproduce Updated View Revisions
2017-10-17 19:43 caristu Assigned To platform => caristu
2017-10-17 19:43 caristu Status new => acknowledged
2017-10-17 19:43 caristu Status acknowledged => scheduled
2017-10-18 09:28 hgbot Checkin
2017-10-18 09:28 hgbot Note Added: 0099933
2017-10-18 09:28 hgbot Status scheduled => resolved
2017-10-18 09:28 hgbot Resolution open => fixed
2017-10-18 09:28 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/8d578e0e9bbdbe27acdf7ceb8e1d4be7cfbe52ad [^]
2017-10-18 09:29 caristu Review Assigned To => alostale
2017-10-18 19:22 caristu Relationship added related to 0037109
2017-10-24 13:34 alostale Note Added: 0100027
2017-10-24 13:34 alostale Status resolved => closed
2017-10-24 13:34 alostale Fixed in Version => 3.0PR18Q1
2018-01-03 12:38 hudsonbot Checkin
2018-01-03 12:38 hudsonbot Note Added: 0101334


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker