Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0036974
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSmajoralways2017-09-29 14:062017-10-16 12:24
ReporterxabiermerinoView Statuspublic 
Assigned Tojorge-garcia 
PriorityurgentResolutionfixedFixed in VersionRR18Q1
StatusclosedFix in branchFixed in SCM revision6c903c081a0a
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tomarvintm
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0036974: [SERQA 3316] It is possible to bypass the overpayments with Pay Open tickets

DescriptionIt is possible to bypass the overpayments with Pay Open tickets
Steps To Reproduce- Open Pay Open ticket window with one layaway
- Use 'Card' and introduce an amount higher than layaway's amount
- The application shows an Overpayment Error --> OK
- Refresh using F5
- Realize that the button 'done' is available and the error message has dissapeared
TagsSERQA
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0099866)
hgbot (developer)
2017-10-11 16:57

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: 6c903c081a0a212acb8710040d56f53b66656b19
Author: Jorge Garcia <jorge.garcia <at> openbravo.com>
Date: Wed Oct 11 12:48:45 2017 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/6c903c081a0a212acb8710040d56f53b66656b19 [^]

Fixed issue 36974: [SERQA 3316] It is possible to bypass the overpayments
with Pay Open tickets

The solution is to check first if the last payment has an overpayment and if
the payment method has defined a limit for it.

Since right now it’s not possible to add more payment once the user has pay it
completely, this is a valid solution.

This solution has forced to take the overpayment to a new function called
checkValidOverpayment and change the old function checkValidCashOverpayment
(now renamed to CheckValidCashChange).

---
M web/org.openbravo.retail.posterminal/js/pointofsale/view/payment.js
---
(0099919)
hgbot (developer)
2017-10-16 12:24

Repository: tools/automation/pi-mobile
Changeset: e89bf7256b9ad24b79b7585f9fd9390a9d47e9f6
Author: Jorge Garcia <jorge.garcia <at> openbravo.com>
Date: Mon Oct 16 10:11:18 2017 +0200
URL: http://code.openbravo.com/tools/automation/pi-mobile/rev/e89bf7256b9ad24b79b7585f9fd9390a9d47e9f6 [^]

Verifies issue 36974: [SERQA 3316] It is possible to bypass the overpayments
with Pay Open tickets

Added test I36974_VerifyOverpaymentByLimitAfterRefresh.

---
A src-test/org/openbravo/test/mobile/retail/pack/selenium/tests/system/I36974_VerifyOverpaymentByLimitAfterRefresh.java
---

- Issue History
Date Modified Username Field Change
2017-09-29 14:06 xabiermerino New Issue
2017-09-29 14:06 xabiermerino Assigned To => Retail
2017-09-29 14:06 xabiermerino Triggers an Emergency Pack => No
2017-09-29 14:06 xabiermerino Tag Attached: SERQA
2017-10-06 11:33 jorge-garcia Status new => scheduled
2017-10-06 11:33 jorge-garcia Assigned To Retail => jorge-garcia
2017-10-11 16:57 hgbot Checkin
2017-10-11 16:57 hgbot Note Added: 0099866
2017-10-11 16:57 hgbot Status scheduled => resolved
2017-10-11 16:57 hgbot Resolution open => fixed
2017-10-11 16:57 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/6c903c081a0a212acb8710040d56f53b66656b19 [^]
2017-10-13 13:37 marvintm Review Assigned To => marvintm
2017-10-13 13:37 marvintm Status resolved => closed
2017-10-13 13:37 marvintm Fixed in Version => RR18Q1
2017-10-16 12:24 hgbot Checkin
2017-10-16 12:24 hgbot Note Added: 0099919


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker