Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0036917
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 04. Warehouse managementminoralways2017-09-21 13:392017-09-26 15:25
ReporterngarciaView Statuspublic 
Assigned Tomarkmm82 
PriorityurgentResolutionfixedFixed in Version3.0PR17Q4
StatusclosedFix in branchFixed in SCM revision170d69d2ab88
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toaferraz
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0036917: Default values are not selected in Return Material Receipt window if the organization does not have an on hand warehouse defined

DescriptionDefault values are not selected in Return Material Receipt window if the organization does not have an on hand warehouse defined

Steps To ReproduceAs group admin role:
   Remove 'España Región Norte' warehouse to 'F&B España - Región Norte' organization (Organization - Warehouse tab)
   Create a new record in Return Material Receipt
   Save it
   Create a new record and check all the fields remain empty

   The log shows:
      ERROR org.openbravo.client.application.window.FormInitializationComponent - TabId:30576C6ABD12419F9D19D497216FC9B8 - Mode:NEW - rowId:null
org.openbravo.base.exception.OBException: Couldn't execute callout (class org.openbravo.erpCommon.ad_callouts.SE_InOut_Warehouse)
    at org.openbravo.client.application.window.FormInitializationComponent.runCallouts(FormInitializationComponent.java:1555)
...
Caused by: java.lang.NullPointerException
    at org.openbravo.erpCommon.ad_callouts.SE_InOut_Warehouse.execute(SE_InOut_Warehouse.java:41)
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to design defect 00323663.0PR16Q4 closedinigosanchez callout invocation ineficiencies 
depends on backport 00369213.0PR17Q3.1 closedmarkmm82 Default values are not selected in Return Material Receipt window if the organization does not have an on hand warehouse defined 
depends on backport 00369223.0PR17Q2.4 closedmarkmm82 Default values are not selected in Return Material Receipt window if the organization does not have an on hand warehouse defined 

-  Notes
(0099434)
aferraz (developer)
2017-09-21 18:02

Moved to minor as per [1]: Default Value missing for the fields required.
[1] http://wiki.openbravo.com/wiki/Bug_Reporting_Guidelines#How_to_Choose_the_Right_Severity [^]
(0099517)
hgbot (developer)
2017-09-25 10:41

Repository: erp/devel/pi
Changeset: 170d69d2ab888f84bcf34501f96b240da1eb421b
Author: Mark <markmm82 <at> gmail.com>
Date: Fri Sep 22 11:35:32 2017 -0400
URL: http://code.openbravo.com/erp/devel/pi/rev/170d69d2ab888f84bcf34501f96b240da1eb421b [^]

Fixes issue 36917: Default values are not selected in Return Material Receipt
window if the organization does not have an on hand warehouse defined

A NPE is fired if Warehouse is not selected, because was trying to access a method
of null object.

To fix that is avoided a NPE, only creating a OBDAL object if a warehouse is selected.

---
M src/org/openbravo/erpCommon/ad_callouts/SE_InOut_Warehouse.java
---
(0099524)
aferraz (developer)
2017-09-25 11:00

Code review + Testing OK
(0099587)
hudsonbot (developer)
2017-09-26 15:25

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/8fa643b4437e [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2017-09-21 13:39 ngarcia New Issue
2017-09-21 13:39 ngarcia Assigned To => Triage Finance
2017-09-21 13:39 ngarcia Modules => Core
2017-09-21 13:39 ngarcia Triggers an Emergency Pack => No
2017-09-21 13:40 ngarcia Issue Monitored: networkb
2017-09-21 14:06 eugeni Issue Monitored: eugeni
2017-09-21 17:18 caristu Relationship added related to 0032366
2017-09-21 18:02 aferraz Note Added: 0099434
2017-09-21 18:02 aferraz Severity major => minor
2017-09-21 18:03 aferraz Status new => scheduled
2017-09-21 18:03 aferraz Assigned To Triage Finance => markmm82
2017-09-25 10:41 hgbot Checkin
2017-09-25 10:41 hgbot Note Added: 0099517
2017-09-25 10:41 hgbot Status scheduled => resolved
2017-09-25 10:41 hgbot Resolution open => fixed
2017-09-25 10:41 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/170d69d2ab888f84bcf34501f96b240da1eb421b [^]
2017-09-25 11:00 aferraz Review Assigned To => aferraz
2017-09-25 11:00 aferraz Note Added: 0099524
2017-09-25 11:00 aferraz Status resolved => closed
2017-09-25 11:00 aferraz Fixed in Version => 3.0PR17Q4
2017-09-26 15:25 hudsonbot Checkin
2017-09-26 15:25 hudsonbot Note Added: 0099587


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker