Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0036922
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] 04. Warehouse managementminoralways2017-09-21 13:392017-09-25 11:00
ReporterngarciaView Statuspublic 
Assigned Tomarkmm82 
PriorityurgentResolutionfixedFixed in Version3.0PR17Q2.4
StatusclosedFix in branchFixed in SCM revisionf6535a34c7ea
ProjectionnoneETAnoneTarget Version3.0PR17Q2.4
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toaferraz
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0036922: Default values are not selected in Return Material Receipt window if the organization does not have an on hand warehouse defined

DescriptionDefault values are not selected in Return Material Receipt window if the organization does not have an on hand warehouse defined

Steps To ReproduceAs group admin role:
   Remove 'España Región Norte' warehouse to 'F&B España - Región Norte' organization (Organization - Warehouse tab)
   Create a new record in Return Material Receipt
   Save it
   Create a new record and check all the fields remain empty

   The log shows:
      ERROR org.openbravo.client.application.window.FormInitializationComponent - TabId:30576C6ABD12419F9D19D497216FC9B8 - Mode:NEW - rowId:null
org.openbravo.base.exception.OBException: Couldn't execute callout (class org.openbravo.erpCommon.ad_callouts.SE_InOut_Warehouse)
    at org.openbravo.client.application.window.FormInitializationComponent.runCallouts(FormInitializationComponent.java:1555)
...
Caused by: java.lang.NullPointerException
    at org.openbravo.erpCommon.ad_callouts.SE_InOut_Warehouse.execute(SE_InOut_Warehouse.java:41)
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 0036917 closedmarkmm82 Default values are not selected in Return Material Receipt window if the organization does not have an on hand warehouse defined 

-  Notes
(0099521)
hgbot (developer)
2017-09-25 10:58

Repository: erp/backports/3.0PR17Q2.4
Changeset: f6535a34c7ead07e7e9dea24c819f78679e76182
Author: Mark <markmm82 <at> gmail.com>
Date: Fri Sep 22 11:35:32 2017 -0400
URL: http://code.openbravo.com/erp/backports/3.0PR17Q2.4/rev/f6535a34c7ead07e7e9dea24c819f78679e76182 [^]

Fixes issue 36922: Default values are not selected in Return Material Receipt
window if the organization does not have an on hand warehouse defined

A NPE is fired if Warehouse is not selected, because was trying to access a method
of null object.

To fix that is avoided a NPE, only creating a OBDAL object if a warehouse is selected.

---
M src/org/openbravo/erpCommon/ad_callouts/SE_InOut_Warehouse.java
---
(0099523)
aferraz (developer)
2017-09-25 11:00

Code review + Testing OK

- Issue History
Date Modified Username Field Change
2017-09-21 18:03 aferraz Type defect => backport
2017-09-21 18:03 aferraz Target Version => 3.0PR17Q2.4
2017-09-21 18:04 aferraz Assigned To Triage Finance => markmm82
2017-09-25 10:58 hgbot Checkin
2017-09-25 10:58 hgbot Note Added: 0099521
2017-09-25 10:58 hgbot Status scheduled => resolved
2017-09-25 10:58 hgbot Resolution open => fixed
2017-09-25 10:58 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/backports/3.0PR17Q2.4/rev/f6535a34c7ead07e7e9dea24c819f78679e76182 [^]
2017-09-25 11:00 aferraz Review Assigned To => aferraz
2017-09-25 11:00 aferraz Note Added: 0099523
2017-09-25 11:00 aferraz Status resolved => closed
2017-09-25 11:00 aferraz Fixed in Version => 3.0PR17Q2.4


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker