Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0036765
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] A. Platformminoralways2017-09-01 12:482017-09-13 08:12
ReporterngarciaView Statuspublic 
Assigned Tocaristu 
PriorityimmediateResolutionfixedFixed in Version3.0PR17Q3
StatusclosedFix in branchFixed in SCM revisionfbbdcccd3272
ProjectionnoneETAnoneTarget Version3.0PR17Q3
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2016-04-18
Regression introduced in release3.0PR16Q3
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/82f27ac1b1497b3a82646b140ab1b6e048f2b766 [^]
Triggers an Emergency PackNo
Summary

0036765: Update information of attachments is not changed after replacing an already attached file

DescriptionUpdate information of attachments is not changed after replacing an already attached file.

It seems the updated column of the c_file table is not updated when a file is replaced
Steps To ReproduceAs group admin role:
   Go to Sales Invoice window
   Add an attachment to it
   Wait at least a minute in order to see its update information as '1 minutes ago by ...'
   Modify the file
   Add it again to the same invoice
   The applications shows:
   "The file you are trying to upload already exists, so it will be replaced by the new one. Are you sure you want to continue?"
   Select OK

   Check the update information remains the same. It should be updated to '0 minutes ago by ...'
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 0036763 closedcaristu Update information of attachments is not changed after replacing an already attached file 

-  Notes
(0098796)
hgbot (developer)
2017-09-04 10:23

Repository: erp/backports/3.0PR17Q3
Changeset: fbbdcccd32726e3e543f49fbd499add64d325b62
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Mon Sep 04 09:23:10 2017 +0200
URL: http://code.openbravo.com/erp/backports/3.0PR17Q3/rev/fbbdcccd32726e3e543f49fbd499add64d325b62 [^]

fixes bug 36765: Audit info not updated when replacing an already attached file

  The audit information (updated, updated by fields) of the attachments was not being updated after replacing an already attached file. In this case the OBInterceptor was not being invoked because the information of the attachment (BaseOBObject) was indeed not changing.

  To fix this problem we explicitly change the 'updated' date of the attachment and the OBInterceptor will take care of update the rest of the audit information (updated by).

---
M modules/org.openbravo.client.application/src/org/openbravo/client/application/attachment/AttachImplementationManager.java
---
(0098936)
hgbot (developer)
2017-09-11 12:09

Repository: erp/backports/3.0PR17Q3
Changeset: fd71055b3e971fc99e25640d15738c3c6d439d6a
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Mon Sep 11 12:05:17 2017 +0200
URL: http://code.openbravo.com/erp/backports/3.0PR17Q3/rev/fd71055b3e971fc99e25640d15738c3c6d439d6a [^]

related to bug 36765: Update attachment last update when metadata also changes

---
M modules/org.openbravo.client.application/src/org/openbravo/client/application/attachment/AttachmentUtils.java
---
(0098986)
hgbot (developer)
2017-09-12 15:51

Repository: erp/backports/3.0PR17Q3
Changeset: 5a80fe33e7c125e71235fb0f255ca989ba2c8dd9
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Tue Sep 12 15:50:45 2017 +0200
URL: http://code.openbravo.com/erp/backports/3.0PR17Q3/rev/5a80fe33e7c125e71235fb0f255ca989ba2c8dd9 [^]

related to bug 36765: last update not updated when removing description

  The last updated information is now updated when the description of an existing attachment is cleared. This was not happening before, because the record in the OBUIAPP_Parameter_Value table was removed when the value to be assigned is null

---
M modules/org.openbravo.client.application/src/org/openbravo/client/application/attachment/AttachImplementationManager.java
---
(0099000)
alostale (developer)
2017-09-13 08:12

reviewed

tested cases:

1. replaced file with same name
2. edited description
3. having a description, it gets removed
4. adding modifications in an extra parameter in attachment method

- Issue History
Date Modified Username Field Change
2017-09-01 14:49 caristu Type defect => backport
2017-09-01 14:49 caristu Target Version => 3.0PR17Q3
2017-09-04 10:23 hgbot Checkin
2017-09-04 10:23 hgbot Note Added: 0098796
2017-09-04 10:23 hgbot Status scheduled => resolved
2017-09-04 10:23 hgbot Resolution open => fixed
2017-09-04 10:23 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/backports/3.0PR17Q3/rev/fbbdcccd32726e3e543f49fbd499add64d325b62 [^]
2017-09-04 10:24 caristu Review Assigned To => alostale
2017-09-11 12:09 hgbot Checkin
2017-09-11 12:09 hgbot Note Added: 0098936
2017-09-12 15:51 hgbot Checkin
2017-09-12 15:51 hgbot Note Added: 0098986
2017-09-13 08:12 alostale Note Added: 0099000
2017-09-13 08:12 alostale Status resolved => closed
2017-09-13 08:12 alostale Fixed in Version => 3.0PR17Q3


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker