Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0036412
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 04. Warehouse managementmajoralways2017-07-05 12:242017-09-21 16:49
ReporterngarciaView Statuspublic 
Assigned Tocollazoandy4 
PriorityurgentResolutionfixedFixed in Version3.0PR17Q4
StatusclosedFix in branchFixed in SCM revisiond7c03ca57c97
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toaferraz
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0036412: Orphan Line is removed from Return To Vendor if Pick/Edit Lines is launched then

DescriptionOrphan Line is removed from Return To Vendor if Pick/Edit Lines is launched then
Steps To ReproduceAs group admin role:
   Set RM Allow Orphan Line preference to Y
   Log out and log in
   Create a Return To Vendor Header
   Insert Orphan Line
   Pick/Edit Lines and click in Done without making any change
   Check the orphan line has been removed
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0036448 closedcollazoandy4 The Line number in RTV is increase in 10 

-  Notes
(0097959)
collazoandy4 (developer)
2017-07-07 16:15

Test Plan
  As group admin role:
   Go to Preference window and create a new record and Property Set RM Allow Orphan Line to Y
   Log out and log in
   Go to Return to Vendor and create a new record:
     Insert Orphan Line:
       Product: Agua sin Gas 1L
       Returned: 3
       Unit Price: 2
       Returned reason: Damaged on arrival
     Pick/Edit Lines and click in Done without making any change
     Check the orphan line has not been remove and without any change
     Pick/Edit Lines select any record set returnedqty = 4 and click in Done
     Check the Lines tab now contains two lines, the orphan line and the selected line
     Pick/Edit Lines deselect the orphan line and clic in Done
     Check the orphan line was removed from the Lines tab
     Pick/Edit Lines deselect the selected line and clic in Done
     Check the Lines tab is now empty
     Pick/Edit Lines select any record set returnedqty = 5 and clic in Done
     Check the selected line was added to the Lines tab
     Book the RTV and check the process ends sucessfull
     Reactivate the RTV
     Insert another Orphan Line:
       Product: Agua sin Gas 1L
       Returned: 3
       Unit Price: 2
       Returned reason: Damaged on arrival
     Book the RTV and check the process ends sucessfull
     Reactivate the RTV
     Pick/Edit Lines and deselect the selected line and clic in Done
     Check the orphan line is the only record in Lines tab
     Book the RTV and check the process ends sucessfull
(0097982)
hgbot (developer)
2017-07-10 16:22

Repository: erp/devel/pi
Changeset: d7c03ca57c9732540f85dc87b213e60055ea6dc1
Author: Armaignac <collazoandy4 <at> gmail.com>
Date: Fri Jul 07 10:37:42 2017 -0400
URL: http://code.openbravo.com/erp/devel/pi/rev/d7c03ca57c9732540f85dc87b213e60055ea6dc1 [^]

Fixes issue 36412: Orphan Line removed from Return To Vendor

The orphan lines was removed when a Pick/Edit is open because if the selected Lines
from the Pick/Edit is 0 all lines are removed and the methods ends.

A refactor was made to take into account the selected orphan lines in the
selected lines process, also a null save validation was done with the goods shipment
line because an orphan lines doesn't have a goods shipment line.

---
M src/org/openbravo/common/actionhandler/SRMOPickEditLines.java
---
(0097983)
hgbot (developer)
2017-07-10 16:22

Repository: erp/devel/pi
Changeset: 2b129041a63e03fdeb2f5a09ad578374216b4685
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Mon Jul 10 16:16:48 2017 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/2b129041a63e03fdeb2f5a09ad578374216b4685 [^]

Related to issue 36412: Code review improvements

---
M src/org/openbravo/common/actionhandler/SRMOPickEditLines.java
---
(0097984)
aferraz (developer)
2017-07-10 16:22

Code review + Testing OK
(0099261)
hudsonbot (developer)
2017-09-21 16:49

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/9750b78d3e5c [^]
Maturity status: Test
(0099262)
hudsonbot (developer)
2017-09-21 16:49

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/9750b78d3e5c [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2017-07-05 12:24 ngarcia New Issue
2017-07-05 12:24 ngarcia Assigned To => Triage Finance
2017-07-05 12:24 ngarcia Modules => Core
2017-07-05 12:24 ngarcia Resolution time => 1501020000
2017-07-05 12:24 ngarcia Triggers an Emergency Pack => No
2017-07-05 12:24 ngarcia Issue Monitored: networkb
2017-07-05 12:27 Practics Issue Monitored: Practics
2017-07-05 13:10 aferraz Assigned To Triage Finance => collazoandy4
2017-07-07 02:13 collazoandy4 Status new => scheduled
2017-07-07 16:15 collazoandy4 Note Added: 0097959
2017-07-10 16:21 aferraz Relationship added related to 0036448
2017-07-10 16:22 hgbot Checkin
2017-07-10 16:22 hgbot Note Added: 0097982
2017-07-10 16:22 hgbot Status scheduled => resolved
2017-07-10 16:22 hgbot Resolution open => fixed
2017-07-10 16:22 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/d7c03ca57c9732540f85dc87b213e60055ea6dc1 [^]
2017-07-10 16:22 hgbot Checkin
2017-07-10 16:22 hgbot Note Added: 0097983
2017-07-10 16:22 aferraz Review Assigned To => aferraz
2017-07-10 16:22 aferraz Note Added: 0097984
2017-07-10 16:22 aferraz Status resolved => closed
2017-07-10 16:22 aferraz Fixed in Version => 3.0PR17Q4
2017-09-21 16:49 hudsonbot Checkin
2017-09-21 16:49 hudsonbot Note Added: 0099261
2017-09-21 16:49 hudsonbot Checkin
2017-09-21 16:49 hudsonbot Note Added: 0099262


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker