Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0036448
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] Z. Othersminoralways2017-07-07 23:302017-09-21 16:49
Reportercollazoandy4View Statuspublic 
Assigned Tocollazoandy4 
PrioritynormalResolutionfixedFixed in Version3.0PR17Q4
StatusclosedFix in branchFixed in SCM revisionc5f112181318
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toaferraz
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0036448: The Line number in RTV is increase in 10

DescriptionThe Line number in RTV is increase in 10 every time you open the Pick/Edit lines even without any change
Steps To ReproduceAs F&B Group Admin Role
  Go to Return to vendor window and create a new record:
    Business Partner: Bebidas Alegres, SL
    Clic on Pick/Edit button select 1 record, press done and check a new line is created in Lines tab with lineno = 10
    Open the Pick/Edit and without any change pres done and check the existing line increase lineno value in 10
Proposed SolutionIn SRMOPickEditLines.java remove the OBCriteria to get the max lineno from the orderline, because the Lines are always created
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0036412 closedcollazoandy4 Orphan Line is removed from Return To Vendor if Pick/Edit Lines is launched then 

-  Notes
(0098159)
collazoandy4 (developer)
2017-07-21 00:00

As F&B Group Admin Role
  Go to Return to vendor window and create a new record:
    Business Partner: Bebidas Alegres, SL
    Clic on Pick/Edit button select 1 record, press done and check a new line is created in Lines tab with lineno = 10
    Open the Pick/Edit and without any change pres done and check the existing line doesn't increase the lineno value
(0098222)
hgbot (developer)
2017-07-26 11:54

Repository: erp/devel/pi
Changeset: c5f112181318c8a14d8c6accd9549383428ef107
Author: Armaignac <collazoandy4 <at> gmail.com>
Date: Thu Jul 20 17:54:57 2017 -0400
URL: http://code.openbravo.com/erp/devel/pi/rev/c5f112181318c8a14d8c6accd9549383428ef107 [^]

Fixes issue 36448: The Line number in RTV is increase in 10

The Line number in RTV is increase in 10 every time you open the Pick/Edit lines
even without any change

The OBCriteria to get the max lineno was remove because the orderlines are
always created

---
M src/org/openbravo/common/actionhandler/SRMOPickEditLines.java
---
(0098223)
aferraz (developer)
2017-07-26 11:55

Code review + Testing OK
(0099286)
hudsonbot (developer)
2017-09-21 16:49

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/9750b78d3e5c [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2017-07-07 23:30 collazoandy4 New Issue
2017-07-07 23:30 collazoandy4 Assigned To => Triage Finance
2017-07-07 23:30 collazoandy4 Modules => Core
2017-07-07 23:30 collazoandy4 Triggers an Emergency Pack => No
2017-07-10 16:21 aferraz Relationship added related to 0036412
2017-07-10 18:17 ngarcia Issue Monitored: networkb
2017-07-10 18:18 ngarcia Issue End Monitor: networkb
2017-07-10 18:18 ngarcia Issue Monitored: ngarcia
2017-07-20 23:59 collazoandy4 Status new => scheduled
2017-07-21 00:00 collazoandy4 Note Added: 0098159
2017-07-26 11:48 aferraz Assigned To Triage Finance => collazoandy4
2017-07-26 11:54 hgbot Checkin
2017-07-26 11:54 hgbot Note Added: 0098222
2017-07-26 11:54 hgbot Status scheduled => resolved
2017-07-26 11:54 hgbot Resolution open => fixed
2017-07-26 11:54 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/c5f112181318c8a14d8c6accd9549383428ef107 [^]
2017-07-26 11:55 aferraz Review Assigned To => aferraz
2017-07-26 11:55 aferraz Note Added: 0098223
2017-07-26 11:55 aferraz Status resolved => closed
2017-07-26 11:55 aferraz Fixed in Version => 3.0PR17Q4
2017-09-21 16:49 hudsonbot Checkin
2017-09-21 16:49 hudsonbot Note Added: 0099286


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker