Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0036406
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] B. User interfaceminoralways2017-07-04 18:272018-01-03 12:39
ReporterngarciaView Statuspublic 
Assigned Toinigosanchez 
PriorityhighResolutionfixedFixed in Version3.0PR18Q1
StatusclosedFix in branchFixed in SCM revision747998ff0bb6
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tocaristu
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0036406: Summary functions do not work in tabs based on tables with Datasource Data Origin

DescriptionSummary functions do not work in tabs based on tables with Datasource Data Origin
Steps To ReproduceAs system admin role:
   Install Not Posted Transactions module

As group admin role:
   Open Report Not Posted window
   Select a column and Add Count summary function to it
   Check the value is not shown
Proposed SolutionPossible solutions:

1. In getAllowSummaryFunctions of OBViewGridComponent class, return false if the table is based on a Datasource

2. Add a Grid Configuration to the 'Not Posted documents - Report Not Posted' tab setting the Allow Summary Functions to 'N'
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0034324 closedinigosanchez Summary function does not function for WIndow's created using hql tables. 
related to design defect 0037381 newplatform Add ability to use Summary Functions in tabs based on Datasources. 

-  Notes
(0100660)
hgbot (developer)
2017-11-22 10:16

Repository: erp/devel/pi
Changeset: 747998ff0bb63b62639764d196f28311ab1ea77b
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Tue Nov 21 17:58:52 2017 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/747998ff0bb63b62639764d196f28311ab1ea77b [^]

Fixed issue 36406: Summary functions do not work in tabs based on Datasources.

The summary functions didn't work in tabs based on Datasources because this
functionality was not developed. The reported datasource hadn't the code to
managed summary functions properly.

To avoid this problem, it has been resolved by blocking the use of the summary
functions in the tabs based on Datasources.

---
M modules/org.openbravo.client.application/src/org/openbravo/client/application/window/OBViewGridComponent.java
---
(0100661)
inigosanchez (developer)
2017-11-22 10:23

Added limitations of Summary Functions properly in the Openbravo wiki[1].


[1]. http://wiki.openbravo.com/wiki/User_Interface_Introduction#Grid_Summaries [^]
(0100703)
caristu (developer)
2017-11-24 14:04

Reopened: disabling summary functions for all non datasource based tables:

!ApplicationConstants.DATASOURCEBASEDTABLE.equals(table.getDataOriginType());
(0100704)
hgbot (developer)
2017-11-24 14:10

Repository: erp/devel/pi
Changeset: f4da2f78f98da5277314c8dcba9125c45cfbaf59
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Fri Nov 24 14:09:22 2017 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/f4da2f78f98da5277314c8dcba9125c45cfbaf59 [^]

Related with issue 36406: Fixed error in the condition

---
M modules/org.openbravo.client.application/src/org/openbravo/client/application/window/OBViewGridComponent.java
---
(0100705)
caristu (developer)
2017-11-24 14:29

Code reviewed + tested OK.
(0101450)
hudsonbot (developer)
2018-01-03 12:39

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/c81e0d3cbab5 [^]
Maturity status: Test
(0101457)
hudsonbot (developer)
2018-01-03 12:39

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/c81e0d3cbab5 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2017-07-04 18:27 ngarcia New Issue
2017-07-04 18:27 ngarcia Assigned To => platform
2017-07-04 18:27 ngarcia Modules => Core
2017-07-04 18:27 ngarcia Triggers an Emergency Pack => No
2017-07-04 18:29 ngarcia Proposed Solution updated
2017-07-04 18:29 ngarcia Issue Monitored: networkb
2017-07-14 11:03 alostale Status new => acknowledged
2017-07-17 08:57 caristu Relationship added related to 0034324
2017-11-21 17:49 inigosanchez Status acknowledged => scheduled
2017-11-21 17:49 inigosanchez Assigned To platform => inigosanchez
2017-11-22 10:16 hgbot Checkin
2017-11-22 10:16 hgbot Note Added: 0100660
2017-11-22 10:16 hgbot Status scheduled => resolved
2017-11-22 10:16 hgbot Resolution open => fixed
2017-11-22 10:16 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/747998ff0bb63b62639764d196f28311ab1ea77b [^]
2017-11-22 10:23 inigosanchez Note Added: 0100661
2017-11-22 10:23 inigosanchez Review Assigned To => caristu
2017-11-24 10:20 inigosanchez Relationship added related to 0037381
2017-11-24 14:04 caristu Note Added: 0100703
2017-11-24 14:04 caristu Status resolved => new
2017-11-24 14:04 caristu Resolution fixed => open
2017-11-24 14:10 hgbot Checkin
2017-11-24 14:10 hgbot Note Added: 0100704
2017-11-24 14:10 inigosanchez Status new => scheduled
2017-11-24 14:10 inigosanchez Status scheduled => resolved
2017-11-24 14:10 inigosanchez Resolution open => fixed
2017-11-24 14:29 caristu Note Added: 0100705
2017-11-24 14:29 caristu Status resolved => closed
2017-11-24 14:29 caristu Fixed in Version => 3.0PR18Q1
2018-01-03 12:39 hudsonbot Checkin
2018-01-03 12:39 hudsonbot Note Added: 0101450
2018-01-03 12:39 hudsonbot Checkin
2018-01-03 12:39 hudsonbot Note Added: 0101457


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker