Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0036280
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 01. General setupminorhave not tried2017-06-19 18:162018-05-14 13:09
ReportershuehnerView Statuspublic 
Assigned ToAtulOpenbravo 
PrioritynormalResolutionfixedFixed in Version3.0PR18Q3
StatusclosedFix in branchFixed in SCM revision2db82514d5d5
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toaferraz
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0036280: Several unused + probably unusable callouts exists and are candidates to be deleted

DescriptionThe following classes are servlets but do all do not have a corresponding ad_model_object entry.

That means they have no servlet mapping and that they cannot be used as callouts (as defined callouts find the java class implementing them via ad_model_object).

So all these seem not usable and are candidates for deletion:

org.openbravo.erpCommon.ad_callouts.SE_Years_For_Calendar
org.openbravo.erpCommon.ad_callouts.SL_CreateFromMultiple_Warehouse
org.openbravo.erpCommon.ad_callouts.SL_Payment_No_Verify
org.openbravo.erpCommon.ad_callouts.SL_CreateFromMultiple_Conversion
org.openbravo.erpCommon.ad_callouts.SL_MovementAll_Locator
org.openbravo.erpCommon.ad_callouts.SL_Payment_DocType
org.openbravo.erpCommon.ad_callouts.SL_CreateFromMultiple_Product
org.openbravo.erpCommon.ad_callouts.SL_Payment_Amounts
org.openbravo.erpCommon.ad_callouts.SE_Calendar_For_Org
org.openbravo.erpCommon.ad_callouts.SL_WorkRequirement_Sequence
org.openbravo.erpCommon.ad_callouts.SL_Invoice_Tax
org.openbravo.erpCommon.ad_callouts.SL_InOutLine_Locator
Steps To Reproduce-
Proposed SolutionDouble check each as usual before deleting anything and maybe remove them.
Note on removal careful to also remove any related items no longer used after deleting those callouts (i.e. xsql files, xmlengine template ...)
TagsNo tags attached.
Attached Filesdiff file icon 36280.diff [^] (62,814 bytes) 2017-06-27 13:36 [Show Content]

- Relationships Relation Graph ] Dependency Graph ]
depends on defect 0036362 closedAtulOpenbravo API Change request 
related to defect 0036279 closedshuehner Unused manual servlets: HeartbeatConfirm & RegistrationConfirm 
related to defect 0036358 closedmarkmm82 Create From Multiple process and related callouts are candidates to be deleted 
related to design defect 0036067 closedmarkmm82 old callouts should be refactored to implement SimpleCallout 
blocks design defect 0032688 acknowledgedplatform remove unused resources 

-  Notes
(0097708)
vmromanos (developer)
2017-06-27 12:45

Most of these callouts can be safely removed because they are not referenced by any internal or external class. This will obviously create an API change with very low risk.

However there are 3 callouts that won't be removed right now because they are referenced by a process. See 0036358 for details
(0104473)
hgbot (developer)
2018-05-11 13:58

Repository: erp/devel/api-checks
Changeset: 3aec9468515a8265dce7b7d5e03ac5ddbab136ed
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Fri May 11 13:57:15 2018 +0200
URL: http://code.openbravo.com/erp/devel/api-checks/rev/3aec9468515a8265dce7b7d5e03ac5ddbab136ed [^]

Fixes issue 36362: API change for issue 36280

---
M java/reference/java.japi.gz
M model/src-db/database/sourcedata/AD_CALLOUT.xml
---
(0104475)
hgbot (developer)
2018-05-11 13:58

Repository: erp/devel/pi
Changeset: 2db82514d5d58618fd8621ec5722e3b7a24c8f5e
Author: Atul Gaware <atul.gaware <at> openbravo.com>
Date: Wed May 02 23:46:36 2018 +0530
URL: http://code.openbravo.com/erp/devel/pi/rev/2db82514d5d58618fd8621ec5722e3b7a24c8f5e [^]

Fixes Issue 36280:Several unused + probably unusable callouts exists and are
candidates to be deleted.

** All the below callouts are not used in internal and external class and
has a low risk to remove them.
** Removed java files for SE_Years_For_Calendar, SE_Calendar_For_Org and
registers in ad_callout.
** Removed java files for SL_Payment_No_Verify, SL_MovementAll_Locator,
SL_Payment_DocType & data xsql file, SL_Payment_Amounts,
SL_WorkRequirement_Sequence & xsql file, SL_Invoice_Tax,
SL_InOutLine_Locator & data xsql file.

---
M src-db/database/sourcedata/AD_CALLOUT.xml
R src/org/openbravo/erpCommon/ad_callouts/SE_Calendar_For_Org.java
R src/org/openbravo/erpCommon/ad_callouts/SE_Years_For_Calendar.java
R src/org/openbravo/erpCommon/ad_callouts/SL_InOutLine_Locator.java
R src/org/openbravo/erpCommon/ad_callouts/SL_InOutLine_Locator_data.xsql
R src/org/openbravo/erpCommon/ad_callouts/SL_Invoice_Tax.java
R src/org/openbravo/erpCommon/ad_callouts/SL_MovementAll_Locator.java
R src/org/openbravo/erpCommon/ad_callouts/SL_Payment_Amounts.java
R src/org/openbravo/erpCommon/ad_callouts/SL_Payment_DocType.java
R src/org/openbravo/erpCommon/ad_callouts/SL_Payment_DocType_data.xsql
R src/org/openbravo/erpCommon/ad_callouts/SL_Payment_No_Verify.java
R src/org/openbravo/erpCommon/ad_callouts/SL_WorkRequirement_Sequence.java
R src/org/openbravo/erpCommon/ad_callouts/SL_WorkRequirement_Sequence.xsql
---
(0104476)
hgbot (developer)
2018-05-11 13:58

Repository: erp/devel/pi
Changeset: 2663ab08fb3f48cd010666fb0c5e58fc276dd25d
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Fri May 11 10:13:35 2018 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/2663ab08fb3f48cd010666fb0c5e58fc276dd25d [^]

Related to issue 36280: Remove SL_Payment_Amounts_data.xsql

---
R src/org/openbravo/erpCommon/ad_callouts/SL_Payment_Amounts_data.xsql
---
(0104480)
aferraz (developer)
2018-05-11 13:59

Code review + Testing OK
(0104495)
hudsonbot (developer)
2018-05-14 13:09

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/ed385e0e027b [^]
Maturity status: Test
(0104496)
hudsonbot (developer)
2018-05-14 13:09

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/ed385e0e027b [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2017-06-19 18:16 shuehner New Issue
2017-06-19 18:16 shuehner Assigned To => Triage Finance
2017-06-19 18:16 shuehner Modules => Core
2017-06-19 18:16 shuehner Triggers an Emergency Pack => No
2017-06-19 18:16 shuehner Relationship added related to 0036279
2017-06-27 12:23 vmromanos Status new => scheduled
2017-06-27 12:23 vmromanos Assigned To Triage Finance => vmromanos
2017-06-27 12:42 vmromanos Relationship added related to 0036358
2017-06-27 12:45 vmromanos Note Added: 0097708
2017-06-27 13:36 vmromanos File Added: 36280.diff
2017-06-27 14:12 vmromanos Relationship added depends on 0036362
2017-09-22 15:14 aferraz Relationship added related to 0036067
2018-04-16 11:59 shuehner Relationship added blocks 0032688
2018-04-25 10:05 dmiguelez Assigned To vmromanos => AtulOpenbravo
2018-05-11 13:58 hgbot Checkin
2018-05-11 13:58 hgbot Note Added: 0104473
2018-05-11 13:58 hgbot Checkin
2018-05-11 13:58 hgbot Note Added: 0104475
2018-05-11 13:58 hgbot Status scheduled => resolved
2018-05-11 13:58 hgbot Resolution open => fixed
2018-05-11 13:58 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/2db82514d5d58618fd8621ec5722e3b7a24c8f5e [^]
2018-05-11 13:58 hgbot Checkin
2018-05-11 13:58 hgbot Note Added: 0104476
2018-05-11 13:59 aferraz Review Assigned To => aferraz
2018-05-11 13:59 aferraz Note Added: 0104480
2018-05-11 13:59 aferraz Status resolved => closed
2018-05-11 13:59 aferraz Fixed in Version => 3.0PR18Q3
2018-05-14 13:09 hudsonbot Checkin
2018-05-14 13:09 hudsonbot Note Added: 0104495
2018-05-14 13:09 hudsonbot Checkin
2018-05-14 13:09 hudsonbot Note Added: 0104496


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker