Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0036195
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] 04. Warehouse managementmajoralways2017-06-06 13:552017-06-09 13:27
ReporterngarciaView Statuspublic 
Assigned Tomarkmm82 
PriorityimmediateResolutionfixedFixed in Version3.0PR17Q1.2
StatusclosedFix in branchFixed in SCM revision5c1488e2ccc4
ProjectionnoneETAnoneTarget Version3.0PR17Q1.2
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toaferraz
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2016-12-02
Regression introduced in release3.0PR17Q1
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/cde4e226d8de [^]
Triggers an Emergency PackNo
Summary

0036195: Cannot select an order line in Create Lines From of Goods Receipt window if it uses secondary UOM

DescriptionCannot select an order line in Create Lines From of Goods Receipt window if it uses secondary UOM
Steps To ReproduceAs system admin role:
   Set as displayed the 'Order Quantity' and 'Order UOM' fields of at least purchase order and goods receipt lines
   Set as active 'Product - UOM' and 'Unit Of Measure - Conversion' tabs

As group admin role:
   Create a new product
   Add a purchase price list to it
   Set a unit in the UOM tab, for example Kg
   Define a conversion between Kg and Unit
   Create a purchase order, add a line to it and include the previously created order
   Select Kg in Order UOM field and set the quantity in Order Quantity field
   Book it
   Create a Goods Receipt header
   Click on Create Lines From and select the already created order line
   Add a storage bin and click on OK
   Check the following error message is shown:

     "This record cannot be deleted because it is associated with other existing elements. Please see Linked Items"

   The logs shows:

   ERROR org.openbravo.erpCommon.ad_actionButton.CreateFromShipmentData - SQL error in query: INSERT INTO M_INOUTLINE ...

Exception:org.postgresql.util.PSQLException: ERROR: insert or update on table "m_inoutline" violates foreign key constraint "m_inoutline_m_product_uom"
  Detail: Key (m_product_uom_id)=(72BA247D31F745F3AF11F74A5E2CCBEF) is not present in table "m_product_uom".
   
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 0036184 closedmarkmm82 Cannot select an order line in Create Lines From of Goods Receipt window if it uses secondary UOM 

-  Notes
(0097283)
hgbot (developer)
2017-06-09 13:26

Repository: erp/backports/3.0PR17Q1.2
Changeset: 5c1488e2ccc41a5236f844dfca0e142bf31839ad
Author: Mark <markmm82 <at> gmail.com>
Date: Thu Jun 08 21:26:48 2017 -0400
URL: http://code.openbravo.com/erp/backports/3.0PR17Q1.2/rev/5c1488e2ccc41a5236f844dfca0e142bf31839ad [^]

Fixes issue 36195: Cannot select an order line in Create Lines From of Receipt
window if it uses secondary UOM

Cannot select an order line in Create Lines From of Goods Receipt window if it uses
secondary UOM.

It was caused because of use of the secondary unit of measure ID instead of the
M_PRODUCT_UOM_ID when creating the field provider for the field of secondary UOM.

To fix it, was used the M_PRODUCT_UOM_ID of the record when the secondary unit
is defined for the selected product, instead of the ID of it unit.

---
M src/org/openbravo/materialmgmt/UOMUtil.java
---
(0097285)
aferraz (developer)
2017-06-09 13:27

Code review + Testing OK

- Issue History
Date Modified Username Field Change
2017-06-07 22:11 markmm82 Type defect => backport
2017-06-07 22:11 markmm82 Target Version => 3.0PR17Q1.2
2017-06-09 11:49 aferraz Regression level => Production - Confirmed Stable
2017-06-09 11:49 aferraz Regression date => 2016-12-02
2017-06-09 11:49 aferraz Regression introduced in release => 3.0PR17Q1
2017-06-09 11:49 aferraz Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/cde4e226d8de [^]
2017-06-09 13:26 hgbot Checkin
2017-06-09 13:26 hgbot Note Added: 0097283
2017-06-09 13:26 hgbot Status scheduled => resolved
2017-06-09 13:26 hgbot Resolution open => fixed
2017-06-09 13:26 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/backports/3.0PR17Q1.2/rev/5c1488e2ccc41a5236f844dfca0e142bf31839ad [^]
2017-06-09 13:27 aferraz Review Assigned To => aferraz
2017-06-09 13:27 aferraz Note Added: 0097285
2017-06-09 13:27 aferraz Status resolved => closed
2017-06-09 13:27 aferraz Fixed in Version => 3.0PR17Q1.2


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker