Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0036184
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 04. Warehouse managementmajoralways2017-06-06 13:552017-06-09 22:41
ReporterngarciaView Statuspublic 
Assigned Tomarkmm82 
PriorityimmediateResolutionfixedFixed in Version3.0PR17Q3
StatusclosedFix in branchFixed in SCM revisiond5b16e274d2c
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toaferraz
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2016-12-02
Regression introduced in release3.0PR17Q1
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/cde4e226d8de [^]
Triggers an Emergency PackNo
Summary

0036184: Cannot select an order line in Create Lines From of Goods Receipt window if it uses secondary UOM

DescriptionCannot select an order line in Create Lines From of Goods Receipt window if it uses secondary UOM
Steps To ReproduceAs system admin role:
   Set as displayed the 'Order Quantity' and 'Order UOM' fields of at least purchase order and goods receipt lines
   Set as active 'Product - UOM' and 'Unit Of Measure - Conversion' tabs

As group admin role:
   Create a new product
   Add a purchase price list to it
   Set a unit in the UOM tab, for example Kg
   Define a conversion between Kg and Unit
   Create a purchase order, add a line to it and include the previously created product
   Select Kg in Order UOM field and set the quantity in Order Quantity field
   Book it
   Create a Goods Receipt header
   Click on Create Lines From and select the already created order line
   Add a storage bin and click on OK
   Check the following error message is shown:

     "This record cannot be deleted because it is associated with other existing elements. Please see Linked Items"

   The logs shows:

   ERROR org.openbravo.erpCommon.ad_actionButton.CreateFromShipmentData - SQL error in query: INSERT INTO M_INOUTLINE ...

Exception:org.postgresql.util.PSQLException: ERROR: insert or update on table "m_inoutline" violates foreign key constraint "m_inoutline_m_product_uom"
  Detail: Key (m_product_uom_id)=(72BA247D31F745F3AF11F74A5E2CCBEF) is not present in table "m_product_uom".
   
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00361943.0PR17Q2.1 closedmarkmm82 Cannot select an order line in Create Lines From of Goods Receipt window if it uses secondary UOM 
depends on backport 00361953.0PR17Q1.2 closedmarkmm82 Cannot select an order line in Create Lines From of Goods Receipt window if it uses secondary UOM 
caused by feature request 0034693 closeddmiguelez Support Multi UOM in Openbravo 
related to defect 0036216 closedinigosanchez Not possible to change secondary quantity nor secondary unit in Goods Receipt create lines from process 

-  Notes
(0097195)
markmm82 (developer)
2017-06-07 17:33
edited on: 2017-06-09 12:18

Test Plan 1: Using Secondary Units of Measure
As system admin role:
   Set as displayed the 'Order Quantity' and 'Order UOM' fields of at least purchase order and goods receipt lines
   Set as active 'Product - UOM' and 'Unit Of Measure - Conversion' tabs

As group admin role:
   Create a new product, for instance A
   Add a purchase price list to it
   Set a unit in the UOM tab, for example Liter
   Define a conversion between Liter and Unit = 10
   Create a purchase order, add a line to it and include the previously created product. Be sure to fill this values in More Information section:
     Select Liter in Order UOM field and set the quantity in Order Quantity field = 10.
     Notice the Order quantity is updated to 100 because teh conversion between Liter and Unit.
   Book it
   Create a Goods Receipt header
   Click on Create Lines From and select the already created order line, using the Secondary Unit with the purchase order line was created. This case: Liter. Take all the quantity.
   Add a storage bin and click on OK
     Check the process ends successfully.
     Notice in the created line the following values:
        Movement quantity = 100
    UOM = Unit
    Order Quantity = 10
    Order UOM = Liter.
   Complete the receipt, and process is successfully too.

Test Plan 2: Using AUM Management
Use the same settings of Test Plan 1 in order to have configured secondary units and alternate units of measure.
As system admin role:
   Activate the Enable UOM Management Preference.

As group admin role:
   Create a new product, for instance B
   Add a purchase price list to it
   Go to Alternate UOM tab (Notice UOM tab is not visible)
     Define a new one to Liter UOM, Purchase = Primary and Conversion Rate = 20.
   Go to Unit of Measure window and define a conversion between Liter and Unit, rate = 10 if it doesn't exists (Differentiate with created in Alternate UOM)
   Create a purchase order, add a line to it and include the previously created product B.
     Notice Order UOM and Order Quantity fields are not present. Instead there are Operative quantity and Alternative UOM fields.
     Select Liter in Alternative UOM field and set the Operative Quantity as 10.
     Notice the Ordered quantity is updated to 200 because the alternate conversion between Liter and Unit and it is read only.
   Book it
   Create a Goods Receipt header
   Click on Create Lines From and select the already created order line, using the Alternative Unit defined in the purchase order line. This case: Liter. Take all the quantity.
   Add a storage bin and click on OK
     Check the process ends successfully.
     Notice in the created line the following values:
        Operative Quantity = 10
    UOM = Unit
        Alternative UOM = Liter
        Movement Quantity = 200
   Complete the receipt, and process is successfully.

(0097287)
hgbot (developer)
2017-06-09 13:35

Repository: erp/devel/pi
Changeset: d5b16e274d2cc9602a9101ce3215f274be5a356e
Author: Mark <markmm82 <at> gmail.com>
Date: Thu Jun 08 21:26:48 2017 -0400
URL: http://code.openbravo.com/erp/devel/pi/rev/d5b16e274d2cc9602a9101ce3215f274be5a356e [^]

Fixes issue 36184: Cannot select an order line in Create Lines From of Receipt
window if it uses secondary UOM

Cannot select an order line in Create Lines From of Goods Receipt window if it uses
secondary UOM.

It was caused because of use of the secondary unit of measure ID instead of the
M_PRODUCT_UOM_ID when creating the field provider for the field of secondary UOM.

To fix it, was used the M_PRODUCT_UOM_ID of the record when the secondary unit
is defined for the selected product, instead of the ID of it unit.

---
M src/org/openbravo/materialmgmt/UOMUtil.java
---
(0097288)
aferraz (developer)
2017-06-09 13:36

Code review + Testing OK
(0097298)
hudsonbot (developer)
2017-06-09 22:41

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/282dd511870b [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2017-06-06 13:55 ngarcia New Issue
2017-06-06 13:55 ngarcia Assigned To => Triage Finance
2017-06-06 13:55 ngarcia Modules => Core
2017-06-06 13:55 ngarcia Triggers an Emergency Pack => No
2017-06-06 13:55 ngarcia Issue Monitored: networkb
2017-06-06 17:44 aferraz Assigned To Triage Finance => markmm82
2017-06-06 18:08 markmm82 Status new => acknowledged
2017-06-07 17:33 markmm82 Note Added: 0097195
2017-06-07 22:11 markmm82 Status acknowledged => scheduled
2017-06-07 22:25 markmm82 Note Edited: 0097195 View Revisions
2017-06-07 22:26 markmm82 Note Edited: 0097195 View Revisions
2017-06-08 10:19 aferraz Relationship added caused by 0034693
2017-06-08 10:51 aferraz Steps to Reproduce Updated View Revisions
2017-06-08 11:18 aferraz Regression level => Production - Confirmed Stable
2017-06-08 11:18 aferraz Regression date => 2016-12-02
2017-06-08 11:18 aferraz Regression introduced in release => 3.0PR17Q1
2017-06-08 11:18 aferraz Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/cde4e226d8de [^]
2017-06-09 09:54 aferraz Relationship added related to 0036216
2017-06-09 12:18 aferraz Note Edited: 0097195 View Revisions
2017-06-09 13:35 hgbot Checkin
2017-06-09 13:35 hgbot Note Added: 0097287
2017-06-09 13:35 hgbot Status scheduled => resolved
2017-06-09 13:35 hgbot Resolution open => fixed
2017-06-09 13:35 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/d5b16e274d2cc9602a9101ce3215f274be5a356e [^]
2017-06-09 13:36 aferraz Review Assigned To => aferraz
2017-06-09 13:36 aferraz Note Added: 0097288
2017-06-09 13:36 aferraz Status resolved => closed
2017-06-09 13:36 aferraz Fixed in Version => 3.0PR17Q3
2017-06-09 22:41 hudsonbot Checkin
2017-06-09 22:41 hudsonbot Note Added: 0097298


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker