Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0036180
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 09. Financial managementmajorsometimes2017-06-06 09:362017-06-08 17:12
Reportereduardo_ArgalView Statuspublic 
Assigned Tomarkmm82 
PriorityurgentResolutionfixedFixed in Version3.0PR17Q3
StatusclosedFix in branchFixed in SCM revision74b0fb916b1f
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toaferraz
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0036180: Add Multiple payments pick and execute performance

Descriptionwhen using Add multiple payments the resultant query when unfolding BP filter combo box is extreamly slow.
The problem seems to be related to the usage of AD_ISORGINCLUDED function
Steps To Reproduce1) Move to Financial account window
2) open add multiple payments P&E
3) move to BP column and unfold the combo box
4) realize the query is performing awfully
Proposed SolutionInstead of using ad_isorgincluded function, try to make a join to AD_Org_Tree table. This was proben to improve performance
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on feature request 00355903.0PR17Q3 closedvmromanos AD_IsOrgIncluded performance improvements 
related to defect 0038551 closedAtulOpenbravo Improve performance of Add Multiple Payments process in Financial Account window 

-  Notes
(0097206)
hgbot (developer)
2017-06-08 11:34

Repository: erp/devel/pi
Changeset: 74b0fb916b1f87e67a865f097f035909aaa7c968
Author: Mark <markmm82 <at> gmail.com>
Date: Tue Jun 06 17:05:14 2017 -0400
URL: http://code.openbravo.com/erp/devel/pi/rev/74b0fb916b1f87e67a865f097f035909aaa7c968 [^]

Fixes issue 36180: Add Multiple payments pick and execute performance

When the BP filter combo box of Add multiple payments P&E the resultant query is
slow. The problem is related to the usage of AD_ISORGINCLUDED function.

To avoid it, and improve the performance, was used an EXISTS clause in the AD_ORG_TREE
table instead of using AD_ISORGINCLUDED function.

---
M modules/org.openbravo.advpaymentmngt/src-db/database/sourcedata/AD_TAB.xml
---
(0097210)
aferraz (developer)
2017-06-08 11:46

Code review + Testing OK
(0097248)
hudsonbot (developer)
2017-06-08 17:12

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/fda0f16ab470 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2017-06-06 09:36 eduardo_Argal New Issue
2017-06-06 09:36 eduardo_Argal Assigned To => Triage Finance
2017-06-06 09:36 eduardo_Argal Modules => Core
2017-06-06 09:36 eduardo_Argal Triggers an Emergency Pack => No
2017-06-06 10:15 aferraz Resolution time => 1498514400
2017-06-06 10:24 aferraz Assigned To Triage Finance => markmm82
2017-06-06 16:04 markmm82 Status new => scheduled
2017-06-07 12:21 aferraz Relationship added depends on 0035590
2017-06-08 11:34 hgbot Checkin
2017-06-08 11:34 hgbot Note Added: 0097206
2017-06-08 11:34 hgbot Status scheduled => resolved
2017-06-08 11:34 hgbot Resolution open => fixed
2017-06-08 11:34 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/74b0fb916b1f87e67a865f097f035909aaa7c968 [^]
2017-06-08 11:46 aferraz Review Assigned To => aferraz
2017-06-08 11:46 aferraz Note Added: 0097210
2017-06-08 11:46 aferraz Status resolved => closed
2017-06-08 11:46 aferraz Fixed in Version => 3.0PR17Q3
2017-06-08 17:12 hudsonbot Checkin
2017-06-08 17:12 hudsonbot Note Added: 0097248
2018-05-17 09:22 vmromanos Relationship added related to 0038551


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker