Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0036092
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2017-05-25 08:372017-06-20 17:15
ReportervmromanosView Statuspublic 
Assigned Toalostale 
PriorityimmediateResolutionfixedFixed in Version3.0PR17Q3
StatusclosedFix in branchFixed in SCM revision472e625ebe84
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tocaristu
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2016-09-21
Regression introduced in release3.0PR17Q1
Regression introduced by commithttp://code.openbravo.com/erp/devel/pi/rev/02c7d99b53e94e81945da798a3130bb2a0aa192 [^]
Triggers an Emergency PackNo
Summary

0036092: Failed to apply roles dataset

DescriptionSince 3.0PR17Q1 is not possible to apply the roles dataset anymore. The following error is raised:

    
Error
Create reference data process failed

[...]

Processing dataset V3 Roles
Exception when parsing entity ADRole (CA5B7FB2C95740E499C0F102343D51AD):Property clientList does not exist for entity ADRole Exception when parsing entity ADRole (D7D7D228E4594ACE8D00FD0E08B333DE):Property clientList does not exist for entity ADRole Exception when parsing entity ADRole (FF8081812250326E012250353BDE0005):Property clientList does not exist for entity ADRole Exception when parsing entity ADRole (FF8081812250326E012250353BDE0006):Property clientList does not exist for entity ADRole Exception when parsing entity ADRole (FF808181259DADEB01259DDDA4BB01E5):Property clientList does not exist for entity ADRole Exception when parsing entity ADRole (FF808181259DADEB01259DDDA4C201E6):Property clientList does not exist for entity ADRole Exception when parsing entity ADRole (FF808181259DADEB01259DDDA4C201E7):Property clientList does not exist for entity ADRole Referenced object ADRole (id: FF808181259DADEB01259DDDA4BB01E5 / ADRoleFF808181259DADEB01259DDDA4BB01E5) not present in the xml or in the database. Referenced object ADRole (id: FF8081812250326E012250353BDE0006 / ADRoleFF8081812250326E012250353BDE0006) not present in the xml or in the database. Referenced object ADRole (id: FF8081812250326E012250353BDE0005 / ADRoleFF8081812250326E012250353BDE0005) not present in the xml or in the database. Referenced object ADRole (id: D7D7D228E4594ACE8D00FD0E08B333DE / ADRoleD7D7D228E4594ACE8D00FD0E08B333DE) not present in the xml or in the database. Referenced object ADRole (id: CA5B7FB2C95740E499C0F102343D51AD / ADRoleCA5B7FB2C95740E499C0F102343D51AD) not present in the xml or in the database. Referenced object ADRole (id: FF808181259DADEB01259DDDA4C201E7 / ADRoleFF808181259DADEB01259DDDA4C201E7) not present in the xml or in the database. Referenced object ADRole (id: FF808181259DADEB01259DDDA4C201E6 / ADRoleFF808181259DADEB01259DDDA4C201E6) not present in the xml or in the database.
Create reference data process failed




Problem seems to be related to API change 0034297
Steps To ReproduceLogin as Openbravo Admin
Change role to System Administrator
Open Initial Client Setup
Fill mandatory fields and uncheck Include Accounting
Select Pre-configured collection of standard ERP roles - Standard Roles
Press OK.
Error is raised
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00360953.0PR17Q2.1 closedcaristu Failed to apply roles dataset 
depends on backport 00360963.0PR17Q1.2 closedalostale Failed to apply roles dataset 
caused by defect 00342013.0PR17Q1 closedalostale can't create import entries while changing role organization access 
related to defect 0036097 closedalostale applying dataset fails if it contains properties not present in the target system 
related to feature request 0036125 newplatform Create new (ideally non-selenium) junit test to apply all data found in installation 

-  Notes
(0096778)
hgbot (developer)
2017-05-25 09:57

Repository: erp/devel/pi
Changeset: 472e625ebe8492a09af209c7ef8559301f4eb1fc
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Thu May 25 09:50:37 2017 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/472e625ebe8492a09af209c7ef8559301f4eb1fc [^]

fixed bug 36092: Failed to apply roles dataset

  Roles dataset still made reference to removed client and organization lists.

  These references have been removed.

---
M modules/org.openbravo.v3.datasets/referencedata/standard/V3_Roles.xml
---
(0096781)
caristu (developer)
2017-05-25 10:09

Code review + testing OK.
(0096986)
hudsonbot (developer)
2017-05-29 17:43

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/1ee70113bdc4 [^]
Maturity status: Test
(0097528)
hgbot (developer)
2017-06-20 17:15

Repository: tools/automation/int
Changeset: 80d4cc71b61f9f74b789bedcad20549e070cf14a
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Thu May 25 12:39:54 2017 +0200
URL: http://code.openbravo.com/tools/automation/int/rev/80d4cc71b61f9f74b789bedcad20549e070cf14a [^]

related with bug 36092: Failed to apply roles dataset

  Included in initial client setup roles dataset that was failing.

---
M src-test/com/openbravo/test/integration/erp/testsuites/smoke/masterdata/ADMc_SetupClientAndOrganization.java
---

- Issue History
Date Modified Username Field Change
2017-05-25 08:37 vmromanos New Issue
2017-05-25 08:37 vmromanos Assigned To => platform
2017-05-25 08:37 vmromanos Modules => Core
2017-05-25 08:37 vmromanos Triggers an Emergency Pack => No
2017-05-25 09:26 alostale Assigned To platform => alostale
2017-05-25 09:27 alostale Relationship added caused by 0034201
2017-05-25 09:37 alostale Review Assigned To => caristu
2017-05-25 09:37 alostale Regression date => 2016-09-21
2017-05-25 09:37 alostale Regression introduced in release => 3.0PR17Q1
2017-05-25 09:37 alostale Regression introduced by commit => http://code.openbravo.com/erp/devel/pi/rev/02c7d99b53e94e81945da798a3130bb2a0aa192 [^]
2017-05-25 09:37 alostale Priority normal => immediate
2017-05-25 09:53 alostale Status new => scheduled
2017-05-25 09:57 hgbot Checkin
2017-05-25 09:57 hgbot Note Added: 0096778
2017-05-25 09:57 hgbot Status scheduled => resolved
2017-05-25 09:57 hgbot Resolution open => fixed
2017-05-25 09:57 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/472e625ebe8492a09af209c7ef8559301f4eb1fc [^]
2017-05-25 10:09 caristu Note Added: 0096781
2017-05-25 10:09 caristu Status resolved => closed
2017-05-25 10:09 caristu Fixed in Version => 3.0PR17Q3
2017-05-25 10:17 alostale Relationship added related to 0036097
2017-05-25 10:27 alostale Regression level => Production - Confirmed Stable
2017-05-29 12:43 shuehner Relationship added related to 0036125
2017-05-29 17:43 hudsonbot Checkin
2017-05-29 17:43 hudsonbot Note Added: 0096986
2017-06-20 17:15 hgbot Checkin
2017-06-20 17:15 hgbot Note Added: 0097528


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker