Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0036095
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] A. Platformmajoralways2017-05-25 08:372017-06-15 12:21
ReportervmromanosView Statuspublic 
Assigned Tocaristu 
PriorityimmediateResolutionfixedFixed in Version3.0PR17Q2.1
StatusclosedFix in branchFixed in SCM revisionc2d6e38b0ed4
ProjectionnoneETAnoneTarget Version3.0PR17Q2.1
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToAugustoMauch
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2016-09-21
Regression introduced in release3.0PR17Q1
Regression introduced by commithttp://code.openbravo.com/erp/devel/pi/rev/02c7d99b53e94e81945da798a3130bb2a0aa192 [^]
Triggers an Emergency PackNo
Summary

0036095: Failed to apply roles dataset

DescriptionSince 3.0PR17Q1 is not possible to apply the roles dataset anymore. The following error is raised:

    
Error
Create reference data process failed

[...]

Processing dataset V3 Roles
Exception when parsing entity ADRole (CA5B7FB2C95740E499C0F102343D51AD):Property clientList does not exist for entity ADRole Exception when parsing entity ADRole (D7D7D228E4594ACE8D00FD0E08B333DE):Property clientList does not exist for entity ADRole Exception when parsing entity ADRole (FF8081812250326E012250353BDE0005):Property clientList does not exist for entity ADRole Exception when parsing entity ADRole (FF8081812250326E012250353BDE0006):Property clientList does not exist for entity ADRole Exception when parsing entity ADRole (FF808181259DADEB01259DDDA4BB01E5):Property clientList does not exist for entity ADRole Exception when parsing entity ADRole (FF808181259DADEB01259DDDA4C201E6):Property clientList does not exist for entity ADRole Exception when parsing entity ADRole (FF808181259DADEB01259DDDA4C201E7):Property clientList does not exist for entity ADRole Referenced object ADRole (id: FF808181259DADEB01259DDDA4BB01E5 / ADRoleFF808181259DADEB01259DDDA4BB01E5) not present in the xml or in the database. Referenced object ADRole (id: FF8081812250326E012250353BDE0006 / ADRoleFF8081812250326E012250353BDE0006) not present in the xml or in the database. Referenced object ADRole (id: FF8081812250326E012250353BDE0005 / ADRoleFF8081812250326E012250353BDE0005) not present in the xml or in the database. Referenced object ADRole (id: D7D7D228E4594ACE8D00FD0E08B333DE / ADRoleD7D7D228E4594ACE8D00FD0E08B333DE) not present in the xml or in the database. Referenced object ADRole (id: CA5B7FB2C95740E499C0F102343D51AD / ADRoleCA5B7FB2C95740E499C0F102343D51AD) not present in the xml or in the database. Referenced object ADRole (id: FF808181259DADEB01259DDDA4C201E7 / ADRoleFF808181259DADEB01259DDDA4C201E7) not present in the xml or in the database. Referenced object ADRole (id: FF808181259DADEB01259DDDA4C201E6 / ADRoleFF808181259DADEB01259DDDA4C201E6) not present in the xml or in the database.
Create reference data process failed




Problem seems to be related to API change 0034297
Steps To ReproduceLogin as Openbravo Admin
Change role to System Administrator
Open Initial Client Setup
Fill mandatory fields and uncheck Include Accounting
Select Pre-configured collection of standard ERP roles - Standard Roles
Press OK.
Error is raised
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 0036092 closedalostale Failed to apply roles dataset 

-  Notes
(0097414)
hgbot (developer)
2017-06-15 11:22

Repository: erp/backports/3.0PR17Q2.1
Changeset: c2d6e38b0ed46ee43953f9f3df77649c7e27a8c7
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Thu Jun 15 11:21:21 2017 +0200
URL: http://code.openbravo.com/erp/backports/3.0PR17Q2.1/rev/c2d6e38b0ed46ee43953f9f3df77649c7e27a8c7 [^]

fixed bug 36095: Failed to apply roles dataset

Roles dataset still made reference to removed client and organization lists.

These references have been removed.

---
M modules/org.openbravo.v3.datasets/referencedata/standard/V3_Roles.xml
---
(0097420)
AugustoMauch (developer)
2017-06-15 12:21

Code reviewed and verified

- Issue History
Date Modified Username Field Change
2017-05-25 09:53 alostale Type defect => backport
2017-05-25 09:53 alostale Target Version => 3.0PR17Q2.1
2017-05-25 10:27 alostale Regression level => Production - Confirmed Stable
2017-06-15 11:22 hgbot Checkin
2017-06-15 11:22 hgbot Note Added: 0097414
2017-06-15 11:22 hgbot Status scheduled => resolved
2017-06-15 11:22 hgbot Resolution open => fixed
2017-06-15 11:22 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/backports/3.0PR17Q2.1/rev/c2d6e38b0ed46ee43953f9f3df77649c7e27a8c7 [^]
2017-06-15 11:22 caristu Assigned To alostale => caristu
2017-06-15 11:22 caristu Review Assigned To caristu => AugustoMauch
2017-06-15 12:21 AugustoMauch Note Added: 0097420
2017-06-15 12:21 AugustoMauch Status resolved => closed
2017-06-15 12:21 AugustoMauch Fixed in Version => 3.0PR17Q2.1


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker