Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0035782
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajorhave not tried2017-04-12 17:402017-05-29 17:43
ReportershuehnerView Statuspublic 
Assigned Toinigosanchez 
PrioritynormalResolutionfixedFixed in Version3.0PR17Q3
StatusclosedFix in branchFixed in SCM revision5a72ca509c6f
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0035782: ant compile.complete.deploy is missing dependencies on core.lib wad.lib trl.lib

DescriptionThat causes compile errors of unsupecting users if some changes are done in i.e. src-core which require recompile to get rest of compile working.

Note:
That has been fixed long time ago in compile.complete but the compile.complete.deploy internally does not reuse this so fix does not auto-apply.
Steps To Reproduce-
Proposed SolutionJust add ant depends
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0013425 closedmigueldejuana ant compile.complete should depend on core.lib, wad.lib, trl.lib 

-  Notes
(0096162)
inigosanchez (developer)
2017-04-25 17:10
edited on: 2017-04-25 17:22

Test plan:
- Execute ant compile.complete.deploy > It should be executed core.lib, wad.lib and trl.lib.
- Execute ant compile.complete.development (Openbravo.properties > deploy.mode=class) > It should be executed core.lib, wad.lib and trl.lib.
- Execute ant compile.complete.war (Openbravo.properties > deploy.mode=war) > It should be executed core.lib, wad.lib and trl.lib.

(0096169)
hgbot (developer)
2017-04-25 17:46

Repository: erp/devel/pi
Changeset: 5a72ca509c6fe71ebef703eb38159380ba8d5a9d
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Tue Apr 25 17:34:18 2017 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/5a72ca509c6fe71ebef703eb38159380ba8d5a9d [^]

Fixed issue 35782: compile.complete.deploy depend on core.lib,wad.lib,trl.lib

Compile.complete.deploy ant task now is depent on core.lib,wad.lib,trl.lib because if deploy.mode
in Openbravo.properties is configured to class mode compile.complete.development ant task is
executed and now this task depend on core.lib,wad.lib and trl.lib.

On the other hand if deploy.mode in Openbravo.properties is configured to war mode, compile.complete
is executed and this ant task has the dependencies defined properly.

---
M build.xml
---
(0096251)
alostale (developer)
2017-04-28 08:51

reviewed + tested
(0096908)
hudsonbot (developer)
2017-05-29 17:43

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/1ee70113bdc4 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2017-04-12 17:40 shuehner New Issue
2017-04-12 17:40 shuehner Assigned To => platform
2017-04-12 17:40 shuehner Modules => Core
2017-04-12 17:40 shuehner Triggers an Emergency Pack => No
2017-04-12 17:42 shuehner Relationship added related to 0013425
2017-04-25 16:29 inigosanchez Status new => scheduled
2017-04-25 16:29 inigosanchez Assigned To platform => inigosanchez
2017-04-25 16:37 inigosanchez Review Assigned To => alostale
2017-04-25 17:10 inigosanchez Note Added: 0096162
2017-04-25 17:22 inigosanchez Note Edited: 0096162 View Revisions
2017-04-25 17:46 hgbot Checkin
2017-04-25 17:46 hgbot Note Added: 0096169
2017-04-25 17:46 hgbot Status scheduled => resolved
2017-04-25 17:46 hgbot Resolution open => fixed
2017-04-25 17:46 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/5a72ca509c6fe71ebef703eb38159380ba8d5a9d [^]
2017-04-28 08:51 alostale Note Added: 0096251
2017-04-28 08:51 alostale Status resolved => closed
2017-04-28 08:51 alostale Fixed in Version => 3.0PR17Q3
2017-05-29 17:43 hudsonbot Checkin
2017-05-29 17:43 hudsonbot Note Added: 0096908


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker