Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0035550
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POS Hardware Managermajoralways2017-03-17 08:552017-03-24 11:02
ReporterguillermogilView Statuspublic 
Assigned Tojorge-garcia 
PriorityimmediateResolutionfixedFixed in VersionRR17Q2
StatusclosedFix in branchFixed in SCM revisionc60cc9f812b9
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tomarvintm
Regression levelProduction - Confirmed Stable
Regression date2014-09-04
Regression introduced in releaseRR14Q4
Regression introduced by commithttps://code.openbravo.com/erp/pmods/org.openbravo.retail.poshwmanager.sources/rev/fc8956a468f3 [^]
Triggers an Emergency PackNo
Summary

0035550: Check Drawer status does not work

DescriptionCheck Drawer status does not work with EPSON TM-T88IV and POSIFLEX CR6000.
HWM screen test seems to be working.

It is returning always an error and that creates a wrong behavior on WebPOS
Steps To ReproduceWith EPSON TM-T88IV and POSIFLEX CR6000
Configure HWM properties file
Open the HWM
Click Test Drawer
Click Check Drawer Status

You will see that Error is always returned
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0035547 closedRetail Hardware manager does not open if you uses a virtualized port 
depends on backport 0035554RR17Q1.1 closedjorge-garcia Check Drawer status does not work 
depends on backport 0035555RR16Q4.3 closedjorge-garcia Check Drawer status does not work 

-  Notes
(0095358)
jorge-garcia (developer)
2017-03-17 10:31

Changeset is not "linked" to an issue, caused by info can't be updated
(0095364)
hgbot (developer)
2017-03-17 11:43

Repository: erp/pmods/org.openbravo.retail.poshwmanager.sources
Changeset: c60cc9f812b94170a46bb96d026416e644286bb2
Author: Jorge Garcia <jorge.garcia <at> openbravo.com>
Date: Fri Mar 17 10:23:42 2017 +0100
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.poshwmanager.sources/rev/c60cc9f812b94170a46bb96d026416e644286bb2 [^]

Fixed issue 35550: Check Drawer status does not work

Reverted code to manage properly the status of drawer.

---
M project/src/com/openbravo/pos/printer/escpos/DevicePrinterESCPOS.java
---
(0095365)
hgbot (developer)
2017-03-17 11:44

Repository: erp/pmods/org.openbravo.retail.poshwmanager
Changeset: 2ec9ffdf817c9b4b13f2724f9fa1ad2f29ca05fd
Author: Jorge Garcia <jorge.garcia <at> openbravo.com>
Date: Fri Mar 17 10:48:10 2017 +0100
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.poshwmanager/rev/2ec9ffdf817c9b4b13f2724f9fa1ad2f29ca05fd [^]

Related to issue 35550: Check Drawer status does not work

Compile hwmanager

---
M bin/poshw.jar
M bin/rev.id
---

- Issue History
Date Modified Username Field Change
2017-03-17 08:55 guillermogil New Issue
2017-03-17 08:55 guillermogil Assigned To => Retail
2017-03-17 08:55 guillermogil Regression level => Production - Confirmed Stable
2017-03-17 08:55 guillermogil Triggers an Emergency Pack => No
2017-03-17 08:55 guillermogil Relationship added related to 0035547
2017-03-17 09:17 guillermogil Regression introduced in release => RR14Q4
2017-03-17 09:57 guillermogil Regression introduced by commit => https://code.openbravo.com/erp/pmods/org.openbravo.retail.poshwmanager.sources/rev/fc8956a468f3 [^]
2017-03-17 10:19 jorge-garcia Regression date => 2014-09-04
2017-03-17 10:31 jorge-garcia Status new => scheduled
2017-03-17 10:31 jorge-garcia Note Added: 0095358
2017-03-17 10:31 jorge-garcia Assigned To Retail => jorge-garcia
2017-03-17 11:43 hgbot Checkin
2017-03-17 11:43 hgbot Note Added: 0095364
2017-03-17 11:43 hgbot Status scheduled => resolved
2017-03-17 11:43 hgbot Resolution open => fixed
2017-03-17 11:43 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.poshwmanager.sources/rev/c60cc9f812b94170a46bb96d026416e644286bb2 [^]
2017-03-17 11:44 hgbot Checkin
2017-03-17 11:44 hgbot Note Added: 0095365
2017-03-24 11:02 marvintm Severity critical => major
2017-03-24 11:02 marvintm Review Assigned To => marvintm
2017-03-24 11:02 marvintm Status resolved => closed
2017-03-24 11:02 marvintm Fixed in Version => RR17Q2


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker