Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0035545
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2017-03-16 17:302017-05-29 17:43
ReporterVictorVillarView Statuspublic 
Assigned Toinigosanchez 
PriorityurgentResolutionfixedFixed in Version3.0PR17Q3
StatusclosedFix in branchFixed in SCM revision1f63d7f9e061
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0035545: There is no tree view in a subtab under some circumstancies

DescriptionIf you configure the tree view in a subtab and in order to generate the data in this subtab you need to launch a process (having selected the header register), no data will appear in the subtab, but when you change the focus, select the subtab and refresh it, you will see it properly.
Steps To ReproduceConfigure the tree view in the Manufacturing Plan lines tab [1] 
Configure the necessary to launch the manufacturing Plan [2]

[1] http://wiki.openbravo.com/wiki/How_to_Define_a_Table_as_a_Tree [^]
[2] http://wiki.openbravo.com/wiki/Material_Requirement_(MRP)#Configuration [^]
[2] this is the summary:


1. Product window: create 2 Products for raw materials and final products.
                  a. Production checkbox selected.
    b. For Raw materials the Purchase flag should be checked. For final products the purchase checkbox not selected.
Manufacturing tab: add a new register for organization ABE selecting the planning method (created before with the demands and supplies) and Safety Stock: 2000

 2. Manufacturing Cost Center window:
Create new record,
select US in the organization field,
 type search key and name.

3. Activity window, to configure the Production Activities:
- Create new record, selecting US in the organization field.
- Select the cost center required,
- Type search key and name.
4. Process Plan window: create the process Plan by typing Process Plan in the quick launch menu and create new record:
Select US in Organization
type search key and name
Process unit and Conversion rate
4.a. Version tab: create a version for the Process Plan with starting and ending date
4.b. Operations tab: create the operations needed for the Process Plan.
Create one record defining the sequence of the Process Plan.
type search key and name.
Select the activity
4.c. I/O Products tab: input-output of the products of the sequence.
Create a new record and select Product
Production Type (if product is consumed P- or produced P+ in the production process)
Quantity needed.

5. Product window: for the Final Products it is necessary to select the Process Plan created for the corresponding product.

6. Work Requirement window:
Create new record,
select US in the organization field
Select quantity, creation date, starting date, ending date
Select the Process Plan that this work requirement refers to
Press Process Work Requirement button and the information from the Process Plan will be inserted
 
Create a sales order for the final product.
Qty: 4000

Go to Manufacturing PLan window
  Create a new register for the product you need to launch the Manufacturing Plan process (the P+)
The lines will be automatically created. Click in Tree view.

Create a new register in the header for the product you need to launch the Manufacturing Plan Process (the P+)
 no data appears in the grid unless you click in the subtab and refresh it.
TagsNo tags attached.
Attached Files? file icon 35545.export [^] (2,362 bytes) 2017-03-30 18:48

- Relationships Relation Graph ] Dependency Graph ]
causes defect 0037399 closedcaristu Duplicated DS Request to the tree datasource having the tree view displayed in a sub-tab 

-  Notes
(0095498)
AugustoMauch (developer)
2017-03-22 11:32

The problem seems to be here [1]. The this.treeGrid.fetchData command is executed, but it does not result in a datasource request being done.

A hackish but easy way to reproduce would be to:
- Open the Account Tree window
- Select a record in the header tab
- Show the tree view in the Element Value subtab
- Execute this in the console: isc_OBStandardView_X.doRefreshContents(true) (replace X with the ID of the Element Value view). If you check in the developers console, a request is done to the standard datasource for FinancialMgmtElementValue, but no request to D2F94DC86DEC48D69E4BFCE59DC670CF (tree datasource for that tab) is done.

[1] https://code.openbravo.com/erp/devel/pi/file/d0204c203b22/modules/org.openbravo.client.application/web/org.openbravo.client.application/js/main/ob-standard-view.js#l1271 [^]
(0095709)
inigosanchez (developer)
2017-03-30 14:01

Added a test in testlink: Platform > [TGV] Tree Grid View > [TGVc] Custom Tree Structure > TGVc010 fetch data should be done on refreshContents
(0095738)
inigosanchez (developer)
2017-03-30 18:49

Attached solution patch
(0095823)
hgbot (developer)
2017-04-04 14:07

Repository: erp/devel/pi
Changeset: 1f63d7f9e0618c52fa8f9b4fae7d1350782d22d9
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Thu Mar 30 18:46:58 2017 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/1f63d7f9e0618c52fa8f9b4fae7d1350782d22d9 [^]

Fixed issue 35545: No tree view on a sub-tab in some circumstances

The problem was found in an environment with the configured manufacturing
plan and the tree view in the Lines tab of the manufacturing plan. If you
have the tree view on the subtab and you want to generate the data in this
subtab you must start a process (having selected the header record and
started the Production Plan process), no data will appear on the subtab.

The problem was that the doRefreshContents method did not working as
expected with a tree view. When the this.treeGrid.fetchData command is
executed, a call to the datasource is not being made as expected.This is
occurred because SmartClient determines that the call to the datasource is
not necessary (no difference in the criteria is detected).

In order to fix this problem invalidateCache() method is used in order to
force to do a datasource call keeping the current criteria.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/main/ob-standard-view.js
---
(0095886)
alostale (developer)
2017-04-07 08:39

core reviewed + tested
(0096862)
hudsonbot (developer)
2017-05-29 17:43

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/1ee70113bdc4 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2017-03-16 17:30 VictorVillar New Issue
2017-03-16 17:30 VictorVillar Assigned To => AugustoMauch
2017-03-16 17:30 VictorVillar Modules => Core
2017-03-16 17:30 VictorVillar Triggers an Emergency Pack => No
2017-03-20 12:38 VictorVillar Resolution time => 1492293600
2017-03-22 11:32 AugustoMauch Note Added: 0095498
2017-03-22 11:32 AugustoMauch Assigned To AugustoMauch => platform
2017-03-29 10:55 inigosanchez Assigned To platform => inigosanchez
2017-03-29 10:55 inigosanchez Status new => acknowledged
2017-03-29 18:15 VictorVillar Steps to Reproduce Updated View Revisions
2017-03-30 14:01 inigosanchez Note Added: 0095709
2017-03-30 18:48 inigosanchez Review Assigned To => alostale
2017-03-30 18:48 inigosanchez File Added: 35545.export
2017-03-30 18:49 inigosanchez Note Added: 0095738
2017-03-30 18:49 inigosanchez Status acknowledged => scheduled
2017-03-31 14:36 alostale Status scheduled => acknowledged
2017-04-04 14:04 inigosanchez Status acknowledged => scheduled
2017-04-04 14:07 hgbot Checkin
2017-04-04 14:07 hgbot Note Added: 0095823
2017-04-04 14:07 hgbot Status scheduled => resolved
2017-04-04 14:07 hgbot Resolution open => fixed
2017-04-04 14:07 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/1f63d7f9e0618c52fa8f9b4fae7d1350782d22d9 [^]
2017-04-07 08:39 alostale Note Added: 0095886
2017-04-07 08:39 alostale Status resolved => closed
2017-04-07 08:39 alostale Fixed in Version => 3.0PR17Q3
2017-05-29 17:43 hudsonbot Checkin
2017-05-29 17:43 hudsonbot Note Added: 0096862
2017-11-27 18:25 caristu Relationship added causes 0037399


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker