Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0037399
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminoralways2017-11-27 18:232018-01-03 12:39
ReportercaristuView Statuspublic 
Assigned Tocaristu 
PriorityimmediateResolutionfixedFixed in Version3.0PR18Q1
StatusclosedFix in branchFixed in SCM revision639a31dffd9c
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression levelProduction - QA Approved
Regression date2017-03-30
Regression introduced in release3.0PR17Q3
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/1f63d7f9e0618c52fa8f9b4fae7d1350782d22d9 [^]
Triggers an Emergency PackNo
Summary

0037399: Duplicated DS Request to the tree datasource having the tree view displayed in a sub-tab

DescriptionDuplicated DS Request to the tree datasource having the tree view displayed in a sub-tab
Steps To Reproduce1) Go to the [Account Tree] window
2) Select a record in the header and move to the "Element Value" sub-tab
3) Switch to the tree view mode
4) Go back to the header and select another record -> Notice that a double call is done for the tree DS (see attached image)
TagsPerformance
Attached Filespng file icon doubleTreeDSRequest.png [^] (143,293 bytes) 2017-11-27 18:23

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00374003.0PR17Q3.2 closedcaristu Duplicated DS Request to the tree datasource having the tree view displayed in a sub-tab 
depends on backport 00374293.0PR17Q4 closedcaristu Duplicated DS Request to the tree datasource having the tree view displayed in a sub-tab 
caused by defect 0035545 closedinigosanchez There is no tree view in a subtab under some circumstancies 

-  Notes
(0100746)
hgbot (developer)
2017-11-27 19:20

Repository: erp/devel/pi
Changeset: 639a31dffd9c7735ec06c156c836639408282931
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Mon Nov 27 19:16:22 2017 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/639a31dffd9c7735ec06c156c836639408282931 [^]

fixes bug 37399: Duplicated DS calls having the tree view shown in a sub-tab

  Fix for issue 0035545 was intended to force a datasource call when the fetchData does not perform it. This function has a mechanism that avoids DS calls when the grid criteria i not being changed.

  But when the criteria indeed changes two DS request was being fired: the one that we are forcing and the other one fired by the fetchData function. To avoid this problem we are forcing the DS call just when the grid criteria has not changed.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/main/ob-standard-view.js
---
(0100852)
alostale (developer)
2017-12-01 09:27

reviewed 6 tested
(0100880)
alostale (developer)
2017-12-01 10:08

reviewed + tested
(0101463)
hudsonbot (developer)
2018-01-03 12:39

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/c81e0d3cbab5 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2017-11-27 18:23 caristu New Issue
2017-11-27 18:23 caristu Assigned To => platform
2017-11-27 18:23 caristu File Added: doubleTreeDSRequest.png
2017-11-27 18:23 caristu Modules => Core
2017-11-27 18:23 caristu Triggers an Emergency Pack => No
2017-11-27 18:25 caristu Regression level => Production - QA Approved
2017-11-27 18:25 caristu Regression date => 2017-03-30
2017-11-27 18:25 caristu Regression introduced in release => 3.0PR17Q3
2017-11-27 18:25 caristu Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/1f63d7f9e0618c52fa8f9b4fae7d1350782d22d9 [^]
2017-11-27 18:25 caristu Relationship added caused by 0035545
2017-11-27 18:27 caristu Tag Attached: Performance
2017-11-27 18:27 caristu Assigned To platform => caristu
2017-11-27 18:27 caristu Status new => acknowledged
2017-11-27 18:28 caristu Status acknowledged => scheduled
2017-11-27 19:20 hgbot Checkin
2017-11-27 19:20 hgbot Note Added: 0100746
2017-11-27 19:20 hgbot Status scheduled => resolved
2017-11-27 19:20 hgbot Resolution open => fixed
2017-11-27 19:20 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/639a31dffd9c7735ec06c156c836639408282931 [^]
2017-11-27 19:21 caristu Review Assigned To => alostale
2017-12-01 09:27 alostale Note Added: 0100852
2017-12-01 09:27 alostale Status resolved => closed
2017-12-01 09:27 alostale Fixed in Version => 3.0PR18Q1
2017-12-01 09:44 alostale Status closed => new
2017-12-01 09:44 alostale Resolution fixed => open
2017-12-01 09:44 alostale Fixed in Version 3.0PR18Q1 =>
2017-12-01 09:44 alostale Status new => scheduled
2017-12-01 09:44 alostale Status scheduled => resolved
2017-12-01 09:44 alostale Fixed in Version => 3.0PR18Q1
2017-12-01 09:44 alostale Resolution open => fixed
2017-12-01 10:08 alostale Note Added: 0100880
2017-12-01 10:08 alostale Status resolved => closed
2018-01-03 12:39 hudsonbot Checkin
2018-01-03 12:39 hudsonbot Note Added: 0101463


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker