Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0035539
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 07. Sales managementmajoralways2017-03-16 11:542017-03-25 01:51
ReporterngarciaView Statuspublic 
Assigned Tomcobas 
PriorityurgentResolutionfixedFixed in Version3.0PR17Q2
StatusclosedFix in branchFixed in SCM revision595d854767a2
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toaferraz
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0035539: Delivered Sales Order Report is showing the business partner only when the sales order is associated with a project

DescriptionDelivered Sales Order Report is showing the business partner only when the sales order is associated with a project.

The problem is that the link between c_order and c_bpartner tables is made by the c_project table

c_order -> c_project -> c_bpartner
Steps To ReproduceAs group admin role:
   Create a sales order
   Create shipment from orders from it
   Launch the Delivered Sales Order Report:
      From Date: sales order date
      To Date: sales order date
   Check the Business Partner name is not shown in the Business Partner title
   Launch the report again by filtering by the sales order business partner
   Check the report is shown empty
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0095533)
mcobas (developer)
2017-03-23 15:21

Test Plan A
1. Create a sales order.
2. Create a Good Shipment using previous order.
3. Launch the Delivered Sales Order Report:
   From Date: sales order date
   To Date: sales order date
4. Notice that Business Partner name is shown in the Business Partner title.

Test Plan B
1. Create a sales order.
2. Create a Good Shipment using previous order.
3. Launch the Delivered Sales Order Report:
   From Date: sales order date
   To Date: sales order date
4. Notice that Business Partner name is shown in the Business Partner title of both Delivered.
5. Launch the report again by filtering by the sales order business partner.
6. Notice that Business Partner name is shown in the Business Partner title.
(0095548)
hgbot (developer)
2017-03-23 18:03

Repository: erp/devel/pi
Changeset: 595d854767a230ff40ace21f8720c245d1e81990
Author: Miguel <martencobasmiguel <at> gmail.com>
Date: Mon Mar 20 14:07:23 2017 -0400
URL: http://code.openbravo.com/erp/devel/pi/rev/595d854767a230ff40ace21f8720c245d1e81990 [^]

Fixes issue 35539: Delivered Sales Order Report is not showing business partner

The problem is that the link between c_order and c_bpartner tables is made by
the c_project table and in cases where the sales order is not related to a
project, the relationship between c_project and c_bpartner is going to return
null, causing it to be impossible to obtain the information of the
business partner.

To solve this problem the union is established between the tables c_order
and c_bdpartner.

---
M src/org/openbravo/erpCommon/ad_reports/ReportSalesOrderProvided_data.xsql
---
(0095549)
hgbot (developer)
2017-03-23 18:03

Repository: erp/devel/pi
Changeset: defaa5739e3fbb1a564bfdb310f30a8b59b0cb2f
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Thu Mar 23 17:54:38 2017 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/defaa5739e3fbb1a564bfdb310f30a8b59b0cb2f [^]

Related to issue 35539: Code review improvements

Join with C_BPARTNER_LOCATION table done using C_ORDER table instead of C_PROJECT table.

---
M src/org/openbravo/erpCommon/ad_reports/ReportSalesOrderProvided_data.xsql
---
(0095550)
aferraz (developer)
2017-03-23 18:04

Code review + Testing OK
(0095578)
hudsonbot (developer)
2017-03-25 01:51

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/a169bf5db5fd [^]
Maturity status: Test
(0095579)
hudsonbot (developer)
2017-03-25 01:51

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/a169bf5db5fd [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2017-03-16 11:54 ngarcia New Issue
2017-03-16 11:54 ngarcia Assigned To => Triage Finance
2017-03-16 11:54 ngarcia Modules => Core
2017-03-16 11:54 ngarcia Triggers an Emergency Pack => No
2017-03-16 11:55 ngarcia Issue Monitored: networkb
2017-03-16 19:36 markmm82 Assigned To Triage Finance => mcobas
2017-03-20 19:27 mcobas Status new => scheduled
2017-03-23 15:21 mcobas Note Added: 0095533
2017-03-23 18:03 hgbot Checkin
2017-03-23 18:03 hgbot Note Added: 0095548
2017-03-23 18:03 hgbot Status scheduled => resolved
2017-03-23 18:03 hgbot Resolution open => fixed
2017-03-23 18:03 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/595d854767a230ff40ace21f8720c245d1e81990 [^]
2017-03-23 18:03 hgbot Checkin
2017-03-23 18:03 hgbot Note Added: 0095549
2017-03-23 18:04 aferraz Review Assigned To => aferraz
2017-03-23 18:04 aferraz Note Added: 0095550
2017-03-23 18:04 aferraz Status resolved => closed
2017-03-23 18:04 aferraz Fixed in Version => 3.0PR17Q2
2017-03-25 01:51 hudsonbot Checkin
2017-03-25 01:51 hudsonbot Note Added: 0095578
2017-03-25 01:51 hudsonbot Checkin
2017-03-25 01:51 hudsonbot Note Added: 0095579


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker