Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0035434
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 09. Financial managementminoralways2017-03-06 12:192017-03-20 15:11
ReporteraferrazView Statuspublic 
Assigned Toaferraz 
PriorityimmediateResolutionfixedFixed in Version3.0PR17Q2
StatusclosedFix in branchFixed in SCM revisionb0e68131dd07
ProjectionnoneETAnoneTarget Version3.0PR17Q2
OSLinux 64 bitDatabasePostgreSQLJava version1.6.0_18
OS VersionProfessional ApplianceDatabase version8.3.9Ant version1.7.1
Product VersionSCM revision 
Review Assigned Tovmromanos
Web browser
ModulesCore
Regression levelPre packaging ( pi )
Regression date2017-03-03
Regression introduced in releasepi
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/86dcf5d294d9 [^]
Triggers an Emergency PackNo
Summary

0035434: Manual taxes deleted when reactivating a price including taxes invoice

DescriptionManual taxes deleted when reactivating a price including taxes invoice
Steps To ReproduceAs QA Admin role:
- Create a Sales Invoice with Price Including Taxes Sales price list.
- Add a line with any tax.
- Add a manual tax in Tax tab.
- Complete the invoice and check there are two records in Tax tab.
- Reactivate the invoice and check the manual created tax (Recalculate = N) in Tax tab has been removed.

The following flow is also failing:

As QA Admin role:
- Create a Sales Invoice with Price Including Taxes Sales price list.
- Add a manual tax in Tax tab with TaxAmt<>0 and TaxBaseAmt<>0.
- Add a line with a different tax than manual tax.
- Check Total Net Amount is wrong.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
caused by design defect 0032265 closedaferraz [SER QA 1434] Taxes at document level are not properly calculated in some cases 

-  Notes
(0094767)
hgbot (developer)
2017-03-06 13:57

Repository: erp/devel/pi
Changeset: b0e68131dd0747e6b671f418be02daac8512c80c
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Mon Mar 06 13:56:27 2017 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/b0e68131dd0747e6b671f418be02daac8512c80c [^]

Fixes issue 35434: Manual taxes deleted when reactivating a PIT invoice

Now when reactivating a price including taxes invoice, manual taxes will not be deleted, and invoice gross amount will be updated to the sum of tax amounts of the manual taxes instead of zero.
Also, when calculating invoice gross and net amounts in invoice line trigger, manual taxes will be taken into account when getting the sum of tax amounts but not for getting the sum of tax base amounts.

---
M src-db/database/model/functions/C_INVOICE_POST.xml
M src-db/database/model/triggers/C_INVOICELINE_TRG2.xml
---
(0095273)
hudsonbot (developer)
2017-03-15 20:21

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/54e102bef53e [^]
Maturity status: Test
(0095428)
vmromanos (developer)
2017-03-20 15:11

Code review OK

- Issue History
Date Modified Username Field Change
2017-03-06 12:19 aferraz New Issue
2017-03-06 12:19 aferraz Assigned To => aferraz
2017-03-06 12:19 aferraz Modules => Core
2017-03-06 12:19 aferraz Regression introduced in release => pi
2017-03-06 12:19 aferraz Triggers an Emergency Pack => No
2017-03-06 12:19 aferraz Relationship added caused by 0032265
2017-03-06 12:31 aferraz Regression level => Pre packaging ( pi )
2017-03-06 12:31 aferraz Regression date => 2017-03-03
2017-03-06 12:31 aferraz Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/86dcf5d294d9 [^]
2017-03-06 13:25 aferraz Steps to Reproduce Updated View Revisions
2017-03-06 13:57 hgbot Checkin
2017-03-06 13:57 hgbot Note Added: 0094767
2017-03-06 13:57 hgbot Status new => resolved
2017-03-06 13:57 hgbot Resolution open => fixed
2017-03-06 13:57 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/b0e68131dd0747e6b671f418be02daac8512c80c [^]
2017-03-15 20:21 hudsonbot Checkin
2017-03-15 20:21 hudsonbot Note Added: 0095273
2017-03-20 15:11 vmromanos Review Assigned To => vmromanos
2017-03-20 15:11 vmromanos Note Added: 0095428
2017-03-20 15:11 vmromanos Status resolved => closed
2017-03-20 15:11 vmromanos Fixed in Version => 3.0PR17Q2


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker