Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0035433
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 09. Financial managementmajoralways2017-03-06 11:312017-05-29 17:43
ReportervmromanosView Statuspublic 
Assigned Tononofrancisco 
PrioritynormalResolutionfixedFixed in Version3.0PR17Q3
StatusclosedFix in branchFixed in SCM revision04a655291985
ProjectionnoneETAnoneTarget Version3.0PR17Q3
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toaferraz
Web browser
ModulesCore
Regression levelPackaging and release
Regression date2017-02-23
Regression introduced in releasemain
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/251ea8a24d39 [^]
Triggers an Emergency PackNo
Summary

0035433: Payables and Receivable Aging Balance Organization and General Ledger fields

DescriptionSeveral problems in Organization and General Ledger Filters in both Payables and Receivables Aging Schedule Reports.

Organization:
1. Validation similar to "AD_Org is transactions allowed" should be added

General Ledger:
1. Add validation to show only general ledgers available for the selected organization. The values should be updated each time the organization is changed.
Steps To ReproduceAs Openbravo Admin

Go to Payables Aging Schedule report (or Receivables Aging Schedule)
Verify * organization can be selected. This is wrong as this organization can't have transactions
Change org to F&B US.
Verify General Ledger "F&B España" is shown in selector. This is wrong as this general ledger is not available for F&B US
Proposed SolutionReview original code in legacy Aging Balance module and transplant it to the version in core for both reports.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00325353.0PR16Q3 closedmarkmm82 Report's currency and report's general ledger should be defaulted to organization's currency and organization's general ledger 
depends on backport 00356983.0PR17Q2 closednonofrancisco Payables and Receivable Aging Balance Organization and General Ledger fields 
caused by feature request 00350893.0PR17Q2 closednonofrancisco Integrate module Aging Balance Report into Openbravo 3 distribution 
related to feature request 0036034 newTriage Finance Improve organization and general ledger parameters default value and on change function inside Aging process definition 

-  Notes
(0095304)
nonofrancisco (developer)
2017-03-15 21:25

Test plan:

As Openbravo Admin

Go to Payables Aging Schedule report
Verify * organization does not appears in selector, just organizations with transaction allowed can be selected.
Change org to F&B US.
Verify just General Ledger "F&B International Group US/A/US Dollar" is shown in selector.
Change org to F&B España - Región Norte.
Verify General Ledger "F&B International Group US/A/US Dollar" and "F&B España, S.A. US/A/Euro" are shown in selector.

Do the same for Receivables Aging Schedule
Verify the behavior is the same
(0096648)
hgbot (developer)
2017-05-17 21:49

Repository: erp/devel/pi
Changeset: 04a6552919851945d8ca428fc012d40c7f9a9020
Author: Nono Carballo <nonofce <at> gmail.com>
Date: Tue May 09 13:28:14 2017 -0400
URL: http://code.openbravo.com/erp/devel/pi/rev/04a6552919851945d8ca428fc012d40c7f9a9020 [^]

Fixes issue 35433: Aging Balance Organization and GL fields

* The default value of parameter Organization is the one selected when login,
if is transaction allowed, otherwise, the first one in the list of Organizations
with transaction allowed.

* When parameter Organization changes, the selected value of General Ledger
selector is set accordingly.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/utilities/ob-onchange-functions.js
M src-db/database/sourcedata/OBUIAPP_PARAMETER.xml
M src-db/database/sourcedata/OBUISEL_SELECTOR.xml
A src/org/openbravo/common/actionhandler/AgingGeneralLedgerByOrganizationActionHandler.java
A src/org/openbravo/common/filterexpression/AgingGeneralLedgerFilterExpression.java
A src/org/openbravo/common/filterexpression/AgingOrganizationFilterExpression.java
---
(0096649)
hgbot (developer)
2017-05-17 21:50

Repository: erp/devel/pi
Changeset: b069f040ba1098f708ce1c3802488ca14211d8ba
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Wed May 17 21:46:10 2017 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/b069f040ba1098f708ce1c3802488ca14211d8ba [^]

Related to issue 35433: Code review improvements

- Fix copyrights.
- Improve Account Schema Selector filter expression.
- Improve AgingOrganizationFilterExpression class.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/utilities/ob-onchange-functions.js
M src-db/database/sourcedata/OBUISEL_SELECTOR.xml
M src/org/openbravo/common/actionhandler/AgingGeneralLedgerByOrganizationActionHandler.java
M src/org/openbravo/common/filterexpression/AgingGeneralLedgerFilterExpression.java
M src/org/openbravo/common/filterexpression/AgingOrganizationFilterExpression.java
---
(0096650)
aferraz (developer)
2017-05-17 21:55

Code review + Testing OK
(0096972)
hudsonbot (developer)
2017-05-29 17:43

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/1ee70113bdc4 [^]
Maturity status: Test
(0096973)
hudsonbot (developer)
2017-05-29 17:43

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/1ee70113bdc4 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2017-03-06 11:31 vmromanos New Issue
2017-03-06 11:31 vmromanos Assigned To => Triage Finance
2017-03-06 11:31 vmromanos Modules => Core
2017-03-06 11:31 vmromanos Triggers an Emergency Pack => No
2017-03-06 11:31 vmromanos Assigned To Triage Finance => nonofrancisco
2017-03-06 11:34 vmromanos Relationship added caused by 0035089
2017-03-15 21:09 nonofrancisco Status new => scheduled
2017-03-15 21:25 nonofrancisco Note Added: 0095304
2017-03-30 16:51 aferraz Relationship added related to 0032535
2017-03-30 17:08 aferraz Target Version 3.0PR17Q2 => 3.0PR17Q2.1
2017-04-05 09:14 vmromanos Status scheduled => acknowledged
2017-04-05 09:14 vmromanos Target Version 3.0PR17Q2.1 => 3.0PR17Q3
2017-04-05 09:15 vmromanos Status acknowledged => scheduled
2017-05-17 21:49 hgbot Checkin
2017-05-17 21:49 hgbot Note Added: 0096648
2017-05-17 21:49 hgbot Status scheduled => resolved
2017-05-17 21:49 hgbot Resolution open => fixed
2017-05-17 21:49 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/04a6552919851945d8ca428fc012d40c7f9a9020 [^]
2017-05-17 21:50 hgbot Checkin
2017-05-17 21:50 hgbot Note Added: 0096649
2017-05-17 21:52 aferraz Regression level => Packaging and release
2017-05-17 21:52 aferraz Regression date => 2017-02-23
2017-05-17 21:52 aferraz Regression introduced in release => main
2017-05-17 21:52 aferraz Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/251ea8a24d39 [^]
2017-05-17 21:55 aferraz Review Assigned To => aferraz
2017-05-17 21:55 aferraz Note Added: 0096650
2017-05-17 21:55 aferraz Status resolved => closed
2017-05-17 21:55 aferraz Fixed in Version => 3.0PR17Q3
2017-05-18 10:16 aferraz Relationship added related to 0036034
2017-05-29 17:43 hudsonbot Checkin
2017-05-29 17:43 hudsonbot Note Added: 0096972
2017-05-29 17:43 hudsonbot Checkin
2017-05-29 17:43 hudsonbot Note Added: 0096973


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker