Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0035426
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminorsometimes2017-03-03 11:392017-03-15 20:22
ReporterJONHMView Statuspublic 
Assigned Toinigosanchez 
PrioritynormalResolutionfixedFixed in Version3.0PR17Q2
StatusclosedFix in branchFixed in SCM revision1eb8d1da9bb9
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tocaristu
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date
Regression introduced in release3.0PR16Q1.3
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/92802596bf940d3c62c8e84547ea21e78055c0fc [^]
Triggers an Emergency PackNo
Summary

0035426: Adaptive filtering capability does not work for Table references.

DescriptionAdaptive filtering capability (filter in client when all data is locally available) does not work for Table references when filtering by text instead of by selecting a value in the drop down list.
Steps To ReproduceAs 'F&B International Group Admin' Role:
1) Open [Business Partner] window.
2) Write 'EUR' in Currency column and press enter button or click elsewhere
--> The data is not filtered properly.
3) Click refresh button.
--> The data is filtered properly because in this case adaptive filtering is not used.

Note: On one hand 'Currency' field (Reference Table) is not filtering properly. On the other hand, 'Business Partner Category' field (Reference TableDir) is filtering properly.
TagsNo tags attached.
Attached Files? file icon noFilterNullValues.mp4 [^] (2,149,200 bytes) 2017-03-03 11:39

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00354643.0PR17Q1 closedinigosanchez Adaptive filtering capability does not work for Table references. 
depends on backport 00354653.0PR16Q4.4 closedinigosanchez Adaptive filtering capability does not work for Table references. 
depends on backport 00354663.0PR16Q3.6 closedinigosanchez Adaptive filtering capability does not work for Table references. 
caused by defect 0030800 closedcaristu Filter on Property field in a table reference column doesn't work 

-  Notes
(0094898)
hgbot (developer)
2017-03-10 10:16

Repository: erp/devel/pi
Changeset: 1eb8d1da9bb9ce7a5fe437518953c4cbe150ae44
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Fri Mar 10 10:15:36 2017 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/1eb8d1da9bb9ce7a5fe437518953c4cbe150ae44 [^]

Fixed issue 35426: Adaptive filtering does not work for Table references.

The problem was that adaptive filtering (filter in client when all data is locally available) did
not work for Table references when filtering by text instead of by selecting a value in the drop
down list. The issue that causes this regression was not taking into account adaptive filtering.

This problem has been fixed by taking into account this case in getDisplayProperty method. Now
getDisplayProperty method manages properly when all the data are in the client (Adaptive filtering).

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-fk-filter.js
---
(0094899)
inigosanchez (developer)
2017-03-10 10:20

Several manual test can be found here: https://docs.google.com/a/openbravo.com/spreadsheets/d/1LhUQG2Yvs7ZaRyILhNnginbiBFvpDNiydHIFivVYkEs/edit?usp=sharing [^]

Pending to add an automatic test in pi-smoke-platform.
(0094921)
hgbot (developer)
2017-03-10 14:38

Repository: erp/devel/pi
Changeset: 5e4e6352a9f740fca721ac0aa04a7d9d9e1c4ef4
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Fri Mar 10 14:37:32 2017 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/5e4e6352a9f740fca721ac0aa04a7d9d9e1c4ef4 [^]

related to issue 35426: improved comments

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-fk-filter.js
---
(0094922)
caristu (developer)
2017-03-10 14:39

Code review + tested OK.

Filtering by a column based on a Table reference is working both in client and server side.
(0095284)
hudsonbot (developer)
2017-03-15 20:21

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/54e102bef53e [^]
Maturity status: Test
(0095289)
hudsonbot (developer)
2017-03-15 20:22

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/54e102bef53e [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2017-03-03 11:39 JONHM New Issue
2017-03-03 11:39 JONHM Assigned To => platform
2017-03-03 11:39 JONHM File Added: noFilterNullValues.mp4
2017-03-03 11:39 JONHM Modules => Core
2017-03-03 11:39 JONHM Regression introduced in release => 3.0PR15Q4.6
2017-03-03 11:39 JONHM Triggers an Emergency Pack => No
2017-03-03 13:21 heccam Issue Monitored: heccam
2017-03-07 11:43 inigosanchez Status new => scheduled
2017-03-07 11:43 inigosanchez Assigned To platform => inigosanchez
2017-03-07 15:48 inigosanchez Regression level => Production - Confirmed Stable
2017-03-07 15:48 inigosanchez Regression introduced in release 3.0PR15Q4.6 => 3.0PR16Q1.3
2017-03-07 15:48 inigosanchez Summary Fields are not automatically filtered if contains null values => Adaptive filtering capability does not work under some circumstances.
2017-03-07 15:48 inigosanchez Description Updated View Revisions
2017-03-07 15:48 inigosanchez Steps to Reproduce Updated View Revisions
2017-03-07 17:32 inigosanchez Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/92802596bf940d3c62c8e84547ea21e78055c0fc [^]
2017-03-07 17:33 inigosanchez Summary Adaptive filtering capability does not work under some circumstances. => Adaptive filtering capability does not work for Table references.
2017-03-07 17:33 inigosanchez Description Updated View Revisions
2017-03-07 17:34 inigosanchez Relationship added caused by 0030800
2017-03-09 12:23 inigosanchez Status scheduled => acknowledged
2017-03-09 12:24 inigosanchez Status acknowledged => scheduled
2017-03-10 08:54 alostale Description Updated View Revisions
2017-03-10 08:54 alostale Description Updated View Revisions
2017-03-10 10:08 inigosanchez Review Assigned To => caristu
2017-03-10 10:16 hgbot Checkin
2017-03-10 10:16 hgbot Note Added: 0094898
2017-03-10 10:16 hgbot Status scheduled => resolved
2017-03-10 10:16 hgbot Resolution open => fixed
2017-03-10 10:16 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/1eb8d1da9bb9ce7a5fe437518953c4cbe150ae44 [^]
2017-03-10 10:20 inigosanchez Note Added: 0094899
2017-03-10 14:38 hgbot Checkin
2017-03-10 14:38 hgbot Note Added: 0094921
2017-03-10 14:39 caristu Note Added: 0094922
2017-03-10 14:39 caristu Status resolved => closed
2017-03-10 14:39 caristu Fixed in Version => 3.0PR17Q2
2017-03-15 20:21 hudsonbot Checkin
2017-03-15 20:21 hudsonbot Note Added: 0095284
2017-03-15 20:22 hudsonbot Checkin
2017-03-15 20:22 hudsonbot Note Added: 0095289


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker