Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0035080
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 04. Warehouse managementmajoralways2017-01-30 10:472017-03-15 20:18
ReporterngarciaView Statuspublic 
Assigned Tocollazoandy4 
PriorityimmediateResolutionfixedFixed in Version3.0PR17Q2
StatusclosedFix in branchFixed in SCM revision1c5c1be850c7
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tomarkmm82
Web browser
ModulesCore
Regression levelProduction - QA Approved
Regression date2016-07-01
Regression introduced in release3.0PR16Q4
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/a1ae555f0807 [^]
Triggers an Emergency PackNo
Summary

0035080: Cannot set an attribute set value in a warehouse document line in case it does not contain an instance attribute

DescriptionCannot set an attribute set value in a warehouse document line in case it does not contain an instance attribute. The attribute sets set as Lot, Serial No, or Expiration Date are also instance attributes.
Steps To ReproduceAs group admin role:
   Create a new Attribute
      Instance Attribute: N
      List: N
      Mandatory: Y
   Create a new Attribute Set
      Lot: N
      Serial No.: N
      Expiration Date: N
   Add the previously created attribute to it
   Create a new product and assign the previously created attribute set to it
   Create a Goods Receipt, add the previously created product and check the Attribute Set Value field is shown
   Open it and add a value to its attribute
   Check the value is not shown when closing the pop-up
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0035081 closedcollazoandy4 Wrong behaviour when the attribute included in an attribute set is named lot, serno or DateFrom 
depends on backport 00350923.0PR17Q1 closedcollazoandy4 Cannot set an attribute set value in a warehouse document line in case it does not contain an instance attribute 
depends on backport 00350933.0PR16Q4.3 closedcollazoandy4 Cannot set an attribute set value in a warehouse document line in case it does not contain an instance attribute 
caused by defect 0033296 closedSanjota The information on the attribute value set on inventory line is not properly shown. 

-  Notes
(0093968)
collazoandy4 (developer)
2017-01-31 19:15

Test Plan 1:

As F&B International Group Admin Role:
  - Go to Attribute window
        Create a new Record
         Name: Attribute
      Instance Attribute: N
      List: N
      Mandatory: Y
  - Go to Attribute Set window
     Create a new Record
      Name: Attribute set
      Lot: N
      Serial No.: N
      Expiration Date: N
     Create a new Line
      Attribute: Attribute
  - Go to product window
     Create a new Record
      Search key / Name : Product
      Attribute set: Attribute set
  - Go to Goods Receipt window
     Create a new Record
       BP: Bebidas Alegres. S.A
     Create a new Line
       Product: Product
       Atribute set value: value
  Check the value is shown when closing the Pop up

Test Plan 2

- Create a new attribute set.
   name: name1
   Lot = N
   serial no = N
   expiration date = Y
   requite at least one value = N

- Create a new product and assign the attribute set created previously

- Make a goods receipt
   Create one line with the previous product and without select the attribute set value
   Create another line with the same product by defining on the attribute set an expiration date
   Create another line with the same product. ON that case open the attribute set selector and click ok without filling the data.

- Process the goods receipt

- Create a physical inventory and click on the process "create inventory count list"

- See that there will be 2 entries for the product used on the previous goods receipt. ONe have the attribute set defined and the other entry will have sum of qty of 2 GR lines that don't have attribute set value.
(0093996)
hgbot (developer)
2017-02-01 19:10

Repository: erp/devel/pi
Changeset: 1c5c1be850c787430a2ec9650afc786517b6433a
Author: Armaignac <collazoandy4 <at> gmail.com>
Date: Tue Jan 31 11:19:49 2017 -0500
URL: http://code.openbravo.com/erp/devel/pi/rev/1c5c1be850c787430a2ec9650afc786517b6433a [^]

Fixes issue 35080: Set value in a warehouse document line with empty attribute

In a warehouse document line now can set value in a warehouse document line in case
it does not contain an instance attribute

---
M src/org/openbravo/erpCommon/info/AttributeSetInstance.java
---
(0094002)
markmm82 (developer)
2017-02-01 19:21

Code review + Testing OK
(0094578)
plujan (manager)
2017-02-23 16:30

16Q4 has not been promoted to confirmed stable yet so I am changing the regression level back to QA Approved.
(0095150)
hudsonbot (developer)
2017-03-15 20:18

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/54e102bef53e [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2017-01-30 10:47 ngarcia New Issue
2017-01-30 10:47 ngarcia Assigned To => Triage Finance
2017-01-30 10:47 ngarcia Modules => Core
2017-01-30 10:47 ngarcia Resolution time => 1487545200
2017-01-30 10:47 ngarcia Triggers an Emergency Pack => No
2017-01-30 10:48 ngarcia Issue Monitored: networkb
2017-01-30 10:48 ngarcia Relationship added caused by 0033296
2017-01-30 10:57 ngarcia Relationship added related to 0035081
2017-01-30 15:54 markmm82 Assigned To Triage Finance => collazoandy4
2017-01-30 22:07 collazoandy4 Status new => scheduled
2017-01-30 22:15 collazoandy4 Regression level => Production - Confirmed Stable
2017-01-30 22:15 collazoandy4 Regression date => 2016-07-01
2017-01-30 22:15 collazoandy4 Regression introduced in release => 3.0PR16Q4
2017-01-30 22:15 collazoandy4 Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/a1ae555f0807 [^]
2017-01-31 19:15 collazoandy4 Note Added: 0093968
2017-02-01 19:10 hgbot Checkin
2017-02-01 19:10 hgbot Note Added: 0093996
2017-02-01 19:10 hgbot Status scheduled => resolved
2017-02-01 19:10 hgbot Resolution open => fixed
2017-02-01 19:10 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/1c5c1be850c787430a2ec9650afc786517b6433a [^]
2017-02-01 19:21 markmm82 Review Assigned To => markmm82
2017-02-01 19:21 markmm82 Note Added: 0094002
2017-02-01 19:21 markmm82 Status resolved => closed
2017-02-01 19:21 markmm82 Fixed in Version => 3.0PR17Q2
2017-02-23 16:30 plujan Regression level Production - Confirmed Stable => Production - QA Approved
2017-02-23 16:30 plujan Note Added: 0094578
2017-03-15 20:18 hudsonbot Checkin
2017-03-15 20:18 hudsonbot Note Added: 0095150


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker