Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0033296
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 04. Warehouse managementmajoralways2016-06-16 19:162016-08-11 18:40
ReporteregoitzView Statuspublic 
Assigned ToSanjota 
PriorityurgentResolutionfixedFixed in Version3.0PR16Q4
StatusclosedFix in branchFixed in SCM revisiona1ae555f0807
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toaferraz
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0033296: The information on the attribute value set on inventory line is not properly shown.

DescriptionThe information on the attribute value set on inventory line is not properly shown.
Steps To Reproduce- Create a new attribute set.
   name: name1
   Lot = N
   serial no = N
   expiration date = Y
   requite at least one value = N

- Create a new product and assign the attribute set created previously

- Make a goods receipt
   Create one line with the previous product and without select the attribute set value
   Create another line with the same product by defining on the attribute set an expiration date
   Create another line with the same product. ON that case open the attribute set selector and click ok without filling the data.

- Process the goods receipt

- Create a physical inventory and click on the process "create inventory count list"

- See that there are 3 entries for the product used on the previous goods receipt. ONe have the attribute set defined and the other 2 on grid mode have not attribute set value.
If you enter on form view you will see that one has not attribute value but the other shows the id of teh attribute set instance id. That one for the goods receipt line where the expiration date was not defined on the attribute selector.

TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0033374 newTriage Finance "Require at least one value" field expects any one value to be set in attribute set 
causes defect 0035080 closedcollazoandy4 Cannot set an attribute set value in a warehouse document line in case it does not contain an instance attribute 

-  Notes
(0088060)
Sanjota (developer)
2016-06-28 18:11

Test Plan:
- Create a new attribute set.
   name: name1
   Lot = N
   serial no = N
   expiration date = Y
   requite at least one value = N

- Create a new product and assign the attribute set created previously

- Make a goods receipt
   Create one line with the previous product and without select the attribute set value
   Create another line with the same product by defining on the attribute set an expiration date
   Create another line with the same product. ON that case open the attribute set selector and click ok without filling the data.

- Process the goods receipt

- Create a physical inventory and click on the process "create inventory count list"

- See that there will be 2 entries for the product used on the previous goods receipt. ONe have the attribute set defined and the other entry will have sum of qty of 2 GR lines that don't have attribute set value.
(0088151)
hgbot (developer)
2016-07-01 13:26

Repository: erp/devel/pi
Changeset: a1ae555f0807cbeec6deada354543c485140bb90
Author: Sanjota <sanjota.nelagi <at> promantia.com>
Date: Tue Jun 28 18:17:20 2016 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/a1ae555f0807cbeec6deada354543c485140bb90 [^]

Fixes issue 33296: Fix to value attributeSetValue on inventoryline is incorrect

Fixed issue related to,the information on the attribute value set on inventory line is not properly shown, which was due to GR attribute set value creation.

---
M src/org/openbravo/erpCommon/info/AttributeSetInstance.java
---
(0088152)
hgbot (developer)
2016-07-01 13:26

Repository: erp/devel/pi
Changeset: 291e57012457eb90e2b28a600fcef13d2e369a9e
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Fri Jul 01 13:06:12 2016 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/291e57012457eb90e2b28a600fcef13d2e369a9e [^]

Related to issue 33296: Code review improvements

---
M src/org/openbravo/erpCommon/info/AttributeSetInstance.java
---
(0088153)
aferraz (developer)
2016-07-01 13:27

Code review + Testing OK
(0088981)
hudsonbot (developer)
2016-08-11 18:40

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/edaa05b1fb18 [^]
Maturity status: Test
(0088982)
hudsonbot (developer)
2016-08-11 18:40

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/edaa05b1fb18 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2016-06-16 19:16 egoitz New Issue
2016-06-16 19:16 egoitz Assigned To => Triage Finance
2016-06-16 19:16 egoitz Modules => Core
2016-06-16 19:16 egoitz Resolution time => 1467842400
2016-06-16 19:16 egoitz Triggers an Emergency Pack => No
2016-06-17 14:58 aferraz Assigned To Triage Finance => markmm82
2016-06-27 11:39 Sanjota Assigned To markmm82 => Sanjota
2016-06-27 11:39 Sanjota Status new => scheduled
2016-06-28 18:11 Sanjota Note Added: 0088060
2016-06-28 18:28 Sanjota Relationship added related to 0033374
2016-07-01 13:26 hgbot Checkin
2016-07-01 13:26 hgbot Note Added: 0088151
2016-07-01 13:26 hgbot Status scheduled => resolved
2016-07-01 13:26 hgbot Resolution open => fixed
2016-07-01 13:26 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/a1ae555f0807cbeec6deada354543c485140bb90 [^]
2016-07-01 13:26 hgbot Checkin
2016-07-01 13:26 hgbot Note Added: 0088152
2016-07-01 13:27 aferraz Review Assigned To => aferraz
2016-07-01 13:27 aferraz Note Added: 0088153
2016-07-01 13:27 aferraz Status resolved => closed
2016-07-01 13:27 aferraz Fixed in Version => 3.0PR16Q4
2016-08-11 18:40 hudsonbot Checkin
2016-08-11 18:40 hudsonbot Note Added: 0088981
2016-08-11 18:40 hudsonbot Checkin
2016-08-11 18:40 hudsonbot Note Added: 0088982
2017-01-30 10:48 ngarcia Relationship added causes 0035080


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker